locked
MSI Failed to connect to server. Error: 0x800703FA from SQL Server setup run by a domain service account with local admin. RRS feed

  • Question

  • Hi, I am trying to install sql server patches from another service locally and while it was just working fine on DEV we do have issues on test even thou a local admin perm has been granted. The problem I am having is that the installer app is unable to connect to the msiserver from our  domain service test account, still it works fine with another domain service account (also having local admin)

    === Verbose logging started: 10/09/2019  14:49:59  Build type: SHIP UNICODE 5.00.9600.00  Calling process: D:\0000000082_LABMS07307_DMGBVSQL01_13.0.5382.0\x64\ScenarioEngine.exe ===
    ...
    MSI (c) (20:B8) [14:49:59:056]: Client-side and UI is none or basic: Running entire install on the server.
    MSI (c) (20:B8) [14:49:59:056]: Grabbed execution mutex.
    MSI (c) (20:B8) [14:49:59:056]: Failed to connect to server. Error: 0x800703FA
    ...


    I have went as far a disassembling the ScenarioEngine.exe from sql server to see how it does the msi install (it uses pinvoke on msi.dll) and created a simmilar app just for testing but my app does not have any problems installing the test msi (same msi fails from ScenarioEngine.exe).

    So I presume there must be some exotic permission that is required by the way ScenarioEngine.exe works with msi.dll but I have no way of finding out what it is.

    I did try extending the logging on msiserver, adding debug etc. Have checked the windows event logs and all.
    Anyone had issues like this ?

    Tuesday, September 10, 2019 1:56 PM

Answers