Shared folder "Acess Denied" RRS feed

  • Question

  • Double-clicking the Shared Folders icon on the desktop, I go to a folder that I have always had access to, and I now get a error message of 'access denied, you do not have permission'.  I then go to the WHS Console, and go to the Shared Folders tab to check out it's properties and see that every user has full access to that specific folder that I was denied access to, I don't have a issue with any other of the shared folders.  I then decide to try and 'reset' permissions by setting access to 'none' for everyone.  I then try and access that folder again, and obviously I get the same error message.  I go back and change it back to 'full access' for everyone and try to access it again, still no go.  I then try all the above and when I do it I restart the server and all computers that have access to the server after I did it to see if that helps.  Still no go.... I try and go to the shared folder from more than 1 of my computers that have access to the server.  I'm running the current version of WHS, two computers are running WIN7, and 1 XP.
    Tuesday, August 31, 2010 7:12 PM

All replies

  • I would say the access for this shared folder was mixed up somehow.
    Best you can do is to copy off all data for this share and delete it using the console. Then re-create the share and copy data back.

    As none of your other shares have problems this will probably solve your problem.
    - Theo.


    No home server like Home Server
    Wednesday, September 1, 2010 5:59 PM
  • I've seen the same thing when creating new shares, but not with the existing ones dropping access. Usually rebooting and waiting an hour or so will fix the problem, but obviously not in your case.

    What I would do s to use the web logon and check if able to access that folder from the web site. If you're able to access it there it seems more like a client issue rather than a share permission issue.

    Friday, September 3, 2010 7:04 AM
  • There's an issue where this error message is a red herring.  It comes from the file names in the folder.  You'll have a perfectly working share until you copy some "bad" file/folder into it.  Bingo, no more access except locally.  You can test if this is the case by doing this:

    1)  Enable remote desktop on the file server, if it's not already setup.

    2)  Go to the shared folder and made a temporary folder.  Something like "New Folder".

    3)  Move ALL the files in the folder that can't be accessed anymore into that one.

    4)  See if the other PCs can access the share again.  If so, you've identified the problem.  No amount of permissions editing will fix this.

    5)  Just for kicks, try accessing the "New Folder" and it'll fail.

    I'll get a link to the solution in a second.  It's damn stupid bug but there's supposed to be a registry workaround.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem has the 8.3 and aliasing entries.

    http://support.microsoft.com/kb/823659 mentions some group policy settings that can cause issues.  Tranversing for one is bad to disable.





    Friday, June 3, 2011 3:54 AM
  • I bet you have homegroup activated.  If so, homegroup overrides all other folder settings.  Go in WHS  Homegroup and see if the folder settings say no access...if so, change them.....


    Sunday, June 5, 2011 2:04 AM