locked
CRM 2013 ADFS 2.1 SDK Calls, Error: System.NotSupportedException: The authentication endpoint Username was not found on the configured Secure Token Service RRS feed

  • Question

  • Hi Community,

    I have successfully configures CRM 2013 with IFD. I get the error message from above when i try to connect to the CRM via SDK calls.

    I have tried to apply the following KB-Article. Which worked for CRM 2011 and AD FS 2.1,

    http://support.microsoft.com/kb/2828015/ 

    But the Script fail with the following error message:

    VerifyConfigurationEntityIsNotAmbiquous raising error : This setting has multiple instances. The Id of the instance is required to set or get the ActiveMexEndpoint property. 

    The error occurs at the following line of code:

    $Id=(Get-CrmAdvancedSetting -ConfigurationEntityName FederationProvider -Setting ActiveMexEndpoint).Attributes[0].Value 
    

    OS: Windows Server 2012 Standard

    Did anyone solved the issue?

    best regards,

    Martin

    Thursday, October 10, 2013 10:07 AM

Answers

All replies

  • I solved the issue now. Microsoft had relaeased an additional AD FS fix.

    http://support.microsoft.com/kb/2827748/en-us

    Everything is now working corretly.

    • Marked as answer by Martintfg Friday, October 11, 2013 8:38 AM
    Friday, October 11, 2013 8:38 AM
  • Hi Martin,

    I use MSCRM 2013 on windows 2018r2 and ADFS on windows 2012 [I guess it is ADFS 2.1]

    When i try to configure Email router it shows 

    "The authentication endpoint Username was not found on the configured Secure Token Service"

    I enabled username endpoint including proxy, even i updated the KB you suggested 

    my adfs exposed only in https but i noticed username binding alone exposed in HTTP "http://adfs.mycompany.com/adfs/services/trust/13/username"

    With regards

    Mamallan

    • Proposed as answer by Federica10 Saturday, February 7, 2015 10:11 AM
    Thursday, February 20, 2014 12:41 AM
  • We are having a similar issue with MS Server 2012. We went to the download page and downloaded the "Windows 8 RTM" file which is the only file option.  In looking through the txt, windows server 2012 hot fix is in the same file as "Windows 8 RTM."  But it still failed to initialize. 
    Monday, September 22, 2014 2:29 PM
  • Hi everybody,

    I'm encountering the same issue: we have a server hosting

    Microsoft CRM 2013 SP1 Rollup 1

    ADFS 6.3.0.0

    We can navigate the CRM web site but when we try connect to the organization through CRM Explorer or Plugin Registration Tool we receive the error "The authentication endpoint Username was not found on the configured Secure Token Service".

    We tried to enable username endpoint including proxy but it didn't work.

    Moreover we tried the KB but it failed to initialize.....did anyone succed in resolving this issue? It's really frustrating.

    Thank you all

    Saturday, February 7, 2015 9:58 AM