Windows Live Writer timeout on publish


  • When I try to publish to my blog from home it frequently fails saying that the connection timed out.  However it works just fine from other locations.  At home I have a satellite based ISP (Starband) and I suspect that the timeout is occurring due to the high latency inherent in satellite based internet connectivity.  The satellite is close to 30,000 miles away and even at the speed of light the round trip for data requests just to go from my computer, up to the satellite, back down to the Starband network center, out to the internet, and back is significant.  Is there a way to tell Live Writer to wait longer before timing out?
    Tuesday, May 18, 2010 1:52 PM

All replies

  • The timeout may not be with with your ISP, but with your site. If you're running Wordpress, the issue could be your plug-ins.

    Are you doing any kind of image compression or any special plug-ins that might affect the posting of your blog? Attempt disabling some of your plug-ins- see if that helps... If it does, it's the site.

    Have you tried visiting the site first, then posting/publishing?

    Just trying to help...



    Tuesday, May 18, 2010 6:57 PM
  • Well Im also having the same problem with my Wordpress Blog. Well I have tried chaning almost every aspect of the sote. I tried to remove spaces from the xmlpr.php as sugested by other fellow bloggers. Tried inserting some code into the .htaccess file but that even brought horor. I ended up hitting into appache 503 errors.

    I would sugest removing the plugins one by one and testing during the process. Plugins always have some funny codes that may affect the site. A good culprit are those that have something to do with backing up. or that automatically add something to the post e.g auto slug or auto tags. name it.

    Wednesday, May 26, 2010 9:55 AM
  • Have you tried loading the site in a browser, and then publishing?

    Periodically, I've the had issues with my blog timing out, but if I hit/visit the site with a browser and then publish with Windows Live Writer it works like a charm; I dunno why.

    Attempt that...

    Until next time,

    Saturday, May 29, 2010 12:57 PM
  • I also have the same problem. I use Blogger. Could the problem comes from the remote Blogger server? Or can i set up the timeout setting?
    Thursday, April 21, 2011 3:49 PM