2 WHS running on one network RRS feed

  • Question

  • I can get them both up and running, but my problem is that if I have them both running on the network only the one website works.  If I type in the other WHS URL, it forwards to the other WHS.  How do I get both of them running idependantly so that both websites can be run from the one network?  Do I need to do something different with the ports?  Thanks for any help!
    • Moved by Ken WarrenModerator Monday, September 15, 2008 11:25 AM This is a question about the software, not a suggestion. (Moved from Windows Home Server Suggestions to Windows Home Server Software)
    Monday, September 15, 2008 2:55 AM


  • You would have to set alternate ports for the second WHS and do the appropriate port forwarding.

    Monday, September 15, 2008 3:02 AM

All replies

  • You would have to set alternate ports for the second WHS and do the appropriate port forwarding.

    Monday, September 15, 2008 3:02 AM
  • How do I set the ports.  I know how to port forward within the router but how do I set the ports on the WHS?
    Monday, September 15, 2008 11:48 AM
  • Just currious, what are you actually trying to do?  I mean you want to get to 2 diff WHS sites from afar or locally?  Do you have more than 10 pc's on the lan and you want remote desktop to all?  Or is it diff websites (not WHS)

    I think if you try to change the defaulut port for the WHS stuff it will most likely break a lot of things.

    Monday, September 15, 2008 12:45 PM
  • The reason is I have a home based business.  For the business I have designed a webpage and it is set through WHS.  It als backs up my business computers.  Seperately from that, I have a home webpage (family) that I want to run through WHS.  Also, I want to join WHS and WMC on the network in the house on the family WHS.  I hope all this is understandable.  Thanks for any help!
    Monday, September 15, 2008 1:45 PM
  • Will,

    This is a difficult problem if you don't have two Internet Connections.
    You can change the ports that IIS on the server listens to, following the instructions here. These would have to correspond to what you are forwarding from your router, also, when accessing from outside, you wouldn't be able to use the server name without explicitly specifying the port number at the address end.
    There is some information in the WHS Documents, which might also help. However, unless you know what you are doing - and what else it might effect, then I would get specific help.

    However, note that any re-install required, will wipe all your settings and information.

    Personally, I would just use the separate HTTP and HTTPS for your homeserver name. I have two servers on the network, and one on http, has has one website, and the other has the https website.
    That just entails forwarding port 80 to one server IP, while the port 443, is forwarded to the other server. Not a high tech solution, but it works!

    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Monday, September 15, 2008 4:44 PM
  • You might want to read this:

     TUTORIAL: Changing the web server ports on your HP MediaSmart Server

    No home server like Home Server
    Monday, September 15, 2008 9:28 PM
  • I like Collins answer a lot.  Let us know if this is not satisfactory for you.

    Monday, September 15, 2008 9:47 PM
  • I like Collins idea, but I must be doing something wrong.  This is what it looks like in my router settings (that I changed):

    Enabled Name IP Address TCP Ports UDP Ports Inbound Filter Schedule    
    WHS 80 80 Allow All Always Edit Delete
    WHS2 443 443 Allow All Always Edit Delete
    whs3 4125 4125 Allow All Always Edit Delete
    when I go to the URL for or the URL for, with both servers running, it always goes to the URL of the server.  Do I need to change something else.
    Monday, September 15, 2008 11:55 PM
  • The Remote Access login page will always go to the https://[url] (port 443) address rather than http:// (port 80). It is for security reasons.

    If you set up your second WHS as the tutorial suggestions, you will get a https://[url]:4443 link that should work. Just remember to go through the entire tutorial and set up IIS correctly
    Tuesday, September 16, 2008 4:23 AM
  • i would use a second network for the 2nd server...since you use one server for business and the other for personal just separate everything...not sure of your location but in the US the cost of the business components (modem, router, monthly fees) is all tax deductible.  to me this seems like the simple solution.  if u have dsl get a 2nd phone line, if u have cable get dsl as your second connection.
    Tuesday, September 16, 2008 4:38 PM