locked
Canned Reports not showing up on CRM 2011 RRS feed

  • Question

  • I am stumped and hoping someone can help me with this.

    I have installed CRM / SSRS / and custom Reporting extensions.

    Originally I had some issues with installing the reporting extensions, I would get the warning that some reports would not be published.  I went into deployment manager and changed the URL and every thing seemed to be ok.  When I started to go through the CRM I notice that no reports were available.

    I have reinstalled the reporting extensions with no errors.  I have assured that the permissions are correct, I can even create a custom report, they show up and run successfully.  It seems like all of the out of box reports are not installed.  Am I missing them?  Is there someway to get them to show up?

    I am lost.. help :(

     

    Dave

    Wednesday, July 6, 2011 8:37 PM

All replies

  • Hi Dave

    out of box reports are created by the Reporing Server Extensions. The problem is that they are created only once, when the reporting services extensions are installed and these reports show on a shared folder on the Reports Manager.

    Suggest you uninstall the SSRS extension (not just repair) and re-install them again. If that doesn't work, disable and edit the MS CRM org and point to another rerpoting services instance and then install SSRS extensions.

    BTW SSRS extensions can only be installed if MS CRM DB exists on the SQL server.

     

    Are you by any chance using a load balanced Environment?

    Thanks and Regards

    AniMandal

    http://xrmadventures.wordpress.com/2011/03/

    Thursday, July 7, 2011 4:17 PM
  • Hey Ani,

     

    It looks like the report install and server were not seeing each other.  I blew out SQL and Dynamics and reinstalling getting another error but will create another thread. 

     

    Thanks!

    Thursday, July 7, 2011 4:18 PM
  • You need to republish your reports. There is a tool from Microsoft called publishreports.exe that you need to run from the prompt with your Organization name as a parameter.Unfortunately i have no link for it at hand

    Sorry

     

    DexDexter

     

    Tuesday, July 26, 2011 8:47 PM