Problem with ActiveX "InternetExplorer.Application" after "Fall Creators Update" RRS feed

  • General discussion

  • Hi Scripting Guys !

    I just realized the update from Windows 10 v.1703 to v.1709 (Fall Creators Update), and then reactivated IE v.11 (and it works OK).
    My problem is that, those of my scripts (.vbs, .wsh, and .hta) that used to drive IE no longer work : the line

    "Dim objectIE : Set objectIE = CreateObject("InternetExplorer.Application")"

    systematically aborts the scripts with the following message :

    "Un composant activeX ne peut pas créer un objet: 'InternetExplorer.Application'"
    (yes, i'm on a french configuration)

    What's happening (has this ActiveX been deprecated, as IE will shortly disappear, or is it a fixable problem (for example some dlls to re-register) ) ?

    Thank you for your suggestions.
    • Changed type Bill_Stewart Tuesday, December 5, 2017 3:24 PM
    • Moved by Bill_Stewart Tuesday, December 5, 2017 3:25 PM This is not break/fix forum
    Wednesday, November 1, 2017 3:30 PM

All replies

  • It works exactly the same on 1709.  I suspect you need to repair your system.


    Wednesday, November 1, 2017 4:08 PM
  • Thank you for your answer, and the information of no-change. 

    I already "sfc /scannow" and "dism /online /cleanup-image /scanhealth" and it did not show any problem.

    I also uninstalled / reboot / reinstall the "windows 10 optional component" IE11, with no success.

    what else can I try ?

    Wednesday, November 1, 2017 5:32 PM
  • Call Microsoft support.  If this was caused by the upgrade then the call will be free.

    First try creating a new account and test as it can be caused by a corrupted profile.

    Also there are known issues with the MUI version of Windows 10 and the upgrade.  Most issues are not documented.


    • Edited by jrv Wednesday, November 1, 2017 5:44 PM
    Wednesday, November 1, 2017 5:43 PM
  • Thanks, jrv, I also tested it from other profiles (basic user, and administrator) : same behaviour.

    I just tried the more verbose Powershell :
    set-ExecutionPolicy -ExecutionPolicy unrestricted
    $ie = new-object -com "InternetExplorer.Application"
    $ie.visible = $true
    While ($IE.Busy -eq $True) {Sleep -Milliseconds 50}
    $doc = $ie.Document

    It worked fine on an other machine under v.1703.

    on v.1709, it returned the following message :

    new-object : La récupération de la fabrique de classes COM pour le composant avec le CLSID
    {0002DF01-0000-0000-C000-000000000046} a échoué en raison de l'erreur suivante: 80040154 Classe non enregistrée
    (Exception de HRESULT : 0x80040154 (REGDB_E_CLASSNOTREG)).
    Au caractère I:\Scripting\PowerShell\IEApp.ps1:1 : 7
    + $ie = new-object -com "InternetExplorer.Application"

    BINGO !!!
    It's just a matter of unregistered component(s) !

    Can anybody help me and identify the files to register ?

    Thanks again for your help

    Wednesday, November 1, 2017 6:05 PM
  • Sorry, but break/fix is outside the scope of this forum.

    -- Bill Stewart [Bill_Stewart]

    Wednesday, November 1, 2017 6:14 PM