CRM 4.0 Email Router woes - SoapException: Server was unable to process request RRS feed

  • Question

  • With CRM 4.0 RU10 (upgrading to latest RU is not an option right now), the email router all of a sudden - without anything having changed - stopped sending emails.  The Microsoft.Crm.Tool.EmailAgent.SystemState.XML file has:

    08/12/2011 10:27:11 : System.Web.Services.Protocols.SoapException: Server was unable to process request.
      at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
      at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
      at Microsoft.Crm.Sdk.Proxy.CrmService.Execute(Request Request)
      at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RequestEmailsToProcess(QueryExpression query)
      at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RetrieveNextMessageInternal()
      at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.RetrieveNextMessage()
      at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()\r\n
     Generic SQL error.


    We tried deleting the Microsoft.Crm.Tools.EmailAgent.SystemState.xml and restarting, as described here, but that didn't help.


    What to try next ?  Any tips appreciated.

    Friday, August 12, 2011 6:01 PM


  • We fixed it by rebooting the SQL Server machine
    • Marked as answer by Jim Glass Jr Thursday, August 25, 2011 5:38 PM
    Thursday, August 25, 2011 1:27 PM

All replies