locked
Add site on WHS. Anonymous access (from the web) won't work RRS feed

  • Question

  • I have added a new site to my WHS on a certain port. Url is something like; http://my-server-ip:1234
    In IIS I have checked allow anonymous access in the authentication methods. When I try to enter the site it asks for a user and password. If I login with any of my set up users on the server it works fine and I can access my new site. This is not what I want. I wish to access the site without entering any user/passwords.
    Navigating to http://my-server-ip takes me to the WHS standard startpage without any fuzz...

    I need to get this working as I want to forward my own web-domain to my WHS and host it myself.
    ie. http://www.my-domain.com would get me to http://my-server-ip:1234

    I have read around for a while now about IIS and permissions and it is by far the most complex stuff I have encounterd with WHS but I guess hosting sites accessible from internet wasn't MS first thougts about making WHS :)  and thereby making it a nice walk in the park... I do realize that IIS is part of Windows Server 2003 and may not have been thought to be used by us home server freaks...

    Any good pointers would be appreciated!

    Regards




    Friday, January 2, 2009 11:35 PM

Answers


  • While not directly answering your question, you could always use the Whiist add-in to add a web page to your WHS.  Simply use Whiist to set up the permissions and then copy your html files into the directory you used for Whiist.
    • Marked as answer by WHSwed Sunday, January 4, 2009 3:17 PM
    Saturday, January 3, 2009 7:05 PM

All replies

  • Hi,
    often the IIS anonymous account has not enough NTFS permissions for accessing the location in the file system, where the sources of the website are located.
    Best greetings from Germany
    Olaf
    Saturday, January 3, 2009 7:53 AM
    Moderator

  • While not directly answering your question, you could always use the Whiist add-in to add a web page to your WHS.  Simply use Whiist to set up the permissions and then copy your html files into the directory you used for Whiist.
    • Marked as answer by WHSwed Sunday, January 4, 2009 3:17 PM
    Saturday, January 3, 2009 7:05 PM
  • I ended up using Whiist. Thank you for the tip.
    I looked through the settings in IIS for the page that was created but I can't see what I did wrong before.
    I checked the permissions thoroughly before posting but god tip anyways.
    Regards

    Sunday, January 4, 2009 3:17 PM