locked
DTMF not responding after upgrade? RRS feed

  • Question

  •  

    Hi!

    Just upgraded our customers standby server from the beta but could not get our DTMF-only application to respond to any dtmf-input. I believe this is related to the telephony cards and Sipcontrol but our customer is blaming the new OCS MSS version. We are using the developer edition download without any licenses or internal/external connectors installed.

     

    Has anybody else experienced (and solved ;-) ) this?

     

    Thanks for your input,

    Markus

    Tuesday, December 11, 2007 3:22 PM

All replies

  • I had to do the old "fix the server trick": restart.

     

    Deleted the application, restarted the server, added the application again.

    Dtmf works!

     

    Tuesday, December 11, 2007 4:12 PM
  • Something strange going on, DTMF works for most calls but not all. Tried calling 4 times and on one occasion it did not work.

     

    Any ideas?

     

    Thanks,

    Markus

    Friday, December 14, 2007 10:56 AM
  • Still have the same problem. Approx 25% of calls have some troubles with dtmf. Most calls that have troubles never get past the first QA (InitialSilenceTimeoutExpired) but some few calls get past the first QA but get stuck on InterDigitTimeoutExpired later in the workflow instead.

    I have checked performance counters but not found anything strange. No DTMF Request Errors. Processor load very low. Problem occurs even if there is no other calls at all (so it should not be load related). Nothing strange in the eventlog.

     

    Please advise, I really have no clue what to do.

    / Markus

    Wednesday, January 2, 2008 2:14 PM
  • Hey Markus,

     

    Still haviung your dtmf issues?

     

    We ran into a similar issue. Using Speech Server 2007, and an IP Gatway for the Telephony interface.  I don't remember the exact symptoms, but the dtmf was sporadic in some way.  We ended up making a change on the Gateway to send DTMF as RFC 2833 in stead of inband - I think. 

     

    Good Luck.

     

    Phil.

     

    Monday, January 7, 2008 9:25 PM
  • Thanks for your input, Phil!

     

    Yes, still have the same problems. We have a support case going so I hope it will be solved soon.

    I'm not really sure what RFC 2833 for DTMF means, was this a setting on your IP Gateway?

     

    I'll look at our settings (the telephony part is not my main area...) and see if I find anything that contains this.

     

    / Markus

    Wednesday, January 9, 2008 1:39 PM
  • By the way, Phil, did you change this between releases (beta vs RTM) or was this an initial change?

    / Markus

    Wednesday, January 9, 2008 2:02 PM
  • Yes - changes were made for a setting/settings on the Gateway.  I did not do it, just quizzed our guy that got it fixed.

     

    I don't recall for sure the build history.  We added a DTMF app to an RTM Speech Server.  That is when we discovered the issue.  The same gateway which was being used for the RTM SS, was also used by a Beta SS.  On that server, I can't recall if we ever used DTMF or not.  Almost all of our apps use it as back up, but I can't say that we tested DTMF on the last Beta.

     

    Please let us know how it turns out.

    Wednesday, January 9, 2008 4:01 PM
  • Hi Markus,

     

    I'm getting exactly the same behaviour as you do. In like 25% of the calls, DTMF isnt recognized at all.I'm using a Dialogic Media Gateway 4000 with OCS 2007 Speech Server RTM. No performance problems, no errors at all, no concurrent calls...

     

    I've been trying to change the DTMF settings in the DMG4000 but I only have an option "DTMF clamping" which I have changed but with no sucess. I cant find anywhere the option to change from in band tone detection to RFC 2833 as suggested by another user in this thread.

     

    What is the gateway that you're using?

    Do you have any updates on this?

     

    Thanks for your help 

    Moreira Lopes

    Tuesday, January 22, 2008 9:29 PM
  • Hi Moreira,

    Sorry, no solution yet. We have an ongoing supportcase with the mss team and another support case with dialogic support. No answers yet. I'll let you know as soon as I find out.

    Hmm, gateway. We are using a 'Eicon Diva Server V-2PRI/E1/T1' - board with their SIPControl. This worked fine on the Beta but not on the RTM. Did you run your setup on the Beta?

     

    I have not yet been able to give the dialogic team all info they want, have tried to use Wireshark to get hold of the localhost traffic (through the loopbackadapter) so they can see what leaves the SIPControl and what is received by mss. But no traffic shows up, if someone has any idea I am all ears.

     

    If you find a solution, please let me know. Thanks,

    Markus

    Monday, January 28, 2008 2:51 PM
  • A couple suggestions:

     

    1.) Make sure SipControl 1.5.1 or higher. 

     

    2.)  For the Dialogic Media Gateway 4000, make sure you follow Dialogic’s configuration guide for Exchange UM and not OCS UC. While Speech Server is a part of OCS, it doesn't require OCS server roles to be installed. The 4000 series when configured for OCS UC, is a mediation server role, which will probably give you problems when trying to directly connect it to Speech Server.

     

    --

    Michael D. Dunn
    http://blogs.msdn.com/midunn

    Monday, January 28, 2008 5:03 PM
  • Hi Michael,

    we have just tried with Sipcontrol 1.6 with the same results.

    I got a suggestion that  the sipcontrol is not fully compliant with the SIP/RTP RFC and a possible solution  : "One potential work around would be to configure something like Windows Firewall to strip out the ICMP "unreachable" response messages." (Advanced tab in Windows firewall, Local area connection, Settings, IMCP settings, check all but "Allow outgoing destination unreachable").

     

    Could not get this to work when running SIPControl on same computer as MSS. Tried going through the loopback adapter and different network cards but no difference. Tried all kinds of settings in sipcontrol 1.6 but could have done something wrong here.

     

    / Markus

     

    Thursday, January 31, 2008 12:47 PM
  • Just a quick update on this issue, it seems like Dialogic/Eicon thinks this fault is in the mss while microsoft regards this as a sipcontrol problem. So when do we get a fix? Never, is my guess.

     

    The workaround (above, using two servers) seems to work for the time being even if that is not the way we planned to run this. Our customer is very security wise so running two complete setups (for redundancy and really heavy loads), now means we need 4 servers instead.

     

    / Markus

    Thursday, March 6, 2008 1:19 PM
  • Hi

     Any ideas on how to detect DTMF over a PC - Phone conversation in Communicator 2007? I am looking for ways to do this with the unified communicator SDK. Any help is appreciated.

    David
    Monday, March 31, 2008 6:42 PM
  • Latest news - this actually seems to work after installing the latest sipcontrol (2.0?)!
    Wednesday, January 7, 2009 2:12 PM