locked
no connectivity between Tnor AF voice gate way and OCS RRS feed

  • Question


  • Hello

    I wonder if someone could help me to solve this bad problem

    I explain you what am I do for integerate ocs with tenor AF :

    I deploy ocs enterprise voice perfectly and I test it with voice analyzer and there is n't any problem in ocs side.

    I install Tenor Configuration Manager (GUI)( with easy to use Microsoft OCS R2 2007 Wizard  )

    In the view>tenor status>sip status I see this report :

     

     

     

     

    "Current system time is WED SEP 23 08:37:11 2009

     

    UserAgent ID = 1, ListenPort = 5061

      Primary Registrar:   All registration disabled

      Secondary Registrar:   All registration disabled

      Current Proxy:          Primary-(192.168.1.16:5060)

     

      Current Outbound Proxy: Primary-(192.168.1.4:5060)

     

    SIP Call Sessions:

    ------------------

           Total number of Gateway sessions: 0

     

    "

     

     

    But I config user agent

    Advance-explore>voip configuration>sip signaling groups>sip signaling group-1> user agent

    I fill the box like this

    Ua : 101

    Lp : 5061

    Primary user : RTCservice ( it's a default sip service user account in ocs )

    Primary password : sahand ( for example )

    Enable : yes

     

    I wish I could explain my problem clearly

    I think we have authentication problem may be it cause by clear password

    Also I set time server correctly and right now time in the tenor is as same as ocs server

    I'm really confuse due to this unusual problem

    what should i do ?

    Friday, September 25, 2009 12:47 PM

Answers

  • Hi

    You don't need to configure any user agent to connect AF to OCS, connection from gateway side is on port 5060 with no authentication.
    Also check file named var_config.txt from Config manager, it contains variables like the "SipTransportDefault" to set to 1 to use TCP instead of UDP.
    • Marked as answer by UCDEMO Saturday, October 3, 2009 7:02 PM
    Saturday, September 26, 2009 5:58 PM
  • i reinstall framework and upgarde it to last version and luckily this problem getting solve

    dear nkv i really thank you
    • Marked as answer by UCDEMO Saturday, October 3, 2009 7:10 PM
    Saturday, October 3, 2009 7:07 PM

All replies

  • Hi

    You don't need to configure any user agent to connect AF to OCS, connection from gateway side is on port 5060 with no authentication.
    Also check file named var_config.txt from Config manager, it contains variables like the "SipTransportDefault" to set to 1 to use TCP instead of UDP.
    • Marked as answer by UCDEMO Saturday, October 3, 2009 7:02 PM
    Saturday, September 26, 2009 5:58 PM
  • thank you in advance for your advice ,
    i checked what you've said , and you are right
    but my Problem not solve yet .
    i check SIP STATUS it seem that it didnt save anything . i dont know why regarding that i CONFIRM/OK and submit changes.

    i attached my SIP Status and status of tenor :


    ------------------ SIP STATUS ------------------------

    Current system time is SUN SEP 27 12:13:18 2009

    UserAgent ID = 1, ListenPort = 5060
      Primary Registrar:   All registration disabled
      Secondary Registrar:   All registration disabled
      Current Proxy:          Primary-(192.168.1.16:5060)

      Outbound Proxies:       Unconfigured

    SIP Call Sessions:
    ------------------
         Total number of Gateway sessions: 0

    -------------- Qointum STATUS------------------------------

    Manufacturer: Quintum Technologies
    Product Name: Tenor AF
    H/W Version: 1 [0 0 0 0][3 3 0 0]
    S/W Version: P107-09-00
    Port Info: 0 FXS + 4 FXO
    Protocol: SIP
    Status: Registered
    Network: 192.168.1.4 (Static)
    Total Calls: 0


    ---------------------


    i dont know why the status is REGISTERD and  Primary Registrar:   All registration disabled .i could say that i send an Email to Quintum and get my license ,i want to know that is it possible that the problem is my license or something else ?! 

    I wonder if someone could help me .
    • Edited by UCDEMO Sunday, September 27, 2009 12:27 PM just for fun
    Sunday, September 27, 2009 12:24 PM
  • Hi

    There is an apply button at the bottom of each config screen, but you also have to click on the red star button on top Config Manager to submit changes.
    You can check Tenor wizard doc for OCS at
    http://ae.quintum.com/~mbarry/MicrosoftOCS/Microsoft%20OCS%202007%20Documentation/Microsoft%20OCS%202007%20Wizard%20AF-AS-AX.pdf
    Tuesday, September 29, 2009 7:12 PM
  • i reinstall framework and upgarde it to last version and luckily this problem getting solve

    dear nkv i really thank you
    • Marked as answer by UCDEMO Saturday, October 3, 2009 7:10 PM
    Saturday, October 3, 2009 7:07 PM
  • Thank you Ali.khani, you're welcome.
    Sunday, October 4, 2009 8:08 PM