CRM 2013 Customize contract lines views RRS feed

  • Question

  • Hello,

    I am just creating a new crm view in contract line entity. I am trying to filter the view from contract lines entity -> views -> edit view common tasks -> edit filter criteria, here I add a filter from related entity (related : contract -> owner : equals current user). But while I set the above filter, I cannot save it. So, my view shows records from all owners.

    Is it bug of CRM 2013?

    Thanks in advanced! 

    Wednesday, April 9, 2014 10:28 AM

All replies

  • Hi, I've tried to reproduce the steps that you provided. But I couldn't get the error, I could save the view.

    Try to refresh the page and clear browser cache and please let me know how it goes.

    Below is my screenshot:

    Wednesday, April 9, 2014 11:23 AM
  • Thanks a lot for the reply. 

    I don't receive any error when I press OK in filter criteria window but the filter isn't saved. If I you press again Edit Filter Criteria, the related entities filters have disappeared. 

    Set Filters from related entities -> OK

    1st picture

    Press again "Edit Filter Criteria". It saved filters from contract lines entity but it loose filter from related entity.

    Thanks a lot.

    Wednesday, April 9, 2014 12:25 PM
  • Hi, I tried again to open the custom view that I saved earlier and clicked on "Edit Filter Criteria" and the previously selected filter is saved properly.

    Btw, is this CRM Online/On Premise (if it's on premise, which update roll-up)? 

    Try to refresh the page and clear browser cache. 

    And also, is the view that you are working on is the out of the box view? And what is the state of the view (Managed/Unmanaged)?

    • Edited by Andre.K.MMVP Thursday, April 10, 2014 11:23 AM Update Question
    Thursday, April 10, 2014 11:20 AM
  • Hi Andre, 

    My CRM is 2013 on premise with UR1. My view is custom view with state unmanaged.

    I just delete browsing history from internet explorer but the problem remains in existence.

    Firstly, I will try to install UR2 and check if the problem continues.

    PS. For now, I create the view through Report Wizard.

    Thanks a lot for the reply.

    Thursday, April 10, 2014 11:40 AM