locked
Cannot connect to Vista 64 bit through Windows Home Server Page RRS feed

  • Question

  • I am running windows Vista Ultimate 64 bit on my main computer at home and WHS on another one.  Whenever I try to connect to my main computer (not the server) I get a message that says "The remote computer requires that authentication be enabled to connect.  Remote computer: mydomain.homeserver.com  The connection cannot proceed because authentication is not enabled."  I have the remote computer set to "Allow connections from computers running any version of Remote Desktop".  My ports are forwarded correctly in my router, I can access the shared folders and it shows my PC is online and ready to connect remotely, but I cannot for the life of me get a connection established. 

    When I try a regular remote desktop connection to my main PC directly from the WHS, I get, "The client could not connect to the remote computer."  However, I can ping it from the WHS.  Also, remote desktop connection is enabled in my main PC's firewall.  Any ideas as to why this isn't working?
    Tuesday, September 8, 2009 7:25 PM

All replies

  • I am running windows Vista Ultimate 64 bit on my main computer at home and WHS on another one.  Whenever I try to connect to my main computer (not the server) I get a message that says "The remote computer requires that authentication be enabled to connect.  Remote computer: mydomain.homeserver.com  The connection cannot proceed because authentication is not enabled."  I have the remote computer set to "Allow connections from computers running any version of Remote Desktop".  My ports are forwarded correctly in my router, I can access the shared folders and it shows my PC is online and ready to connect remotely, but I cannot for the life of me get a connection established. 

    When I try a regular remote desktop connection to my main PC directly from the WHS, I get, "The client could not connect to the remote computer."  However, I can ping it from the WHS.  Also, remote desktop connection is enabled in my main PC's firewall.  Any ideas as to why this isn't working?

    Have you tried rebooting both your server and your client?  How about disabling the firewall on your client?  Do you have any kind of security software installed on your client?
    Wednesday, September 9, 2009 1:10 AM
    Moderator
  • Hi there


    I had the same problem with windows 7 64bit here is how i fixed it.

    1. go to the following path  - C:\Windows\System32\drivers\etc
    2. change the security settings on the host file so you can edit it
    3. open it in notepad
    4. add the following 192.168.1.3  server #server
        change the IP above for the IP of your server
        change the word 'server' for the name of your server
    5. save the host file
    6. make sure that remote access is still turned on, on the server  

    you may have to ask it to reset home server console, but that should get you going again.

    Good luck Ian
    Wednesday, September 9, 2009 9:06 AM
  • kariya21 - Yes I have rebooted both server and client, I have tried disabling the firewalls on both, I have spyware doctor on my client, but I have disabled it for testing.  I am also 99% sure I am not currently infected (you can never be COMPLETELY sure).


    Ian - am I going to that path on the client or the server machine?  Also, I add my server IP, then in the name of my server part do you mean the machine's actual name or the url like mydomain.homeserver.com  ?  I have set it on both the client and server as (server ip)   mydomain.homeserver.com and restarted both machines, but it has not helped.

    I can actually remote into a windows XP machine on my network through the WHS, but I fail when I try to mstsc from that XP computer into my Vista 64 bit computer.  It totally seems to me like a problem with my Vista 64 bit computer, but I am at a loss as to what exactly it is. 
    Wednesday, September 9, 2009 9:07 PM
  • ok sorry I should have said, Its the client pc do not change the server one.  The name you have to give it is the network name not the url.

    Please check out this link it is the one i posted about a problem that sounds just like yours,

    http://social.microsoft.com/Forums/en-US/whssoftware/thread/faf367ff-a70c-4099-aa80-a785b11de413

    I am aware that you are trying to connect to your client but I think the link problem may be very much the same.

    Just a tought can you try makeing all your pc's use static IP.


    Hope it helps.
    Wednesday, September 9, 2009 10:07 PM
  • kariya21 - Yes I have rebooted both server and client, I have tried disabling the firewalls on both, I have spyware doctor on my client, but I have disabled it for testing.  I am also 99% sure I am not currently infected (you can never be COMPLETELY sure).


    Ian - am I going to that path on the client or the server machine?  Also, I add my server IP, then in the name of my server part do you mean the machine's actual name or the url like mydomain.homeserver.com  ?  I have set it on both the client and server as (server ip)   mydomain.homeserver.com and restarted both machines, but it has not helped.

    I can actually remote into a windows XP machine on my network through the WHS, but I fail when I try to mstsc from that XP computer into my Vista 64 bit computer.  It totally seems to me like a problem with my Vista 64 bit computer, but I am at a loss as to what exactly it is. 

    When you try to Remote Desktop from your XP box to your Vista 64 box, do you get an error message?  If so, what does it say?
    Thursday, September 10, 2009 4:36 AM
    Moderator
  • Ian, I actually have my router set to DHCP with reservations for my PCs, so it's just like static.  My server IP and the Vista 64 client IP never change.  I did add the server into the hosts file as you suggested and it didn't help. :(


    kariya21 - when I try to Remote Desktop from my XP machine to the Vista 64 box I get a message stating "The identity of the remote computer cannot be verfied.  Do you want to connect anyway?  The remote computer could not be authenticated due to problems with its security certificate.  It may be unsafe to proceed.  Certificate name:  My client PC.  Certificate errors - The certificate is not from a trusted certifying authority.  Do you want to connect despite these certificate errors?"

    I can click yes, but then it just pops me right back to the Remote Desktop connect screen.  When I view certificate it says "This CA Root certificate is not trusted.  To enable trust, install this certificate in the Trusted Root Certification Authorities store."  I've tried doing that and it didn't help anything so I deleted that certificate back out (of my XP machine).

    I've also tried setting the remote desktop connection to Connect and don't warn me, but it does the same thing (just pops me back to the first Remote Desktop screen). 

    I am not sure how my certificate could have gotten messed up on that Vista64 machine.  I will probably eventually wipe it and put Windows 7 on it, but I am not really wanting to do that right now. 
    Monday, September 14, 2009 3:10 PM
  • Ian, I actually have my router set to DHCP with reservations for my PCs, so it's just like static.  My server IP and the Vista 64 client IP never change.  I did add the server into the hosts file as you suggested and it didn't help. :(


    kariya21 - when I try to Remote Desktop from my XP machine to the Vista 64 box I get a message stating "The identity of the remote computer cannot be verfied.  Do you want to connect anyway?  The remote computer could not be authenticated due to problems with its security certificate.  It may be unsafe to proceed.  Certificate name:  My client PC.  Certificate errors - The certificate is not from a trusted certifying authority.  Do you want to connect despite these certificate errors?"

    I can click yes, but then it just pops me right back to the Remote Desktop connect screen.  When I view certificate it says "This CA Root certificate is not trusted.  To enable trust, install this certificate in the Trusted Root Certification Authorities store."  I've tried doing that and it didn't help anything so I deleted that certificate back out (of my XP machine).

    I've also tried setting the remote desktop connection to Connect and don't warn me, but it does the same thing (just pops me back to the first Remote Desktop screen). 

    I am not sure how my certificate could have gotten messed up on that Vista64 machine.  I will probably eventually wipe it and put Windows 7 on it, but I am not really wanting to do that right now. 

    Well, it seems to me that your problem is with Vista, not WHS.  You could try posting your problem in the Vista forums and see if anyone has any suggestions there.
    Tuesday, September 15, 2009 4:47 AM
    Moderator