Problem with AjaxToolkitManager and ScriptManager RRS feed

  • Question




    I used "ModalPopupExtender" with "ToolkitScriptManager" in my page, it had worked properly.

    Later I added "UpdatePanel" control,but it needs "ScriptManager". So I added that also, but now ModalPoupExtender is not working. How to fix this? How to use updatepanel and ajax controls in same page.



    <atlas:ScriptManager id="ScriptManger2" runat="server" EnablePartialRendering="true"></atlas:ScriptManager>

    <ajax:ToolkitScriptManager ID="ScriptManager1" runat="server" EnablePartialRendering="true" CombineScriptsHandlerUrl="~/CombineScriptsHandler.ashx" />


    Thanks in Advance

    Wednesday, May 28, 2008 12:48 PM

All replies

  • in the update panel u added check in sourse code whether their is a "id" property mentioned .if not mention it.
    i think this will help u out
    Wednesday, May 28, 2008 1:09 PM
  • The ToolkitScriptManager is inherited from the original ScriptManager coming along with ASP.NET AJAX. The ToolkitScriptManager has all the functionalities of the ScriptManager and so, you don't have to include them both. Just the ToolkitScriptManager should be enough (haven't actually tried it out).

    Saturday, May 31, 2008 6:06 PM



    I had same problem and take me a few hours (spend few hours one day, no luch, dare try few hours again one week later, solved) to find out problem and resolve it.


    The reference System.Web.Extensions you used in your project/web site might be , and the AjaxControlToolKit is refering And this cause problem.


    I just download source code for AjaxControlToolKit , change it reference to refer to same System.Web.Extensions.dll I am using in my project and compile it, and use AJAXExtensionsToolbox.dll I produced, works fine.


    You don't have to do this way,  you can simple make your project refer to 3.5.00 version of System.Web.Extensions.dll come with .net 3.5 as well.


    Or if you are using .net 2.0, you can just go to http://www.asp.net/ajax/ajaxcontroltoolkit/samples/ to download Toolkit version 1.0.20229 (if it is still available there) or download source code you compile yourself.


    Anyway, version mismatch is the problem.


    Hope it is same problem for you.


    Good luck!

    - Ryan

    Thursday, October 30, 2008 11:40 PM