locked
Adding Multiple Users RRS feed

  • Question

  • I have MS CRM v4 Enterprise on a server called QGDynamics.  I have SQL 2005 on a server called QGDatabase.  I have Active Directory on a server called QGPrimary. This is how it has been since time. 

     

    Before christmas, it came to my attention that we could not add mutliple users to any of our organizations.  Although it will pick up names from AD, after pressing 'create users', an error message appears after a few moments. "Error: The following user was not added : <user name>".

     

    I ran a trace, and part of it is below

     

    [2009-01-15 16:36:51.9] Process: w3wp |Organization:46c8932b-d574-dd11-a217-000c29f08865 |Thread:   20 |Category: Application |User: 00000000-0000-0000-0000-000000000000 |Level: Error | ActiveDirectoryUtility.FindUser
     at ActiveDirectoryUtility.FindUser(String domainAccountName)
     at ActiveDirectoryUtility.PopulateSystemUserProperties(Entity user)
     at UserManager.AddUsers(String userXml, Guid[] roles, Boolean sendInvitation)
     at RuntimeMethodHandle._InvokeMethodFast(Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
     at RuntimeMethodHandle.InvokeMethodFast(Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
     at RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
     at RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
     at LogicalMethodInfo.Invoke(Object target, Object[] values)
     at WebServiceHandler.Invoke()
     at WebServiceHandler.CoreProcessRequest()
     at SyncSessionlessHandler.ProcessRequest(HttpContext context)
     at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
     at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
     at ApplicationStepManager.ResumeSteps(Exception error)
     at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
     at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
     at HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)
     at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)
    >Unable to get find user QGATE\RowlandD: System.Runtime.InteropServices.COMException (0x8007203A): The server is not operational.
    >
    >   at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
    >   at System.DirectoryServices.DirectoryEntry.Bind()
    >   at System.DirectoryServices.DirectoryEntry.get_AdsObject()
    >   at System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne)
    >   at System.DirectoryServices.DirectorySearcher.FindOne()
    >   at Microsoft.Crm.Application.Utility.ActiveDirectoryUtility.FindUser(String domainAccountName)

     

    I know this user does exist as I can add him individually.

    Any help is welcome.

    Thanks in advance

     

    Friday, January 16, 2009 11:29 AM

All replies

  • When was the last time you made changes to your server by either downloading programs or completing updates.  Have you either rebooted your Exchange Server or CRM server lately.

     

    You may want to try downloading and installing Rollup 1 if you have not already done that and then reboot the CRM, SQL, Exchange server.  Lets see where you are after that.

     

    Friday, January 16, 2009 1:34 PM
  • The servers have been updated and restarted many times since the error started occurring.  We have had some problems with our exchange server but we do not use this wtih MS CRM as this is not our primary CRM package.

     

    Rollup 1 was installed on release.  I cant remember if this problem was pre Rollup 1 or not.

    Friday, January 16, 2009 2:08 PM
  • Ok, thank you.  Download and install the diag tool, turn Dev errors on, recreate the issue and let's see if you get a different error message.

     

    http://blogs.msdn.com/benlec/archive/2008/03/04/crmdiagtool4-for-microsoft-crm-4-0-has-been-released.aspx

     

    Just to ensure I understand the issue correctly,  you can not use the feature to add Multiple Users but you can add single users and save them successfully.  Is that correct?

    Friday, January 16, 2009 2:34 PM
  •  

    I always have Dev errors on as I mainly use MS CRM for testing.  The error message is the same.

     

    You are a correct. I can add single users without any problems but adding "mulitple users"  the error occurs.  Over the last weeks/months iv tried different situations like adding one multiple user as system admin etc etc.  Creating new organizations does not help either.

    Friday, January 16, 2009 3:04 PM
  • Iv tried logging on as different users and this hasn't made a difference.

     

    The only unsual thing that I have done is that The SQL server is 2005 but we had a 2008 databse come in from a customer that needed viewing.  So I set up an image with SQL2008 on and connected to that instance when importing an organization. There was still only one MSCRM_CONFIG databsse. This worked well and but is no longer needed so I have deleted the organization.  Would this make any difference to adding users?

     

    Tuesday, January 20, 2009 8:40 AM
  • could have, difficult to say for sure.  Since this is a test server, maybe you could take a copy of the production database and restore it to your test server and then use the Deployment Manager to import an Organization.  Basically, redeploy your test environment.  You can save off any customizations that you have on your test environement and restore those after the redeployment.
    Tuesday, January 20, 2009 4:11 PM
  • The problem is that our production CRM system is Saleslogix.  We have one instance of MS CRM but with about 15 organizations, all reporting the same problem. 

     

    Iv had a look at the log file on the SQL2K5 Server and here are a couple of lines....

     

    Error: 18456, Severity: 14, State: 16.
    2009-01-20 09:41:58.49 Logon       Login failed for user '[domain name]\[sever name]$'. [CLIENT: <named pipe>]

     

    This suggests that it could be a problem with SQL. Iv checked to make sure remote connections are alowed for TCP/IP and named pipes.  I cant think what else to check

     

     

    Wednesday, January 21, 2009 11:05 AM
  • Since you have 15 Organizations affected by this, I would open a ticket with Microsoft support.  They should be able to quickly identify a solution.  I don't beleive this is a common issue that will be fixed with any of the Rollups or hot fixes.

     

    Wednesday, January 21, 2009 2:07 PM