Cannot connect internet with firefox and chrome, but Internet Explorer is OK


  • I used the Windows XP SP3 and Norton Internet Security, it works fine for connecting internet with IE, firefox and chrome, recently I removed the Norton Internet Security and installed the MSE (durring the MSE installation I selected to enable the Windows Firewall), after the MSE installation I can not use the Firefox and Chrome again, it always shows that can not connect internet. But IE still can work normally.

    The chrome shows the the error message as
    "Error 102 (net::ERR_CONNECTION_REFUSED): server refused the connect"

    The Firfox shows the message as
    "Connect Failed
    Firefox can not establish connect with server " and in the webpage content it shows
    "[15:15:29.354] GET [undefined 15ms]"

    As the check for the Firewall and Proxy settings they are as below,
    1. Firewall setting
    1) Firefox and Chrome both listed in the exception list and both items are checked
    2. Proxy configuration
    1) IE and Chrome use the same setting tool and both are set in the same (no proxy)
    2) Firefox uses the setting tool of itself, but the default setting is as "Use system proxy setting", I had tried to change the setting as "no Proxy", it still can not work.
    3. Encryption setting
    1) All enable the SSL 3.0 and TLS 1.0

    And I had tried
    1) to delete the Firefox from the exception list and re-add it into the list, but it still can not work.
    3) to uninstall the Firefox and re-install it, the case is the same, it still cannot work.

    Thanks a lot to give the help!



    Tuesday, May 03, 2011 11:04 PM

All replies

  • I have a very similar problem on an eMachines netbook

    Chrome and Firefox fsil to connect to the internet but IE works fine

    Skype also fails to connect

    I cannot remeber if I ever had Nortons on this PC ... I think not

    But I am also running MSE (which also works fine ,,, downloads updates)

    I've tried disabling Windows Firewall .... still a problem

    Very very strange ...

    Tuesday, July 19, 2011 1:01 AM
  • This forum is for a blog software called Windows Live Writer. For help in Windows networking, visit

    The following is signature, not part of post
    Please mark the post answered your question as the answer, and mark other helpful posts as helpful, so they will appear differently to other users who are visiting your thread for the same problem.
    Visual C++ MVP
    Thursday, July 21, 2011 9:10 PM