locked
D-Link Shareport Utility -- What are the Onecare Firewall Settings? RRS feed

  • Question

  • I've seen one post on this, but have seen no answers.  I have installed the new D-Link "Shareport" utility, which allows the user to connect a USB drive to my DGL-4500 router and access it via a router firmware upgrade 1.13 and their new Shareport utility.  I purchased a 750 gig Maxtor USB drive for this purpose and hooked it up. 

     

    I was pleased when my Toshiba laptop connected to the drive without any issues, and assumed that all of the rest of my computers would connect as well.  Well -- not so fast.  All of the rest of the computers are running Microsoft Live Onecare, whereas the Toshiba was running Norton 360. It is obvious that the Onecare firewall is blocking access.  If I disable the Onecare firewall, each computer can access the drive without problem.  Just as obvious, I don't want to run without a firewall.  I've tried to "tune" the Onecare firewall by "allowing" the Shareport program and by opening the same ports (53 and 80) that Norton 360 assigned (automatically, I might add) to the Shareport program in its configuration, to no avail.  So ..... question is, how do I make the Onecare Firewall let this Shareport program through? 

    Friday, October 17, 2008 1:26 AM

Answers

  • The other thread offered a number of suggestions:

    1. Contact DLink Support. - unfortunately, the person who did that had no success as DLink support was clueless

    2. Contact OneCare support - still a valid solution. If the problem can't be solved by the front line tech, you would want to get the problem escalated.

    3. One customer reported that they found this in their firewall exceptions, but I'm assuming that it wasn't OneCare's firewall. However, entering a new port exception for this may be the solution:

    "SharePort Network USB Utility UDP" using Port 9303

    You've already added the program to the exceptions, but you would also need to add UDP port 9303 - assuming this information would work.

     

    If the information from #3 doesn't work for you, please contact OneCare support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Friday, October 17, 2008 4:48 PM
    Moderator

All replies

  • The other thread offered a number of suggestions:

    1. Contact DLink Support. - unfortunately, the person who did that had no success as DLink support was clueless

    2. Contact OneCare support - still a valid solution. If the problem can't be solved by the front line tech, you would want to get the problem escalated.

    3. One customer reported that they found this in their firewall exceptions, but I'm assuming that it wasn't OneCare's firewall. However, entering a new port exception for this may be the solution:

    "SharePort Network USB Utility UDP" using Port 9303

    You've already added the program to the exceptions, but you would also need to add UDP port 9303 - assuming this information would work.

     

    If the information from #3 doesn't work for you, please contact OneCare support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Friday, October 17, 2008 4:48 PM
    Moderator
  • I have the same problem with my DIR-655 with SharePort and OneCare.  Unfortunately Boots' suggestion didn't work for me.

    Saturday, October 18, 2008 2:31 AM
  • OK.  Looks like I finally have it working.  Solutions were:

     

    Bring up the Firewall Settings.  Under "Advanced Settings", "Ports and protocols" tab, add the following:

    - Allow Port UDP 9303 (I have it as "inbound", but it might need to be "both ways")

    - Allow Inbound TCP Port 80

    - Allow Outbound TCP/UDP Port 53

    - Allow USB Protocol 6 with "both" checked

     

    Under the "Programs" tab, add the following:

    -  Add the "SharePort Network USB" program and check it as allowed.

     

    I'll tweak to see what is really needed.  I have everything checked as "local network (subnet).  These settings seem to work for me; However, not being an expert, I don't know if they are the most secure, so use at your own risk.  Post back if it works for others.

    Saturday, October 18, 2008 5:14 PM
  • Thanks Riffe!  Your settings worked for me too!  Let us know if you come up with a list of the minimal settings that are required to get this to work.

     

    Saturday, October 18, 2008 5:47 PM
  • Glad that it worked for you.  I have not had time to look at it further today, but the settings that I specified do seem to be the "minimal settings".  Delete or change any of them and it appears that the Shareport will not work.  You can fool around with the settings if you want and see if you agree.  Keeping everything to your local network/subnet should prevent outside intrusion but as new as I am to OneCare, I can't be sure of that.

     

    Sunday, October 19, 2008 1:04 AM
  • This worked well for me.  I did choose the "Local Network (Subnet)" setting.  I'm hoping this will eliminate issues outside the network addressing devices on the router.

     

    Sunday, October 19, 2008 1:47 AM
  • Thanks for finding these settings!  They work like a charm!

     

     

     

    Sunday, October 19, 2008 8:35 PM
  • As long as you set all the settings to the local subnet, you should be secure. The ports will still be closed to outside internet access.

     

    Great to have this working.

    Monday, October 20, 2008 4:02 AM
  •  

    It still amazes me that Dlink support didn't even think the program used ports....I mean they make routers....It kind of silly. I even spoke to a support manager who then sent me to a "high level" tech, who told me they basically don't know how the software works. I guess all the software is made by a 3rd party...so they don't even have support for it really...it blows ones mind.
    Monday, October 20, 2008 4:08 AM
  • Protocol 6 Both was all I needed.
    Tuesday, October 21, 2008 10:34 PM
  •  

    Yeah same here.  USB protocol 6 (both ways, local subnet) is all I needed to get it to work as well.
    Wednesday, October 22, 2008 9:18 PM
  • Well -- It seems to work for me, as well.  As I said when going through everything trying to make it work, I still needed to go back and tweak.  I went at this like every other computer hardware problem -- keep trying stuff until it works.  Anyway, glad that others had the time to do the "tweaking" to determine the minium set.  As of late, my job hasn't allowed me much time to do anything fun, so I was never able to get back to it.  Thanks to all that worked the solution.

     

     

    Thursday, October 23, 2008 1:21 AM
  • After all of that.  Now, after I installed the latest Windows Security Update (Cumulative Update for Media Center for Windows Vista (KB955519)), I'm back to GROUND ZERO again.  Not only did it trash out all of the settings that worked for Onecare -- It now won't even work on my Toshiba that was running Norton 360.  Turning the Firewall off doesn't even help now.

     

    This whole Shareport vs OneCare issue has become way more trouble than it is worth.  Thanks a lot for nothing Microsoft.  I'm done with wasting my time trying making this work.

     

    Good luck to the rest of you.  Just wish that I hadn't wasted the money on the USB drive.

     

     

    Saturday, October 25, 2008 3:09 AM
  • Shareport started working again later on with the Vista update (I should have noted that I have the 64-bit version) -- I did have to tweak Norton with 9303 port, but Onecare seems to still be playing well.

     

    (sigh)

     

    Saturday, October 25, 2008 2:02 PM
  • Yeah mine went bad with the Windows updates as well.  Had to enable port 9303 (in addition to usb protocol 6) to get mine working again.  What a pain.  Hope this isn't a pattern.  Dlink: nice feature thanks... but its worthless if it continually takes this effort to keep it working.

     

    Saturday, October 25, 2008 2:10 PM
  • I've found setting up only

    TCP port 20005 outbound (local network only)

    Allows me to work. 

    Sunday, November 16, 2008 8:55 PM
  •  

    USB protocol 6

    port 1000 - 65535

    Open on TCP/UDP Both Incommin and Outgoing. I set for internal network only to get some

    additional security

    Friday, February 20, 2009 10:21 PM
  • I tried these configurations and they worked!  
    BUT as soon as I switched from an ethernet (wired) connection to a wireless connection it failed again!

    Anyone has any suggestions to make this work on BOTH an ethernet and a wireless connection to the router ???
    Saturday, March 28, 2009 10:38 PM
  • The connection method should have no bearing on success or not if you configure the firewall per the above. Confirm that your wireless connection is shown as Home or Work. If not, it will be locked down, possibly causing the issue. Also, if the wireless and wired connections are both active, the network is Public no matter what the individual settings are since OneCare can't deal with multiple connections active in any other way.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare & Live Mesh Forum Moderator
    Sunday, March 29, 2009 7:39 PM
    Moderator
  • port udp 9303 was my problem... running vista x64
    Friday, May 29, 2009 9:48 PM
  • Hi guys,

    I've been working on that pb. for a week now. I have DIR655 (A4-1.21EU) and Shareport (1.14) on Desktop XP SP3 wired to the router. My firewall blocks for Shareport. I am pretty sure of that because as soon as I stop it, then I get connection to my HP Deskjet 930C via Shareport. If I start the firewall, then I lose it straight away...

    Now, my firewall is not Onecare but Bullguard Internet Security. I have allowed all of the ports decribed in the begining of this post, gave access to "SharePort Network USB" program BUT do not understand how to "- Allow USB Protocol 6 with "both" checked". WHAT IS THIS ? Something particular/special to Onecare Firewall ? Many places on the net, could I see that "USB Protocol 6" has to be enable to get Shareport to work but I do not know where to do that. PLEASE HELP ME...

    Wednesday, September 2, 2009 8:49 AM
  • Hi guys,

    I've been working on that pb. for a week now. I have DIR655 (A4-1.21EU) and Shareport (1.14) on Desktop XP SP3 wired to the router. My firewall blocks for Shareport. I am pretty sure of that because as soon as I stop it, then I get connection to my HP Deskjet 930C via Shareport. If I start the firewall, then I lose it straight away...

    Now, my firewall is not Onecare but Bullguard Internet Security. I have allowed all of the ports decribed in the begining of this post, gave access to "SharePort Network USB" program BUT do not understand how to "- Allow USB Protocol 6 with "both" checked". WHAT IS THIS ? Something particular/special to Onecare Firewall ? Many places on the net, could I see that "USB Protocol 6" has to be enable to get Shareport to work but I do not know where to do that. PLEASE HELP ME...


    Hello, Chrisy27.
    Sorry that you've been struggling with this, but since you aren't using OneCare, your best bet is to contact the vendor for your firewall or D-Link support for help if the information in this thread doesn't help.
    Yes, the reference that you asked about is the way you add an exception to the OneCare firewall for a specific port or protocol.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Wednesday, September 2, 2009 11:04 AM
    Moderator
  • Hi Steve,

    thanks for your answer, at least I understood that was something special to Onecare firewall...
    Anyway, after many attempts and using the command 'Netstat' I have been able to find the right ports to enable in Bullguard Firewall. I am very happy now...
    -Chrisy27 
    Wednesday, September 2, 2009 9:49 PM
  • Glad to read that you resolved it, Chrisy27.
    -steve
    Microsoft MVP Windows Live / Windows Live OneCare, Live Mesh, & MS Security Essentials Forums Moderator
    Thursday, September 3, 2009 11:22 AM
    Moderator