locked
Roles or team based work flow execution RRS feed

  • Question

  • I've got a work flow which is an on demand workflow, user gets to decide if he needs to run it or not.

    now the issue is we have got X role and we want that Workflow to be available only to all those user who has got the X role and not others. I tried to see option on workflow but was unable to view any such relevant option.

     

    Any idea how to achieve it


    KV
    Saturday, April 17, 2010 10:52 AM

Answers

  • Okay in that case please do following steps.

    1. make scope of the workflow to "User"

    2. make your self as owner of the workflow and publish it.

    3. now share with team only..

    they should fix your porblem and only user who have been shared the workflow will see this workflow and able to exceute it..

     

    • Marked as answer by Jim Glass Jr Tuesday, April 20, 2010 3:16 PM
    Monday, April 19, 2010 12:10 PM

All replies

  • Hi,

    Since this is ondemand workflow then you need to share this with relevant users so that user can see it..

    Simple thing to do this is scenario as per me is to create new team let's call it "X Team" and then add all the user who able to access the workflow in this team..

    Now go to workflow and share it with this "X Team"..so all team user will be able to access it now..

    future changes would be just to change team member for this "X Team".

     

    Saturday, April 17, 2010 10:59 AM
  • and who should be the owner and should be the scoop of the Workflow.
    KV
    Saturday, April 17, 2010 11:36 AM
  • Owner should be the person who have previlage to do the task mentioned in the workflow it self..

    scope does not matter for on demand workflow ...scope is useful only when you want to run the workflow automatically..

     

     

    • Proposed as answer by Mayank Pujara Monday, April 19, 2010 8:01 AM
    Saturday, April 17, 2010 8:27 PM
  • Tried as mentioned but other users who don't belong to that team still able to run the workflow.
    KV
    Monday, April 19, 2010 11:55 AM
  • Okay in that case please do following steps.

    1. make scope of the workflow to "User"

    2. make your self as owner of the workflow and publish it.

    3. now share with team only..

    they should fix your porblem and only user who have been shared the workflow will see this workflow and able to exceute it..

     

    • Marked as answer by Jim Glass Jr Tuesday, April 20, 2010 3:16 PM
    Monday, April 19, 2010 12:10 PM
  • This is really strange becuase I tested this at my end and works fine for me..

    what are the security roles these user have got? I mean user whom you have n't shared the workflow.

    particurely open security role and go to customization tab and check settings for workflow entity. what's setting set in this row? Please let me know and I might try to help further with this..

    Monday, April 19, 2010 2:23 PM
  • exceute workflow permission is fine....but what about read/write of workflow entity itself?

    read/write should be set to user and this should resolve this issue.

    Tuesday, April 20, 2010 7:58 AM
  • is it possible to share the security role screen print for thos users please?
    Tuesday, April 20, 2010 9:46 AM
  • couldn;t find way to upload attachment so uploaded on google site.

     

    http://sites.google.com/site/microcrm2010/crm 

     

    and then click on roles.bmp view.



    KV
    Tuesday, April 20, 2010 10:24 AM
  • Hace you tried adding all teams to the Sharing list and removing the privilages on the teams that you do not want to have access. Hence only tick the privileges for the required team and nothing for the others.
    MSCRM Bing'd - http://bingsoft.wordpress.com
    Tuesday, April 20, 2010 10:33 AM
    Moderator
  • Please make sure the other users security role looks like mentioned in the following screen print.

    http://drop.io/qynkvuk/asset/role-jpg

    if you just got one role for all users currently then copy this role to create new role and just change setting for workflow and assign this role to person you do not them to view the workflow.

     

    Tuesday, April 20, 2010 1:15 PM
  • Mayank I really appreciate your help. but this solution will work only if you have one work flow. what I mean is that the same user who is not allowed to run on demand workflow, updates an record which fires the workflow without Implementing this solution. it works fine. but if i implement this solution what it does it hides the On Demand workflow option but it doesn;t fire other workflows. 
    KV
    Friday, April 23, 2010 9:38 AM
  • well..in this case go for to have this workflow (which should be accessible only specific person) in different business unit.

    Let's say all user currently in BU called A, I an saying create other Business unit called B  (now B can be parent of A or sepearate altogather)

    Now do following steps.

    1. make your self or owner of the workflow in Business unit B.

    2. change all other user's security role to have workflow entity access to parnt child business unit.. make sure all other workflows should be owned by person with in same or child business unit. (see http://drop.io/4skannd/asset/rolenew-jpg for this)

     

    So this was your special workflow belongs to diffrent BU and only the users whom you share with will be able to access it..

    Hope this helps...

     

     

    Friday, April 23, 2010 12:19 PM