locked
E-mail router doesn't pull certain e-mails to Queue CRM 2011 (NoRecipientMatch) RRS feed

  • Question

  • Hello, I have an on premise Dynamics CRM 2011 configured to use the E-mail Router to pull mail to some queues.

    The queues have the tracking option "All E-mail Set"

    The owner of the queues has the tracking option "All E-mail in Response to CRM E-mail" set.

    The account used by the E-mail Router has the "All E-mail in Response to CRM E-mail" option set.

    So, with this configuration in place, email is getting pulled into the queue without resolving the who is it coming from, which is correct. However, when certain e-mails didn't show up, I activated the E-mail Router log and got the following errors:

    06/14/2011 04:42:33 : #60263 - The e-mail message with subject "<subject>" in mailbox <email> for delivery to http://<CRM URL> was rejected. Reason: NoRecipientMatch.

    06/14/2011 04:42:33 : #35241 - The recipients for the e-mail message with subject "<subject>" in mailbox <email> did not match any known records.

    So my question is why is this problem occuring, if all e-mail is supposed to get pulled into the queue? I tested resending this same e-mails, using the "To" field to enter the queue's address and I keep on getting this errors. Is it possible the email router has a bug or that the email contains something that doesn't allow the email router to process it correctly?

    Thanks in advance for any help!

    Thursday, April 26, 2012 12:00 AM

Answers

  • Hello, we did resolve our issue. We noticed the e-mail address we had set up for the queue had an alias address. For example, while the queue was set up for xyz@constoso.com, the mailbox also received mails sent to xyz@contoso.net. However, when the E-mail Router identified the alias addresss (xyz@contoso.net) in a message, there was no match with the queue's email address, and the message was rejected.

    • Marked as answer by Alex Garza Tuesday, May 29, 2012 9:12 PM
    Thursday, May 17, 2012 1:49 PM

All replies

  • Hello:

    Try approving primary e-mail of all the users using admin account


    Saurabh Gupta, MS CRM 2011 Software Development Engineer

    Thursday, April 26, 2012 9:29 AM
  • Thank you for your reply, unfortunately I tried this, retested and got the same error message.
    Thursday, April 26, 2012 3:01 PM
  • Has there been any success in tracking down this issue?  I have a similar issue where we have a support queue that all internal employees email.  All emails go to a mailbox and the email router picks them up and routes them to the proper queue in CRM.  This has been working fine for nearly a year.  There are a handful of users that when they submit a their emails make it to the mailbox, but when the router goes to pick them up, it rejects the email with the following error:

    #60263 - The e-mail message with subject "<Subject>" in mailbox "<Mailbox>" for delivery to https://crm.xxx was rejected. Reason: NoCorrelationMatch.

    I can submit emails all day from any other user, but these handful will fail consistently. 

    Thursday, May 17, 2012 12:49 PM
  • Hello, we did resolve our issue. We noticed the e-mail address we had set up for the queue had an alias address. For example, while the queue was set up for xyz@constoso.com, the mailbox also received mails sent to xyz@contoso.net. However, when the E-mail Router identified the alias addresss (xyz@contoso.net) in a message, there was no match with the queue's email address, and the message was rejected.

    • Marked as answer by Alex Garza Tuesday, May 29, 2012 9:12 PM
    Thursday, May 17, 2012 1:49 PM