locked
WCF RRS feed

  • Question

  • Hi,

    In my application I am loading the record in the Devexpress grid using WCF. The Grid is not showing morethan 6000 records where it is 25,000.

    Can any one help me on this?

     

    Regards,

    zameer

    • Moved by SamAgain Friday, September 3, 2010 2:29 AM not 64bit .net question (From:64-Bit .NET Framework Development.)
    Thursday, September 2, 2010 8:40 AM

Answers

  • Hi,

    Thanks for sharing your knowledge. But this is more like a  WCF question. So please consider WCF forum as a better option.


    Please mark the right answer at right time.
    Thanks,
    Sam
    • Marked as answer by Just Karl Thursday, September 4, 2014 8:45 PM
    Friday, September 3, 2010 2:28 AM

All replies

  • Hi,

    I found the answer, it may be right

     

    In the web.config we have to create the behaviour for datacontract serializer and given the value to the maxItemingraph attribute.

    <behaviors>
               
                <endpointBehaviors>               
                    <behavior name="EndPointBeh">                   
                        <dataContractSerializer maxItemsInObjectGraph="6553600"/>
                    </behavior>
                </endpointBehaviors>
            </behaviors>

     

    and then need to

     

    <endpoint address="http:/" behaviorConfiguration="EndPointBeh" binding="wsHttpBinding" bindingConfiguration="EndPoint" contract="ServiceContract" name="EndPoint">
                    <identity>
                        <dns value="localhost" />
                    </identity>
                </endpoint>

     

    Thursday, September 2, 2010 8:50 AM
  • Hi,

    Thanks for sharing your knowledge. But this is more like a  WCF question. So please consider WCF forum as a better option.


    Please mark the right answer at right time.
    Thanks,
    Sam
    • Marked as answer by Just Karl Thursday, September 4, 2014 8:45 PM
    Friday, September 3, 2010 2:28 AM
  • Hi Zameer,

    I think, that is configuration settings change . if you modify the buffer size based on the below configuration then, you cann't get any problem in your wcf service call. The modification you should do on the service side and then, modify you client also based on the mentioned buffer size.

    <system.serviceModel>
       <behaviors>
         <serviceBehaviors>
           <behavior name="TestLargeWCF.Web.MyServiceBehavior">
             <serviceMetadata httpGetEnabled="true"/>
             <serviceDebug includeExceptionDetailInFaults="false"/>
           </behavior>
         </serviceBehaviors>
       </behaviors>
       <bindings>
         <customBinding>
           <binding name="customBinding0">
             <binaryMessageEncoding />
             <!-- Start change -->
             <httpTransport maxReceivedMessageSize="2097152"
                            maxBufferSize="2097152"
                            maxBufferPoolSize="2097152"/>
             <!-- Stop change -->
           </binding>
         </customBinding>
       </bindings>
       <serviceHostingEnvironment aspNetCompatibilityEnabled="true"/>
       <services>
         <service behaviorConfiguration="Web.MyServiceBehavior"             name="TestLargeWCF.Web.MyService">
           <endpoint address=""
                    binding="customBinding"
                    bindingConfiguration="customBinding0"
                    contract="TestLargeWCF.Web.MyService"/>
           <endpoint address="mex"
                    binding="mexHttpBinding"
                    contract="IMetadataExchange"/>
         </service>
       </services>
     </system.serviceModel> 



    prabakaran.M

    Wednesday, August 27, 2014 6:28 PM