locked
OCS 2007 SE Setup Issue RRS feed

  • Question

  • Hello all,

     

    I have two servers running on Virtual Server 2005.

     

    The first is SRV-01 which is a Windows Server 2008 EE machine. It is a domain controller and runs exchange.

     

    The second is SRV-02 which is a Windows Server 2003 EE machine. It currently is a domain member and is running Performance Point server.

     

    I am trying to install OCS 2007 SE on SRV-02. I run the setup program, choose "Deploy Standard Edition", and then attempt to run the "Prep Schema" step. I accept the defaults for the "Prep Schema" step, but then I get the error message "Schema Preparation Wizard has failed" and the corresponding log shows error "Failure [0x8007203A] The Server is not functioning".

     

    The servers are able to see each other without issue. I can access domain resources from either server. I am logged in under an account which has full administrative rights (Domain, Enterprise, Exchange, Schema).

     

    Has anyone else encountered this or can maybe point me in the right direction?

     

    Thank You

    Monday, June 9, 2008 10:14 PM

All replies


  • Did you try prepare your active directory from the first server>?

    You can run the schema prep, forestprep and domain prep from server 1 and still you can install the OCS on server 2.

    As far as the mentioned error is concerned, it happens only when the server has problem contacting LDAP server ( Due to networking and firewall issue).




    Regards,
    R. Kinker
    MCTS - LCS 2005, MCTS - OCS 2007
    http://www.ocspedia.com
    http://www.itcentrics.com/LCS_Home.htm



    Tuesday, June 10, 2008 11:18 AM
  • Thank you for your reply.

     

    I am, however, unable to run the OCS 2007 Install from the first server because it is running Windows Server 2008 EE. OCS does not support install on that operating system, so it gives me an error when starting the application and does not allow me to proceed.

     

    I will attempt the following steps based upon your post:

     

    1) I will disable the firewall on both machines and see if this remedies the problem

    2) I will promote the second system to a domain controller, attempt the OCS install, then demote it back to a simple member server.

     

     

    I will post the results here once these steps are attempted.

     

    Thank You Again,

     

    Richard

    Tuesday, June 10, 2008 4:29 PM
  • Richard,

     

    Since the setup will not run on the Windows 2008 server, you'll need to manually run the forest and schema prep actions using lcscmd.exe.

     

    See this TechNet article for how to accomplish this:

    http://technet.microsoft.com/en-us/library/bb905979(TechNet.10).aspx

     

    Tuesday, June 10, 2008 4:53 PM
    Moderator

  • Hi Richard.. Jeff is right. You need to use LCScmd.exe to prepare your active directory. After that you would be good to go..

    And one more thing.. if you install OCS on a domain controller and demote it back.. the server will die. It wont run the same OCS again.

    This is one of the main reasons why it is not recommended to install OCS or any other application for that matter on a DC.

    please dont try second step.. just prepare your active directory using lcscmd.exe and run the OCS setup.

    http://www.ocspedia.com/Misc/Win2k8OCS2k7.htm


    Regards,
    R. Kinker
    MCTS - LCS 2005, MCTS - OCS 2007
    http://www.ocspedia.com
    http://www.itcentrics.com/LCS_Home.htm




    Tuesday, June 10, 2008 5:48 PM
  •  

    After running the Schema, then ForestPrep on the domain controller using LCSCmd.exe I then go back to the Win2003 box and attempt to do the OCS Install.

     

    The OCS Install wizard starts up and goes to the page that checks the status of the Schema and the Forest. This page doesn't reflect that I have already executed the Schema Prep and Forest Prep on the DC and is the same as it was before, and of course trying to execute these steps fails (as it did before)

     

    All the operations executed via the LCSCmd command finished successfully. The remote registry service is running on the DC. Both Srvr's firewalls are disabled.

     

    Any further suggestions?

     

    Tuesday, June 10, 2008 6:27 PM
  • Depending on how many domain controllers you have make sure you allow enough time for any AD replication to complete between servers.  If this is a single-DC forest then replication doesn't apply and something else is the culprit.

     

    Tuesday, June 10, 2008 6:46 PM
    Moderator
  • Yes, this is a single DC, single member server scenario.

     

    Both machines are VMs, both connected via a virtual network. Neither server has any other problems seeing each other....

    Tuesday, June 10, 2008 6:53 PM
  • If I wanted to do everything from the command line to bypass the fact that the wizard doesn't recognize that the Schema has been prepped I would have to:

     

    Run the Schema Prep

    Run the Forest Prep

    Run the Domain Prep

    Run the Server.msi file from the OCS2007 Install CD on the Win2003 Machine

     

    Is that all? Is there also some database instance that needs to be setup, or is that part of the Server.msi setup process?

     

    Thanks again.

    Tuesday, June 10, 2008 7:02 PM
  •  

    The solution that I discovered was as follows:

    Code Snippet
    Execute on SRV-01: "LCSCmd /schema /action:schemaprep"
    Execute on SRV-01: "LCSCmd /forest /action:forestprep"
    Execute on SRV-01: "LCSCmd /domain /action:domainprep"

    Execute on SRV-02: "Server.msi SERVER=SE"

     

     


    The last step above may fail a couple times, telling you which prerequisites that you need to install.

    After installing all the prereqs (as indicated) and running Server.msi again the operation completed without error!

    Tuesday, June 10, 2008 7:23 PM
  •  

    Of course I have now ran into another issue!

     

    After successfully completing the main setup, I wanted to install CWA on the OCS server. I ran the CWA Install step and it completed without error. I then ran the CWA Activate step and it returned the error:

     

    "Setup did not find Microsoft Office Communications Server 2007 in the Domain."

     

    I am sure this is related to the problem that I experienced earlier (couldn't prep schema from machine targeted for OCS install). I cannot activate the server from the other machine though.

     

    Any thoughts?

    Tuesday, June 10, 2008 7:43 PM
  •  

    Well, I was re-reading through the link that was pointed out earlier and I realized that I hadn't activate the SE server.

     

    So I went back to the DC and ran the following line:

     

    Code Snippet
    LCSCmd /server:SRV-02.DOMAIN.LOCAL /role:SE /action:activate /password:PASSWORD

     

     

     

    It ran through the activation process and completed successfully.

     

     

    However, I still cannot activate the Communicator Web Access on SRV-02.

     

    Tuesday, June 10, 2008 8:02 PM
  • Additionally I have ran the CheckLCServerState command and everything came back green.

    Tuesday, June 10, 2008 8:31 PM


  • Before trying to install CWA.. could you login in Office coomunicator and chat?


    Regards,

    Wednesday, June 11, 2008 9:49 AM
  • That's a very good question. I got frusterated with the issues that I was having, so I shut down the VM (that OCS was installed on), removed the computer account from the domain, created a new Server 2003 install and attempted to rejoin / reinstall OCS and I am running into the exact same issue!

     

    Again, the two machines can communicate, I can access domain resources on either from either, their times are syncronized. I just can't wrap my mind around what could be happening here...

    Wednesday, June 11, 2008 4:44 PM