locked
CRM 2011 Online - Solution update, 0x80040217, solution With Id = abcdefgh-eac5-4d26-8390-abcdefghijkl Does Not Exist RRS feed

  • Question

  • Have tried this on 2 CRM instances with the same result.

    I am installing a managed solution (it is mine and comed from an unmanaged dev server).

    I wanted to change an entity in my solution from a custom entity into a custom activity.  I did this and then decided to remove the old entity by using the technique of having 2 solutions, the primary one would not have the old entity and a temporary one would.

    I ended up with both installed and then I removed the secondary solution.  Hey presto, no entity.

    Now I am installing an updated version of the primary solution and it fails on a specific entity with the error as shown in the subject of this message.

    The entity in question did have a reference to the deleted entity in it so can understand why that one has failed (sort of since it may have some remnant of an association with the deleted entity).

    Can anyone tell me how to get around the problem?

    Do I need to change the solution I am installing or do I need to look at the Customizations section in the CRM instance and make an unmanaged edit to the existing solution?

    I have no way of noing what the actual issue is: a relationship; a plugin????

    Wednesday, October 31, 2012 4:21 PM

Answers

  • In the end this was solved by the Microsoft Team.  The Dynamics CRM Online database contained invalid metadata which was removed with a SQL Script.
    Tuesday, December 11, 2012 9:53 AM

All replies