none
WHS drives from storage pool showing as "not added" including system disk RRS feed

  • Question

  • So this weekend, my WHS took a dive so I am looking to the pros for some insight so I can tackle this issue as soon as I get off work tonight. Please bare with me as I am not at home currently so I am limited on the amount of detail I can provide.

    Basically, I purchased a new 2TB SATA drive to replace the last 500GB drive in my WHS. I removed the drive and after several hours it finished removing files and gave me the ok to yank it from the system. So I shut down, pulled the drive and proceeded to install the new one. ALSO, (I'm starting to suspect this is what caused the issue) I decided to add a different 500GB IDE drive at the same time. Since I am maxed on SATA port usage I figured this would give me some more usable space. This is the first IDE drive I have ever put in the system. So while it was off, I added a 2TB SATA, and a 500GB IDE. 

    When I booted it back up, all seemed fine because I went straight to the storage tab so I could add the new drives to the pool. I tried to add each one but each failed. This is when I noticed that 3 of my 4 other drives were showing as "not added" including the system drive itself and also started receiving file conflict errors. It also is stuck on the "calculating storage space" and doesn't show the pie chart anymore. To sum up what all I did, I rebooted, ran chkdsk, prayed, sacrificed chickens, did a raindance, all to no avail, nothing worked to rectify this issue. What's weird is I can access all my data, thank god, so I did manage to hook up the two disks and just formatted them and gave them drive letters and copied everything to them (which took a day and a half), but I would still really really like to get this back to normal without having to do a reinstall and/or further compromising the 2.5TB's of data.

    So after much Googling I have only found a couple of posts here and there about similar issues but one of them said something about if doing a reinstall, the install process MUST see the system drive as "Disk 0" otherwise a recovery won't be possible and will require a full new install. This got me to thinking, could installing the IDE drive have screwed up the boot order of the drives and could this lead to the issues I am seeing? I do specifically remember seeing that the system disk is NOT disk 0 but I don't know that it ever was as I never paid attention to that. Does anyone know if WHS is this picky? And if so what would be the best way to fix it? If I were to remove all of the NON-system drives naturally the system would become disk 0 again but would it stay there after I put all of the others back in?

    I could shoot myself for doing this, but my WHS is a home built box, so back when I built it, I put a video card in just for the install then removed it after it was no longer needed. This was a high end video card that I didn't need so I have since sold it. And of course now that I really need it, it's gone, so there is no way for me to see the BIOS until I buy another but that won't really help me tonight.

    So anyone intimiately familiar with either this issue or if WHS needs it's disk assignments to stay consistent? Any help would be greatly appreciated.
    Monday, February 22, 2010 4:38 PM

All replies

  • Stop and buy a cheap ($30) PCI video card on your way home. It will be good enough to see the BIOS etc. and you will need it in order to be able to reinstall anyway.

    As for disk assignments: Windows Home Server will normally adjust to having a disk move from one interface to another, changing ports, etc. but the system drive and the boot drive (in any system, not just Windows Home Server, and I'll note that the two may not be the same drive) are different and "special".

    Probably a server reinstallation/recovery will be the only way to get everything back to normal; I don't know what caused Windows Home Server to reach the state it has (and I've not been able to recreate it except by adding an old Windows Home Server system disk to a new server), but there's plenty of anecdotal evidence that it's no recoverable short of server recovery. The problem is that you may be unable to get a server recovery to work, given the state of your server. So it's good that you've backed up your data...

    I'm not on the WHS team, I just post a lot. :)
    Monday, February 22, 2010 4:57 PM
    Moderator
  • Thanks for the response Ken. Recovery is about the last thing I want to do so my gameplan at this point will be to get a video card so I can see what's going on in the BIOS, but first thing I'm going to try is removing all disks except the system drive so it will become 0 again and see what happens to it's status. If I do that and it shows as normal and no longer as "not added" then I can just re-add the storage pool disks (one-by-one if necessary) and try to get things back in order.

    My logic is: when I added the IDE drive, and since there has never been an IDE device in the system, that it changed the order in which the disks are enumerated and essentially confused the system because the system drive changed. It would probably be safe to assume that under normal circumstances a system drive would not change it's device order but by introducing an IDE device, it caused the board to reorder it's devices. Due to the age of this motherboard, it makes sense (maybe only to me) that if an IDE device were connected, by default it would be given a higher priority since there were no SATA CD-ROMS back then and CD's typically come before HDD's in boot sequence.

    I am not overly hopeful but at this point it's all for posterity anyway and if it actually works then great. To be honest though, this has shaken my confidence in my WHS overall as a platform. It has had it's small issues here and there since I built it but nothing like this. What concerns me is that I have upgraded several drives (all SATA previously) and it always went over without a hitch, just like all signs indicated would be the case this time as well so I don't know what went wrong or why but I do know there was no prior indication of any issues at all. Pretty frustrating to say the least.
    Monday, February 22, 2010 5:54 PM
  • Hi,

    I just found one of my HDD "not added". It shows up where it suposed to be in my storage pool. If I diconnect it and connects it agin it shows up as added but every time WHS restarts it is "not added" It contains about 1TB of data that I do not want to lose. This happend after i installed a new 2 TB disc. When I try to remove the HDD the WHS says that I do not have enogh free space even if I have 3,3TB free. I also do not get the "cake" of how much space I have left when this disc is not added. My system files are on a completly diffrent HDD. Should I try to reinstall? Will I then lose all my data? I have 7TB of data right now, all family pictures and all my music...Please help!!

     

    Monday, April 12, 2010 6:58 PM