locked
Backups freeze at 67% RRS feed

  • Question

  • I am very new to servers and WHS so bear with me if I ask stupid questions.

    I have bought a Acer Apire Easystore with WHS to use primary as a backup server for 2 computers. The 2 computers that are connected to it are running Windows 7 64-bit. I did not find out till later that WHS doesn't work well with Windows 7 64-bit.

    My problem is that my backups freeze at 67% and never finish. I have updated WHS to the latest and greatest. Is there anything else I can or should do?
    Saturday, March 13, 2010 1:55 PM

All replies

  • Hi,

    Is this when you are trying to make a backup, or restoring from a backup?  I'll assume you are getting the problem when you are backing up.  My guess is you have a second drive and the failure is happening because there are errors on this disk. 

    On you Windows 7 PC you need to run eithe run chkdsk /r on each drive from the command prompt or in my computer right click on each drive, select properties and run check diks making sure you check both checkboxs to fix errors and to scan and test the whole disk.

    Windows Home Server works fine with Windows 7 64-bit.   The only gotcha is on restoring 64-bit OSes where you actually need the 32-bit drivers for the first part of the recovery.

    Cheers,
    Al


    --
    Saturday, March 13, 2010 4:26 PM
  • Ok, I ran chkdsk and checked both boxes to scan and fix any errors. I also found that I was missing a raid driver in my device manager which I updated but the problem still exists. Is there anything else I could try to resolve this issue?
    Sunday, March 14, 2010 8:08 PM
  • 67% suggests to me that it's afailing on the backup of the 3rd drive.  With most W7 installs you will have a 1/200MB System Partition and then a partition taking up the rest of the first physical drive with the OS on (C:)  do you have a D: or some other drive connected because I think it's failing here.  

    For example did you have an eSATA drive connected and configured for backup and now it's not present?  In which case you should go through the configure backup option from the Windows Home Server console - actually it#'s worth going through this option again to check.
    --
    Sunday, March 14, 2010 8:25 PM
  • Yes I do have a D: drive that was orginally set up as a back up drive, but when I configured WHS, I did not add drive D: to backup. I will do a chkdsk on D: and let you know my results.
    Monday, March 15, 2010 2:32 AM
  • Please check the Event Viewer on the client for potential related error messages.
    More log files can also be found on the server (Start/Run %qlogs%) and on the client (C:\users\all users\Microsoft\Windows Home Server\logs), which may help to determine, at which point the backup stops to continue.
    Best greetings from Germany
    Olaf
    Monday, March 15, 2010 7:05 PM
    Moderator
  • OK, did a chkdsk on D: and no error's were found.

    I looked up the event viewer and the only potential problem that I could find is:

    Log Name:      System
    Source:        Service Control Manager
    Date:          3/15/2010 9:14:15 PM
    Event ID:      7011
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      JeffsComputer
    Description:
    A timeout (30000 milliseconds) was reached while waiting for a transaction response from the ShellHWDetection service.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7011</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2010-03-16T01:14:15.534180600Z" />
        <EventRecordID>15712</EventRecordID>
        <Correlation />
        <Execution ProcessID="668" ThreadID="1000" />
        <Channel>System</Channel>
        <Computer>JeffsComputer</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">30000</Data>
        <Data Name="param2">ShellHWDetection</Data>
      </EventData>
    </Event>

    I started a backup at 9:09pm and this happened at 9:14pm which is right about the time that my backup freezes. I have no idea what this means or even how to fix it if this is even an issue.
    Tuesday, March 16, 2010 9:44 PM
  • From the Windows Home Server Console under Backups - select your client PC and go through the configure stage again.


    --
    Wednesday, March 17, 2010 10:37 AM
  • OK, did that and no change.
    Friday, March 19, 2010 12:35 AM
  • Does anyone else have any idea's? I'm at a loss
    Friday, March 26, 2010 9:11 PM
  • Does anyone know what this means?

    The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID

    {5F36DC27-B076-4D0C-BD8C-7AEE14022193}

    and APPID

    {D3D96827-F7A7-4C54-A65F-EDC42D9EBB5E}

    to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    Jeff

    Saturday, March 27, 2010 12:49 AM
  • Hi Jeff,
    login to the machine, which shows the behavior, run regedit and search for that key. That should help to resolve the name of the application or service, which is causing the warning.

    With that information you can use the Component Services in Control Panel/Administrative tool to adjust the permissions under Computers/My Computer/DCOM after right clicking the component, selecting Properties and going to the Security tab. Here you would have to grant the permission to the account Network Service.

    (About the timeout error, which seems to indicate a problem with a hardware component in your computer, you can find a lot of hits in the web.)

    Best greetings from Germany
    Olaf

    Saturday, March 27, 2010 8:16 PM
    Moderator
  • The app name is "mdmcls32.exe" and it is under internet explorer/low rights/elevation policy in the register. I cant find it in the component services and I'm not sure even what this file does? Is this something that I should even try to fix?

    I almost feel like I missed a step in setting up the WHS. For example, I can see the server in the network but when I try to configure Windows 7 to backup to the server, it does not see it. I can start the backup from WHS but not from Windows 7. Is this anything?

    Saturday, March 27, 2010 9:31 PM
  • As far as I can tell, this file is not part of a normal WHS installation (at least cannot find it on my WHS, but I have no Acer model).

    Sources in the Internet tell about CA Internet Security suite as the application related to this file. Since such program should not be installed on the server, it may well be a reason for connectivity issues.

    Best greetings from Germany
    Olaf

    Sunday, March 28, 2010 9:14 PM
    Moderator
  • It's all starting to make sence now, at one time, I was running CA on my home computer. But when I tried to uninstall it and add Kaspersky, Kaspersky kept telling me that CA was not unistalled correctly. I bet that is where some of my problems lie. Now I just need to figure out how to fix that issue.

    Also, is there a way to check the event viewer on the server? and if so how?

    Thanks, Olaf, you have been a lot of help.

    Jeff

    Tuesday, March 30, 2010 7:43 PM
  • ...
    Now I just need to figure out how to fix that issue.

    Also, is there a way to check the event viewer on the server? and if so how?

    ...

    Server reinstallation/recovery would be the supported method. As for the event viewer, it's not exposed in the console, so viewing it is "unsupported". Doing so is, however, pretty harmless. Log in to your server using Remote Desktop (log in as the local administrator account using the server's console password) and you'll have a full desktop experience. Just be careful; as I said this is unsupported and there are tools that you may be familiar with from other versions of Windows that can cause serious problems or data loss.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, March 30, 2010 8:18 PM
    Moderator
  • Ok, I may be wrong, but I don't believe that Remote Desktop is supported by windows 7. Is there another way or does someone know if this issue has been fixed. I will try to find the file again and hopefully they have fixed that issue.
    Wednesday, March 31, 2010 9:19 PM
  • The remote desktop client is included with Windows 7: Start/All programs/Accessories.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, April 1, 2010 1:42 AM
    Moderator