locked
Qwest M1000 and Port 4125 Issue RRS feed

  • Question

  • Currently I'm trying to get the remote access portion of WHS to work properly. I am able to view/manipulate files via the web interface, as well as get into the remote control portion as far as it prompting me to use the attached printers/clipboard, etc. Once I get that far into the remote access portion it attempts to connect and immediately throws an unable to connect, connection dropped error (can't remember exact error offhand).


    I have the modem set to forward the ports 80, 443, and 4125. I confirm that I can get through (and see traffic) on the port 80 and 443 side, but using some tools I can see that 4125 still doesn't seem to be forwarding, or at least not getting to my machine properly. I had originally thought that it was because I was using a Linksys router behind the Qwest modem, but I took that out of the picture  and now have the WHS box hooked directly up to the modem.


    I've verified that I have the firewall on the modem disabled and that the ports forwarding properly. I've also put the machine into the DMZ and I still can't remote to the actual machines. Has anyone else on Qwest with a M1000 modem had similar issues or am I missing something?


    Thanks
    Tuesday, February 5, 2008 8:18 PM

All replies

  • It sounds to me like your ISP is blocking port 4125 for some reason. You can go to Shields Up! to test your ports.
    Tuesday, February 5, 2008 9:26 PM
    Moderator
  • That was my theory too, but according to Qwest and also people on their forums they do not block any ports. But it sure doesn't seem that way.

    The ShieldsUp report seems to be slightly confusing. It reports as closed, but it says it responded to a request...


    Results from probe of port: 4125

        0 Ports Open
        1 Ports Closed
        0 Ports Stealth
    ---------------------
        1 Ports Tested

    THE PORT tested was found to be: CLOSED.

    TruStealth: FAILED - NOT all tested ports were STEALTH,
                       - NO unsolicited packets were received,
                       - A PING REPLY (ICMP Echo) WAS RECEIVED.

    Tuesday, February 5, 2008 9:38 PM
  • I have the same issue with my TP-Link TD8840 ADSL router.  ShieldsUp shows ports 80 and 443 are both open, but I get exactly the same report as abtbear for 4125.  In addition, it says "Unknown protocol for this port".  Does that mean I've set my router up wrongly somehow?  When I open my ports in the router config I identify them all as TCP protocol - is 4125 TCP?  My router gives me a choice of TCP/UDP, TCP, UDP, ICMP.  I'm new to playing with routers so apologies if that's a dumb question.

    Saturday, March 8, 2008 1:22 AM
  • OK - I've just found this http://www.myitforum.com/forums/m_145673/printable.htm where a poster says 4125 should show up as "Closed" with ShieldsUp.  I gather 4125 only gets opened when a remote desktop session is started.  Is that right?  Doesn't help me because I still can't get WHS to accept my ports 80, 443 and 4125 are forwarded.

    Saturday, March 8, 2008 1:44 AM
  • I am having the same problem with a different Qwest modem a Actiontec GT701-WGv2. I configured port forwarding for 80 443 and 4125 and have success with the first two but not 4125. portforward.com doesn't have a WHS link yet but looking at different user defined set ups and using port 4125 doesn't work. 

    I can get sheilds up open results on 80 and 443 but my best efforts only get a closed or stealth result on 4125. I don't think the last comment on the sheilds up result being closed is accurate because I opened a remote desktop connection to another computer in the network and scanned to port and it returned closed result.

    Was there ever a solution to this problem posted somewhere else that someone might be able to point me to?

    Thanks from an eager but sometimes frustrated "student". It has been a great learning experience but I want to get over this hurdle soon!!!!
    Friday, March 13, 2009 2:11 AM
  • Just a bump to see if this was fixed.  The M1000 seems to have faulty routing baked in and is an all around POS.  The only way I got the WHS remote connection to work was to place it behind a netgear router with the ports setup using UPnP.  I then had to DMZ the netgear router.  Everything worked for the first day and then the M1000 started to block all microsoft services.  hotmail.com, live.com, MSN.com, anything using passport.....  At this point I regret moving to a place that only had qwest DSL.  The issue is how DSL modems work.  If they just were modems like the cable surfboard modems, we would not have problems.  Its when the DSL modem has a router built in where things get messed up.

    Don't use the Actiontec M1000 if you want to access your WHS from the internet. 
    Staple Bench Computers

    Actually I fixed it.  You have to forward UDP port 4125.  I should have known that as 2wire DSL modems need UDP port 3389 for RDP to work.
    Friday, June 12, 2009 9:07 AM
  • Your best bet is going to be to put the DSL modem in bridge mode. (Broadband modems don't make very good routers, so no great loss. :)) Your ISP can tell you how to do that. You may then have to configure your router to authenticate; your ISP can also give you some help there, but will probably not be able to tell you step by step how to configure your router unless they supplied it with custom firmware.
    I'm not on the WHS team, I just post a lot. :)
    Friday, June 12, 2009 2:45 PM
    Moderator
  • I have the exact same issue after 1 successful day of remote acces to my WHS using port forwarding on 80, 443, and 4125 using User Defined rules, something begins to block the passport services.  My m1000 is port forwarding using application forwarding to my router:

    1.  Selecting the 'web server' (HTTP and HTTPS ports 80 and 443) category to create and add the rule to the router device

    2.  Selecting the 'user' (RDP port 4125). 

    My linksys WRT54g (ver 1.1) is port forarding the same 80, 443, and 4125 to my WHS (HP MediaSmart Server) via DHCP address.  Once i apply this rule, all msn traffic is being blocked from a workstation.  Once i remove the m1000 port forwarding rules, it works just fine to access msn.com, hotmail, etc.  Thoughts based on you adding UDP port 4125. 

    Did you setup as a User category and then add the ports and the mapping to 4125 to get it to work? 

    THANKS in advance..   

    Tuesday, July 27, 2010 6:16 PM
  • It had been a while but I believe all I did was forward UDP port 4125 to the WHS.  I eventually swapped out the m1000 for a Netgear that operated much faster with no issues blocking any MSN or passport services..


    Staple Bench Computers

    Friday, May 18, 2012 4:39 PM