none
Console and Remote Access problems RRS feed

  • Question

  • Hi,
    I have two minor issues with my WHS; Logging on using the console from other computer and remove access.

    Using the Console, the WHS rejects the correct Administrator password when attempting to log on from other computer than the WHS server. Obvioulsy the smae password was accepted when the Console was installed. This has worked previously but has hit some snag recently. I have the same error from XP SP3 and Vista SP1.

    Remote access to the server, which likewise used to work, also does not function.

    Any ideas?

    Thanks!
    Monday, November 3, 2008 4:42 PM

All replies

  • What happens if you reboot your server?
    I'm not on the WHS team, I just post a lot. :)
    Monday, November 3, 2008 6:23 PM
    Moderator
  • Hi Ken,
    I have tried rebooting the server and loggong on initially from a desktop - with no success. I still get the message "password is incorrect", which is not the case. 
    All other functions like backups, shared folders etc works beautifully.

    Bo
    Monday, November 3, 2008 10:52 PM
  • Bo,

    A few items to check:

    To ensure that your Passwords do match, on the Client machine: Start, Run, type control userpasswords2 after pressing Enter, this will open a window that lists your actual login names. From this, select a user and check it's Properties,  this will show the Name used for Login, plus also the displayed name. Just ensure these match what you want.

    Next check:
    Also on the Client computer, open Explorer and navigate  go to C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys and see that the FOLDER AND ALL FILES in it have Full permissions for the Administrators GROUP and SYSTEM account.

    Also,
    On the client computer: Start, Run, type rundll32.exe keymgr.dll, KRShowKeyMgr, press Enter. Inthe resultant list, find the name of your WHS, highlight it and then Delete. Logoff, then back Log back inagain, you will then need to update your password one final time through the WHS client.

    These all ensure the Client(s) are correct.

    If one of these steps don't help. let us know, and we'll go from there.

    Colin





    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Tuesday, November 4, 2008 5:49 PM
    Moderator
  • Hi Colin,

    thanks for reply.

    I have done No 1, and confirmed the login name of my client (I tried this on my Vista) is equal to what's in my WHS.

    I have also checked the folder indicated for permissions, and as far as i can understand it, the Aministrator account has full permission, and the 'everyone' account limited permissions to the folder.

    Finally, I checked the last commend. Surprisingly, there is no mention of my WHS in the list of log-ons. Perhaps this is the issue?

    Bo

    Friday, November 7, 2008 1:39 PM
  • Hi Bo,
    please login locally to the server and check the event log.
    I had a similar behavior a while ago after upgrading a server to PP1.

    This machine had two issues:
    • the Windows Firewall was somewhat misconfigured (you can test this by temporary disabling)
    • a lack of permissions for the IIS guest account, which showed itself in the event log as DCOM error, pointing to the GUID for the Windows Home Server Transport Service (which made it reject each attempt to enter the password from a remote system). Fixing the permissions in Administrative Tools/Component Services solved that behavior.
    Best greetings from Germany
    Olaf
    Friday, November 7, 2008 2:20 PM
    Moderator
  • Hi Olaf,

    Checking Event Viewer, there are indeed a number of logged errors related to DCOM. I am not sure if the error relates to remote logon though. The properties window details "The application-specific permission does not grant Local Activation permission for the COM server application with CLSID (...) to the user NT AUTHORITY\NETWORK SERVICE SID etc". Does that sound familiar?

    In Component Services, can you provide more detail of what specific program i should change permissions for?

    Thanks, 

     

    Friday, November 7, 2008 3:05 PM
  • Hi Bo,
    Bo Lundqvist said:

    Checking Event Viewer, there are indeed a number of logged errors related to DCOM. I am not sure if the error relates to remote logon though. The properties window details "The application-specific permission does not grant Local Activation permission for the COM server application with CLSID (...) to the user NT AUTHORITY\NETWORK SERVICE SID etc". Does that sound familiar?

    In Component Services, can you provide more detail of what specific program i should change permissions for?


    simply try again a log in, check the event log and watch the time stamp as well to see, if the errors are related.
    But yes, this sounds familiar.
    There is a GUID mentioned in the events as well, I assume (such a long number in {} brackets?
    1. Copy this GUID to the clipboard (right click on the selection and Copy) and open regedit on the server.
    2. In Registry editor hit F3 key and press Ctrl+V to paste the GUID.
    3. Search for the GUID.
    4. Once found, check the content of the key for clear text name of the service.
    5. Keep that information in mind.
    6. In Control Panel/Administrative Tools/Component Services open Component Services/Computers/My Computer/DCOM config.
    7. Search for the application you found.
    8. Right click on it and select Properties from context menu.
    9. Open the Security tab.
    10. Check the status of Launch and Activation Permissions.
    11. If it is not set to Default, may be something you installed on your WHS altered the permissions.
    12. By clicking Edit right from the Customize radio button you could add the Network Service account or whatever is claimed to lack permissions, otherwise you also could try the Default settings (if it is currently set to Customize).
    13. If finished, click OK and try again. (I think, a reboot is not necessary, but practice will show.)
    Good luck
    Olaf

    Friday, November 7, 2008 3:26 PM
    Moderator
  • Hi Olaf,

    I will need to ask for some more of your help to get through this. This will for sure be my first encounter with this part of Windows Server.

    I have tried failed log-ins to see if i can capture the error in Event Viewer/Security. There are regular logon/logoff for both users of my WHS, which i assume is normal. What i have assumed is my failed remote login is an event called 538 or 540 by NT AUTHORITY/ANONYMOUS LOGON. The workstation name and IP correlates to the PC i am using to attempt to logon to the Console. Here's a dump from the Event Properties;

    <<Event Type: Success Audit
    Event Source: Security
    Event Category: Logon/Logoff
    Event ID: 540
    Date:  11/8/2008
    Time:  10:21:41 PM
    User:  NT AUTHORITY\ANONYMOUS LOGON
    Computer: MOTHER
    Description:
    Successful Network Logon:
      User Name: 
      Domain:  
      Logon ID:  (0x0,0x3C79AFB)
      Logon Type: 3
      Logon Process: NtLmSsp
      Authentication Package: NTLM
      Workstation Name: BO-PC
      Logon GUID: -
      Caller User Name: -
      Caller Domain: -
      Caller Logon ID: -
      Caller Process ID: -
      Transited Services: -
      Source Network Address: 192.168.1.102
      Source Port: 0 >>

    From here, i am not sure what to do with the info I have. Obvioulsy no GUID. Ideas? Is this the correct error captured?

    Cheers,



    Saturday, November 8, 2008 3:38 PM
  • Hi Bo,
    that looks like a successfull network login with guest account.
    But the GUID is what should be in your former posting mentioned as CLSID (damn geek abbreviations ;-) ):
    Bo Lundqvist said:
     "The application-specific permission does not grant Local Activation permission for the COM server application with CLSID (...) to the user NT AUTHORITY\NETWORK SERVICE SID etc".

    Best greetings from Germany
    Olaf
    Saturday, November 8, 2008 5:19 PM
    Moderator
  • Hi again Olaf,
    I did a new search focusing on DCOM and found a number of errors with GUID reference numers. I followed your instructions and found the GUID number refers to two applications related to IIS ('IIS WAMREG admin service' and 'IISADMIN'). I changed properties from 'custom' to 'default' which changed the SYSTEM user's priviligies to same as ADMIN. After re-start, I have the same issue...

    Do you have any other ideas I can try out? Or, is it possible I am not on the right error?

    Bo
    Saturday, November 8, 2008 6:07 PM
  • Hi Bo,
    well, since those are not WHS components, setting this to default may not the proper solution.
    Please try to go the custom way and add the user account (i.e. Network Service) with the appropriate permissions.

    If this starts to get to complicated, a server reinstall followed by applying the Windows updates and reestablishing user accounts and client connections may be the other option.

    You also can export the event logs, zip them and drop me a mail where to download for evaluation.
    E-Mail address should be in my profile.
    Best greetings from Germany
    Olaf
    Saturday, November 8, 2008 7:00 PM
    Moderator
  • I have the same problem here, and from what I have read so far, is reinstalling the only way to fix this?

    Was the OP able to get the connector software working on client PC's ?
    Wednesday, November 12, 2008 9:55 AM
  • Since he did not answer to my email which I sent him after looking into his event logs I can't tell, if he could fix his system.
    Best greetings from Germany
    Olaf
    Wednesday, November 12, 2008 10:07 AM
    Moderator
  • Hi Bo,
    in your event logs I found a message \SystemRoot\System32\RDPDD.dll failed to load.
    Do you have a NVidia video card?
    In this case try to import the following lines to the registry of your server after saving them with Notepad in a text file with extension .reg:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
    "SessionImageSize"=dword:00000020


    Taken from http://blogs.technet.com/brad_rutkowski/archive/2008/01/04/systemroot-system32-rdpdd-dll-failed-to-load.aspx
    After importing reboot.

    Best greetings from Germany
    Olaf

    Thursday, November 13, 2008 11:35 AM
    Moderator
  • Thought I would check back on this thread, as I had it book marked.

    I also have a Nvidia card, so I did as Olaf sudjested, and I can now access the Console from my laptop.

    TYVM.


    now I got to get my remote desktop/remote access working from when I messed with the settings trying to get around ISP blocking port 80 and such, but that would be for another day and another thread.

    Thanks again,

    Dale
    Sunday, December 14, 2008 11:36 AM