locked
Communicator Web Access desktop sharing not working... RRS feed

  • Question

  • So I have a complete OCS 2007 R2 environment setup. We have one server for Standard edition OCS 2007 R2, one consolidated Edge Server in a DMZ and now another server serving as a web interface. I just install the web interface and everything seemed to go fine but the Desktop Sharing (it is grayed out). Everything else works since we also have a reverse proxy (ISA 2006). You can get communicator on your phone, and expand distribution list from the outside, everything in meetings works... etc.. so my Edge server and OCS Reverse Proxy seems to be working fine, but why is the web interface not working?

    Now I told the web interface NOT to use SSL. Could this be why its grayed out? Does it need SSL to work?
    Friday, September 25, 2009 1:57 PM

All replies

  • If the option is grayed-out in the client this is typically an indication that the Meeting policy has not yet been configured.  Desktop sharing is disabled for all users by default when OCS is first deployed, you'll need to modify the meeting policies configuration to enable this.

    Take a look at the Meetings tab in the Global Properties window and either (1) edit the Default Policy and enable web conferencing and program/desktop sharing, or (2) change the Global Policy setting to either Policy 1, 2, or 4.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Friday, September 25, 2009 3:02 PM
    Moderator
  • I have enabled desktop sharing on the server before? Communicator and LIVE Meeting work 100%. There isn't a problem with desktop sharing there. The problem is desktop sharing with the Communicator Web Access. I did double check what you suggested and Enable program and Desktop sharing is checked

    But like I mentioned about when I deployed it, I used a CA from the Internal.. but as to accessing the website I told it does NOT require SSL (which was NOT recommended). But for the time being I do not have a CA from Digicert or anything. I was wondering if not having it use SSL was the cause of desktop sharing not working
    Monday, September 28, 2009 11:56 PM
  • Hi Jacob

    It is odd issue that you run into, and i can not reproduce it in my lab.
    I want to confirm something that you referred, what do you mean by "bu as to accessing the website i told it does NOT require SSL"?
    Although the desktop sharing with the communicator and live meeting work fine, but it is not very related with the CWA client. So, I think you should confirm you have prepared the certificate for the CWA server correctly? When you access the OCS, you must use :https://Im.DomainName.com.  That is you must issued a CERT for the client, either by your CA in your domain or third-party CERT. You can refer to below link:
    http://technet.microsoft.com/en-us/library/dd425345(office.13).aspx 
      
    If i misunderstand your issue, please tell me.
    Regards!

    Tuesday, October 6, 2009 8:04 AM
    Moderator
  • Hi
    Any update for your issue!

    Regards!
    Thursday, October 8, 2009 9:05 AM
    Moderator