locked
WHS 2011 RTM Domain Setup Error with existing godaddy SSL RRS feed

  • Question

  • I have install WHS 2011 RTM. I have a domain listed with godaddy.com listing is valid for 9+ more years.

    Also, I have a Standard SSL certificate purchased from godaddy which is valid for 4+ years.

    My router is setup to forward 80 and 443 to my WHS box. Set Up Your Domain Name wizard also recognizes that my domain is with godaddy.

    BTW: I have used advance option in the Wizard and removed the “remote” from remote.mydomain.com, as I am trying to use “mydomain.com” without any remote or www in the start.

    nslookup mydomain.com  resolves to my IP address correctly.

    In the domain setup wizard in WHS, I get following error:

    An error occurred while setting up your domain name

    The domain name was not setup for your server. Wait a few minutes and run the wizard again.

    An unexpected or unknown problem occurred. Please wait a few minutes, and then try again.

    I did not buy this domain or SSL certificate through the URL that WHS is providing, because as per this post:

    http://social.microsoft.com/Forums/en/whsvailbeta/thread/9c7b7e93-e0fa-4cb8-a368-31043c320cbe

    <copy> If you have purchased a certificate, and are simply re-installing, just choose that you have your own domain name, and when you launch the partners website (in this case GoDaddy's) just close the website and finish the wizard.  GoDaddy will re-issue the same certificate that you had before. </copy>

    Does any expert here know what is going on? I have tried this like 20 times since yesterday.

    BTW: I know how to manually import godaddy SSL certificate in to IIS manager, but with this approach RD Gateway does not work.

     

    Here is a tutorial to manually setup domain name for SBS 2011 Essentials (which is very close to Vail), but I do not see any such option in the Vail RTM.

    http://www.channelprosmb.com/blog/entry/23801/SBS-2011-Essentials-setups-setting-up-a-domain-name/

     

    Monday, April 11, 2011 1:34 AM

Answers

  • I have seen the same behavior. It appears that it doesn't recognize the manually installed cert and replaces it upon boot. I also saw a warning about the certificate in the console and it wanted to repair it for me.

    I eventually got it to work, but I probably changed a lot more than necessary. I just installed a VM to test with and found that it really is a simple fix.


    Assuming you are using godaddy for the domain and already have a cert manually installed, all you need to do is change this registry entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Domain Manager\Providers\E423C85D-6B1F-4583-95E0-449D8263BAC4\UseV2CertificateSupport
    Change the DWORD to 0

    Then you can go through the domain setup. This will setup the name and ddns, but will install a self-signed cert. Then just change the IIS binding back to your actual cert.

    -timotl

    • Marked as answer by mss786 Tuesday, April 12, 2011 7:58 PM
    Monday, April 11, 2011 1:13 PM

All replies

  • BTW: I know how to manually import godaddy SSL certificate in to IIS manager, but with this approach RD Gateway does not work.


    Well, RD Gateway works OK after manually installing godaddy SSL certificate in the IIS. But, after server reboot I get this error:

    You computer can't connect to the remote computer because no certificate was configured to use at the Remote Desktop Gateway server. Contact your network administrator for assistance.

    Monday, April 11, 2011 3:19 AM
  • I have seen the same behavior. It appears that it doesn't recognize the manually installed cert and replaces it upon boot. I also saw a warning about the certificate in the console and it wanted to repair it for me.

    I eventually got it to work, but I probably changed a lot more than necessary. I just installed a VM to test with and found that it really is a simple fix.


    Assuming you are using godaddy for the domain and already have a cert manually installed, all you need to do is change this registry entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Domain Manager\Providers\E423C85D-6B1F-4583-95E0-449D8263BAC4\UseV2CertificateSupport
    Change the DWORD to 0

    Then you can go through the domain setup. This will setup the name and ddns, but will install a self-signed cert. Then just change the IIS binding back to your actual cert.

    -timotl

    • Marked as answer by mss786 Tuesday, April 12, 2011 7:58 PM
    Monday, April 11, 2011 1:13 PM
  • I have seen the same behavior. It appears that it doesn't recognize the manually installed cert and replaces it upon boot. I also saw a warning about the certificate in the console and it wanted to repair it for me.

    I eventually got it to work, but I probably changed a lot more than necessary. I just installed a VM to test with and found that it really is a simple fix.


    Assuming you are using godaddy for the domain and already have a cert manually installed, all you need to do is change this registry entry:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Domain Manager\Providers\E423C85D-6B1F-4583-95E0-449D8263BAC4\UseV2CertificateSupport
    Change the DWORD to 0

    Then you can go through the domain setup. This will setup the name and ddns, but will install a self-signed cert. Then just change the IIS binding back to your actual cert.

    -timotl


    Thank You timotl. With this registry change, I was able to complete the domain setup. But, I still get this error:

    Your computer can't connect to the remote computer because no certificate was configured to use at the remote desktop gateway server.

     

     

    Monday, April 11, 2011 5:55 PM
  • Hmm.. Wonder if the ts gateway doesn't refresh it's cert without rebooting?

    I can't test the VM from the outside (network guy would have a coronary)... I can set one up at home later and try again if needed.

    -timotl

    Monday, April 11, 2011 6:17 PM
  • Timotl, thanks for trying to help. I will reboot WHS when I'm home in the evening. BTW: I am also running WHS 2011 in a hyper-v VM.

    Monday, April 11, 2011 7:13 PM
  • Even after reboot broblem is not fixed. I still get the no certificate for gateway server.

    BTW: After the certificate change in IIS server it was working for some minutes and then stops working again. There must be some background service running to update things with TSGateway.

    Tuesday, April 12, 2011 12:12 AM
  • I started a VM to test with, but didn't get to the cert part yet...

    I didn't mention this because I thought it turned out to be a waste of time, but at one point I did setup a live domain, release it, and resetup my godaddy one and install the cert.

    What cert is TS Gateway trying to use? I assume it's self-signed right? is the certificate name your server name or your godaddy domain?

    -timotl

     

    Tuesday, April 12, 2011 3:42 AM
  • I started a VM to test with, but didn't get to the cert part yet...

    I didn't mention this because I thought it turned out to be a waste of time, but at one point I did setup a live domain, release it, and resetup my godaddy one and install the cert.

    What cert is TS Gateway trying to use? I assume it's self-signed right? is the certificate name your server name or your godaddy domain?

    -timotl

     

    Hi Timotl, thanks for your help! TS Gateway did not have any certificate when I got that error. I have a good news to report.

     

    I saw an alert in the WHS dashboard that was something like Remote desktop setup has problem, there was an option to repair. I selected that option and it installed my godaddy certificate for RD gateway and problem is fixed.

     

    Once again thank you!

    Tuesday, April 12, 2011 7:58 PM
  • Glad that eventually worked!

    I still plan to start from scratch and see what is and isn't necessary to get this all working. Not as much motivation now that it's working though..

    -timotl

    Tuesday, April 12, 2011 8:17 PM