locked
Rendering Sharepoint Document Library Images in SSRS RRS feed

  • Question

  • SSRS Question:
    ============
    I’ve an entity in my CRM for Image URLs. The images are stored in Sharepoint Document Library.

    I’ve a report which will load the dataset with all image URL’s and display the Images in Report. But the images are not getting displayed in SSRS reprot. If I add a image url from any of the public website those images are perfectly getting displayed. But not the Images from Sharepoint Server.

    Both CRM / Database / Reprot Server / Sharepoint Server are in the same domain.

    My first thought is as Sharepoint Server works on AD Users, so user impersonation might be an issue. What would be the better way I can display images in SSRS Report.

    Any help would be greatly appreciated. Thanks in advance.


    Thanks, Ranjitsingh R | http://mscrm-developer.blogspot.com/ | MS CRM Consultant
    Tuesday, April 6, 2010 7:10 AM

Answers

  • Here are the steps:

    • login to the server where SSRS is installed
    • Start -> All programs -> Microsoft SQL Server 20XX -> Reporting Services Configuration Manager (or something like that)
    • Connect to the current server
    • Go to execution account on the left navigation menu
    • Specify an account that has access to the image library
    • Validate
    • restart SSRS service
    • Try again your report!
    Just a remark, it is a good thing somehow to try by yourself resolving issue or configuring application. I just don't know how you can progress if you ask always the full procedure... I know you can't know everything, but as soon as you have a hint, you should try to continue by yourself...

    Anyway, I hope you have enough information to resolve your problem


    My blog : http://mscrmtools.blogspot.com
    You will find:
    Bulk Delete LauncherView Layout replicator
    ISV.Config Manager Form Javascript Manager
    Assembly RecoveryAnd others (use tool tag on my blog)
    • Marked as answer by Ranjitsingh R Tuesday, April 6, 2010 8:15 AM
    Tuesday, April 6, 2010 7:34 AM
    Moderator

All replies

  • I already faced this problem.

    If you didn't configure SSRS with an execution account that has access to the SharePoitn library, then the image won't be displayed.

    In other terms, you need an execution account set for your SSRS deployment. This account must have at least read access to the image library.

     

    Hope this helps!

     


    My blog : http://mscrmtools.blogspot.com
    You will find:
    Bulk Delete LauncherView Layout replicator
    ISV.Config Manager Form Javascript Manager
    Assembly RecoveryAnd others (use tool tag on my blog)
    Tuesday, April 6, 2010 7:22 AM
    Moderator
  • Could you please let me know what are the steps to configure the Execution account ?

    It would be good if you provide detailed steps if possible. Please take some time out and let provide me the details

    Thanks,


    Thanks, Ranjitsingh R | http://mscrm-developer.blogspot.com/ | MS CRM Consultant
    Tuesday, April 6, 2010 7:28 AM
  • Here are the steps:

    • login to the server where SSRS is installed
    • Start -> All programs -> Microsoft SQL Server 20XX -> Reporting Services Configuration Manager (or something like that)
    • Connect to the current server
    • Go to execution account on the left navigation menu
    • Specify an account that has access to the image library
    • Validate
    • restart SSRS service
    • Try again your report!
    Just a remark, it is a good thing somehow to try by yourself resolving issue or configuring application. I just don't know how you can progress if you ask always the full procedure... I know you can't know everything, but as soon as you have a hint, you should try to continue by yourself...

    Anyway, I hope you have enough information to resolve your problem


    My blog : http://mscrmtools.blogspot.com
    You will find:
    Bulk Delete LauncherView Layout replicator
    ISV.Config Manager Form Javascript Manager
    Assembly RecoveryAnd others (use tool tag on my blog)
    • Marked as answer by Ranjitsingh R Tuesday, April 6, 2010 8:15 AM
    Tuesday, April 6, 2010 7:34 AM
    Moderator
  • You are absolutely correct. But as i already spent log of time on it. Now I would like to resolve this ASAP by anymeans.

     


    Thanks, Ranjitsingh R | http://mscrm-developer.blogspot.com/ | MS CRM Consultant
    Tuesday, April 6, 2010 7:38 AM