locked
Backup fails at 0% RRS feed

  • Question

  • I've searched these (and other) forums and seen lots of similar issues but many of the threads were very old.  I've never seen a definitive answer, and I've tried most of the options I've run across so far with no luck, so I'll ask again.

    My LAN is a WHS and two Vista Home Premium 64 clients.  Both clients have an almost identical software load.  WHS automatically backs up one client just fine.  Backups of the other client always fail at 0% with an error message about "Unable to create volume shadow copy".

    VSS is enabled and started.  Several other services that I saw mentioned also are started.  I forget the command but I listed the vss services on the faulty client and there were 7, all of which showed no errors and stable.

    Both machines had Acronis True Image 11 installed.  I uninstalled it from the balky machine and it made no difference.  Both machines also have Nero 8 installed.  I have not uninstalled it from the balky machine yet, as uninstalling every piece of backup or burning software I own isn't my idea of a solution, especially if an identical machine with the same software has no problems.

    I'm hoping this is a well-known issue by now and someone can point me to a clear solution. 

    Thanks,

    RJ

    Edit:  Oh yes, I am able to initiate ntbackup from the WHS and back up either client successfully, if that means anything.
    Thursday, April 30, 2009 11:01 PM

Answers

  • Oh well.  I tried everything I could find on the web and nothing worked.  Everything except a format and clean install of Vista, anyway.  A repair install took like 3 hours but didn't help.  Neither did the 4 hours I wasted re-running chkdsk /f /r on both drives.

    I was really hoping WHS would work for my needs but just couldn't solve that issue, so I gave up and installed linux.  Thanks anyway for the help.

    RJ
    • Marked as answer by richj44 Sunday, May 3, 2009 5:26 PM
    Sunday, May 3, 2009 5:26 PM

All replies

  • I would recommend you start by running chkdsk /r on the drive in the PC that's having problems. In addition, have you reviewed the event log on that PC for errors? Often an event is generated at the same time as the error you mention.
    I'm not on the WHS team, I just post a lot. :)
    Friday, May 1, 2009 2:52 PM
    Moderator
  • Ken,

    I have run chkdsk /r and also norton disk doctor and all drives on the client pc check out ok.  With the many many posts that I've found from others having this same issue who didn't have disk problems, I tend to think it's a red herring but just in case I ruled that out first.

    Event viewer is full of related entries with either of two errors which are repeated many times.  The first is:

    Source: VSS 
    EventID:  13
    Volume Shadow Copy Service information: The COM Server with CLSID {faf53cc4-bd73-4e36-83f1-2b23f46e513e} and name VSSEvent cannot be started. [0x80070057]

    Operation:

    Abort Backup

    Context:

    Execution Context: Requestor

    Current State: SnapshotSetCreated

    and also

    Source: VSS
    EventID: 12292

    Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {790f2886-9889-4c99-8ef5-531add05d044} [0x8007007e].

    Operation:

    Obtain a callable interface for this provider

    Add a Volume to a Shadow Copy Set

    Context:

    Provider ID: {262b716e-bb23-41b5-aaef-e2c15e767167}

    Class ID: {790f2886-9889-4c99-8ef5-531add05d044}

    Snapshot Context: 0

    Execution Context: Coordinator

    Earlier today I tried re-registering s list of .dll files I found in one thread with similar issues, as follows:

    1. From command prompt:

    Cd windows\system32
    Net stop vss
    Net stop swprv
    regsvr32 ole32.dll
    regsvr32 vss_ps.dll
    Vssvc /Register
    regsvr32 /i swprv.dll
    regsvr32 /i eventcls.dll  --
    got the error "The module "eventcls.dll" was loaded but the call to DLLInstall failed with error code 0x8000ffff"
    regsvr32 es.dll -- got the error "The module "es.dll" was loaded but the entry-point DLLRegisterServer was not found.
    regsvr32 stdprov.dll
    regsvr32 vssui.dll --  The module "vssui.dll" failed to load.
    regsvr32 msxml.dll -- failed to load 
    regsvr32 msxml3.dll
    regsvr32 msxml4.dll -- failed to load

    Anything not commented loaded successfully.  However, backups still failed at 0%.  It takes several minutes before it finally errors out with the "Unable to create volume shadow copy" message.

    I'll be glad to provide any other information that may help you or someone else point me in the right direction. 

    Thanks,

    RJ


    Friday, May 1, 2009 10:52 PM
  • FWIW, any product that "fingers" with VSS may break it.  I had Shadow Protect and even though I had uninstalled it I had to find it in the registry and kill it.  Though if both boxes have Acronis.... 
     
    How does the VSS listsing compare with the 2 boxes?
     
    Still......
     
    Grey
    "richj44" wrote in message news:5e0bafe6-49f0-445 c-8923-a23f33064671...
    I've searched these (and other) forums and seen lots of similar issues but many of the threads were very old.  I've never seen a definitive answer, and I've tried most of the options I've run across so far with no luck, so I'll ask again.

    My LAN is a WHS and two Vista Home Premium 64 clients.  Both clients have an almost identical software load.  WHS automatically backs up one client just fine.  Backups of the other client always fail at 0% with an error message about "Unable to create volume shadow copy".

    VSS is enabled and started.  Several other services that I saw mentioned also are started.  I forget the command but I listed the vss services on the faulty client and there were 7, all of which showed no errors and stable.

    Both machines had Acronis True Image 11 installed.  I uninstalled it from the balky machine and it made no difference.  Both machines also have Nero 8 installed.  I have not uninstalled it from the balky machine yet, as uninstalling every piece of backup or burning software I own isn't my idea of a solution, especially if an identical machine with the same software has no problems.

    I'm hoping this is a well-known issue by now and someone can point me to a clear solution. 

    Thanks,

    RJ

    Edit:  Oh yes, I am able to initiate ntbackup from the WHS and back up either client successfully, if that means anything.
    Friday, May 1, 2009 11:02 PM
    Moderator
  • FWIW, any product that "fingers" with VSS may break it.  I had Shadow Protect and even though I had uninstalled it I had to find it in the registry and kill it.  Though if both boxes have Acronis.... 
     
    How does the VSS listsing compare with the 2 boxes?
     
    Still......
     
    Grey


    Thanks for the suggestion.  I will post a comparison...both machines have multiple instances but they aren't all the same.  The "problem" client is as follows:

    Microsoft Windows [Version 6.0.6001]
    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

    C:\Users\Den>vssadmin list writers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    Waiting for responses.
    These may be delayed if a shadow copy is being prepared.

    Writer name: 'System Writer'
       Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Instance Id: {e04f7cde-e291-4609-8f79-30d3a1cb4534}
       State: [1] Stable
       Last error: No error

    Writer name: 'ASR Writer'
       Writer Id: {be000cbe-11fe-4426-9c58-531aa6355fc4}
       Writer Instance Id: {381321f8-81b0-49cc-9ed8-83f67786a4de}
       State: [1] Stable
       Last error: No error

    Writer name: 'MSSearch Service Writer'
       Writer Id: {cd3f2362-8bef-46c7-9181-d62844cdc0b2}
       Writer Instance Id: {464df0da-18cf-4da2-b213-2e74878bf256}
       State: [1] Stable
       Last error: No error

    Writer name: 'Registry Writer'
       Writer Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
       Writer Instance Id: {09a21790-a1fb-4260-88f1-7151ed385a67}
       State: [1] Stable
       Last error: No error

    Writer name: 'Shadow Copy Optimization Writer'
       Writer Id: {4dc3bdd4-ab48-4d07-adb0-3bee2926fd7f}
       Writer Instance Id: {d6c7181a-ed37-4992-962f-ff54b15be9b1}
       State: [1] Stable
       Last error: No error

    Writer name: 'COM+ REGDB Writer'
       Writer Id: {542da469-d3e1-473c-9f4f-7847f01fc64f}
       Writer Instance Id: {8ed73ec7-b1f0-420d-902d-09b4f84b11b6}
       State: [1] Stable
       Last error: No error

    Writer name: 'WMI Writer'
       Writer Id: {a6ad56c2-b509-4e6c-bb19-49d8f43532f0}
       Writer Instance Id: {ca750e89-a6ad-48a9-80d4-2be5410c94d3}
       State: [1] Stable
       Last error: No error


    The machine that is able to run backups successfully shows this: 

    Microsoft Windows [Version 6.0.6001]

    Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

     

    C:\Users\Office>vssadmin list writers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

     Waiting for responses.  These may be delayed if a shadow copy is being prepared. 

    Writer name: 'System Writer'
       Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Instance Id: {b5828813-3ef1-44f2-9eae-532219936336}
       State: [5] Waiting for completion
       Last error: No error

     Writer name: 'ASR Writer'
       Writer Id: {be000cbe-11fe-4426-9c58-531aa6355fc4}
       Writer Instance Id: {97bd5776-a762-4bdf-a2bc-a2acce871254}
       State: [1] Stable
       Last error: No error

     Writer name: 'Registry Writer'
       Writer Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
       Writer Instance Id: {c8a59869-da4e-4e81-ba7f-14ba952e5d16}
       State: [1] Stable
       Last error: No error

     Writer name: 'Shadow Copy Optimization Writer'
       Writer Id: {4dc3bdd4-ab48-4d07-adb0-3bee2926fd7f}
       Writer Instance Id: {f9d1abe1-6946-43c5-9ba5-f02dc2284942}
       State: [1] Stable
       Last error: No error

     Writer name: 'WMI Writer'
       Writer Id: {a6ad56c2-b509-4e6c-bb19-49d8f43532f0}
       Writer Instance Id: {becfc9d4-4119-4d1d-b32d-0e057f3663aa}
       State: [5] Waiting for completion
       Last error: No error

     Writer name: 'MSSearch Service Writer'
       Writer Id: {cd3f2362-8bef-46c7-9181-d62844cdc0b2}
       Writer Instance Id: {3065c884-34eb-453a-adbb-664e34b34c71}
       State: [5] Waiting for completion
       Last error: No error

     Writer name: 'COM+ REGDB Writer'
       Writer Id: {542da469-d3e1-473c-9f4f-7847f01fc64f}
       Writer Instance Id: {9489c581-7692-433b-8683-ed3c6b73239f}
       State: [1] Stable
       Last error: No error

     Writer name: 'BITS Writer'
       Writer Id: {4969d978-be47-48b0-b100-f328f07ac1e0}
       Writer Instance Id: {9973cc1a-93f1-4ce4-b994-df9806c71ca1}
       State: [1] Stable
       Last error: No error

     I have no idea why several instances are in a "Waiting for completion" state on the 2nd machine, but I was able to start a backup with no problems.  Being curious though, I cancelled it at 1% and rebooted.  The machine came up with everything in Stable state when it finished booting.

    Friday, May 1, 2009 11:27 PM
  • I think I have a clue now.  Last night I realized that i also had Norton Ghost on the problem client and uninstalled it, but still wasn't able to back up.  However, I just noticed that the Symantec symsnap vss is still showing up as a provider.  I'm going to figure out how to stop that from loading and reboot and try again...I'm going to be really disappointed, though, if it still doesn't work.

    Friday, May 1, 2009 11:38 PM
  • Nope, I'm still clueless.  I haven't removed the Symantec VSS provider but I was able to stop the service and boot with it stopped.  Still failing backups.  I dug up a little more info FWIW.


    C:\Users\Den>vssadmin list providers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    Provider name: 'Symantec Software VSS Provider'
       Provider type: Software
       Provider Id: {262b716e-bb23-41b5-aaef-e2c15e767167}
       Version: 1.0

    Provider name: 'Microsoft Software Shadow Copy provider 1.0'
       Provider type: System
       Provider Id: {b5946137-7b9f-4925-af80-51abd60b20d5}
       Version: 1.0.0.7


    C:\Users\Den>vssadmin list shadowstorage
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    Error: Unexpected failure: Catastrophic failure

    C:\Users\Den>vssadmin list volumes
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    Error: The volume shadow copy provider is not registered in the system.


    C:\Users\Den>vssadmin list shadows
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.

    No items found that satisfy the query.

     

    Saturday, May 2, 2009 12:21 AM
  • Oh well.  I tried everything I could find on the web and nothing worked.  Everything except a format and clean install of Vista, anyway.  A repair install took like 3 hours but didn't help.  Neither did the 4 hours I wasted re-running chkdsk /f /r on both drives.

    I was really hoping WHS would work for my needs but just couldn't solve that issue, so I gave up and installed linux.  Thanks anyway for the help.

    RJ
    • Marked as answer by richj44 Sunday, May 3, 2009 5:26 PM
    Sunday, May 3, 2009 5:26 PM