locked
Federation - Call terminated on media connectivity failure RRS feed

  • Question

  • hello,

    I have got a audio/video connectivity issue with federated partners.

    IM is working fine but when call is initiated it rings and fails approx 5-10 second after the pickup.
    In the ocs logger is 52031; reason="Call terminated on media connectivity failure"

    Thare are no problems with running external conferences, commmunication with external users is fine also.

    There are no events generated on access or a/v edge.
    Firewall is configured:
    a/v edge ext: 443 TCP in, 3478 UDP in, 50000-59999 TCP/UDP in/out
    a/v edge int: 443 TCP in, 3478 UDP in, 5062 TCP

    A/V edge internal configured on Forest level, Access edge also.
    Federation route configured on the Frontend server level (not possible to configure it on forest level due to LCS installation).


    Any idea?

    Thanks in advance for any hint.
    Michal

    Friday, December 14, 2007 4:56 PM

All replies

  •  

    Are you natting on you AV edge? does it happen with all federated partners or just one, could it be a issue there end, I have the same issue with one of ours and it turned out to be a issues at there end.

     

    You say it works for your clients externally, this makes me think that you are all set,

     

    feel free to contact me offline, I do not mind testing with you, we are currently federated with afew companies

     

    Blackduke

    Saturday, December 15, 2007 12:10 AM
  •  

    Hello,

     

    we are not NATting on our a/v edge, it has public IP.

    This happen to all federated partners now, but it was working before - something has changed and I don't know what.

    We have a testing OCS installation, but I'm not able to simulate the problem there.

     

    I welcome to make tests, could you please contact me on mimr0001@gmail.com?

     

    Many thanks

    Michal

    Monday, December 17, 2007 5:40 PM
  • I have the same Error. When the external client try to call internal client. I call was ended and the trace write this error.

    Call terminated on media connectivity failure

     

    Thanks

    Luca

    Tuesday, February 19, 2008 4:09 PM
  • I have exactly the same problem. All the IM and presence are working well, when I try to communicate using video hte invitation is correcly sended, I can answer, then the local video is displayed for each contect and the call ended with the message "call terminated on media connectivity failure".

    I've just a firewall on both internal connection of each edge server and a direct cable between both external interface.

    There is nothing in the firewall logs. There is no NAT.

    any idear?

     

    Thanks

     

    Sylvain

    Thursday, March 20, 2008 10:19 AM
  • The client MUST have the possibility to contact DIRECTLY the internal interface of the edge server. I've modified the firewall configuration and all seems ok know.

     

    Sylvain

    Friday, April 11, 2008 7:43 AM
  • I solved the issue some time ago and it was caused by the firewall between internal network and the DMZ where the OCS A/V adge is connected. there are simply two conditions which have to be fulfilled:
    • public interface has to be assigned with fully routable public IP address with no NAT
    • internal interface has to be fully routable (internal IP range) with no NAT as well

    Once I configured that all started working.
    FW can be in the row between Internet and A/V edge Public and also can be between A/V edge internal adapter and internal network, but there must not be used NAT in any form.

    Recently I found a nice whitepaper describing the perimeter configuration, setup of the server and finally the call flow setup, it is from June 2008. Could be much easier having this whitepaper end 2007 :-). Designing Your Perimeter Network for Office Communications Server 2007

    Cheers,
    Michal

    P.S. took me some time to update the thread
    Wednesday, October 29, 2008 4:43 PM