locked
Error While Backing Up to Server Backup Disk RRS feed

  • Question

  • My problem is that I have a removable hdd configured under Home Server as a Server Backup Disk for all of my shares (Music, Photos, Users, etc.).

    After running a backup, it fails every time with this message:

    Backing up  to  ARCHIVE
    Backing up Music...
    Failed to process file Music\System Volume Information : Access to the path 'D:\shares\Music\System Volume Information' is denied.
    6347 unchanged files linked from the last backup to save space

    How do I get around this problem?
    Wednesday, April 8, 2009 4:56 PM

Answers

  • "System Volume Information" is a folder, and it should normally be at the root of a drive; the question is how you managed to get one in your Music share.

    You could try something like this:
    • Log in to your server using Remote Desktop or physical console.
    • Open up D:\Shares\Music and try to delete the folder named "System Volume Information".
    • If you can't delete it, probably it's because the local Administrators group isn't the owner of the folder and files, so right click the folder and select Properties from the menu.
    • Select the Security tab.
    • Click the Advanced button.
    • Click the Owner tab.
    • If the local administrators group isn't the owner of the folder, select the group, turn on the check box next to "replace owner on subcontainers and objects" and click OK.
    • Confirm your way back out and try to delete the folder again.
    Note: I haven't tried this; I don't have a System Volume Information folder in any of my shares. It's what I would try first if I had a similar issue. However, you do the above at your own risk.

    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by kariya21Moderator Thursday, April 9, 2009 1:26 AM
    • Marked as answer by Straes Thursday, April 9, 2009 3:38 PM
    Wednesday, April 8, 2009 5:34 PM
    Moderator

All replies

  • "System Volume Information" is a folder, and it should normally be at the root of a drive; the question is how you managed to get one in your Music share.

    You could try something like this:
    • Log in to your server using Remote Desktop or physical console.
    • Open up D:\Shares\Music and try to delete the folder named "System Volume Information".
    • If you can't delete it, probably it's because the local Administrators group isn't the owner of the folder and files, so right click the folder and select Properties from the menu.
    • Select the Security tab.
    • Click the Advanced button.
    • Click the Owner tab.
    • If the local administrators group isn't the owner of the folder, select the group, turn on the check box next to "replace owner on subcontainers and objects" and click OK.
    • Confirm your way back out and try to delete the folder again.
    Note: I haven't tried this; I don't have a System Volume Information folder in any of my shares. It's what I would try first if I had a similar issue. However, you do the above at your own risk.

    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by kariya21Moderator Thursday, April 9, 2009 1:26 AM
    • Marked as answer by Straes Thursday, April 9, 2009 3:38 PM
    Wednesday, April 8, 2009 5:34 PM
    Moderator
  • This worked, at least somewhat.  Setting the permissions allowed WHS to backup the folder, but it did not allow me to delete it.  I thought that it was a leftover folder from my old music hdd backup, but the properties say it has been modified today...

    It works at least, but I still have no idea why the folder is there.  None of my other shares have this folder.

    Oh, and thanks again.
    Thursday, April 9, 2009 3:43 PM