locked
Static IP Address? RRS feed

  • Question

  • Is there a way to configure Windows Home Server on my HP EX470 to have a static IP address rather than requesting one via DHCP?

    Here's my problem.  I've got a LinkSys WRT54G router that does DHCP in a 192.168.5.100 range.  However, it now appears that my Cisco 678 DSL modem also acts as a DHCP server, assigning numbers in a 10.0.0.1 range.  The HP EX470 is getting its IP number from the Cisco device rather than from the Linksys.  Which means that I can't use the LinkSys to do the port forwarding that I need to do in order to allow external access to the EX470.  I found a manual for the Cisco DSL router and I should be able to Telnet to it and turn off the DHCP server, but it appears that Qwest (my DLS provider) has placed a password on the Cisco box so I can't log into it.

    So, if I could force the HP EX470 to use a static IP address (192.168.5.200, for example), it would solve my problem.  Or if I could force the EX470 to use the LinkSys's DHCP rather than the Cisco's.  I've read the EX470 installationo guide and the EX470 userr guide but neither seems to address this issue.

    Thanks.
    Sunday, January 4, 2009 9:50 PM

Answers

  • Hello,
    open a command prompt on the server and type
    ipconfig /all
    This will give you all informations you need to set the proper subnet mask, default gateway and DNS server (the both last values are usually the internal address of your router).
    Be aware, that each typo will make a connection impossible.
    Best greetings from Germany
    Olaf
    Saturday, January 10, 2009 8:38 PM
    Moderator

All replies

  • I should have noted that this is actually my son's HP EX470 Home Server.  I'm trying to help him get it set up but since he lives 250 miles away, I can't actually get my hands on it or peruse the setup screens.  So, if there is a way to set a static IP address, it would be great if you could give me a description of how to get there so that I can help walk him through it.  These things are always tougher when you can't actually see the screens yourself!
    Sunday, January 4, 2009 9:56 PM
  • Question on that network setup:
    Is the Linksys connected to the modem via its (the router's) WAN or LAN port?
    If the former, the server's DHCP request shouldn't make it to the gateway - it'll stop at the router.  The modem will hand the router's WAN side an address; the router will hand out addresses to the network.
    If the latter, however, you need to make some changes to the LAN - running two DHCP servers on one physical network creates issues, as you've seen.

    Problem #2 for you:
    If they're connected properly (modem --> router WAN --> clients), your ISP's password (which they should provide you with) protection on the modem/gateway will prevent you from configuring any port-forwarding in it.
    Question:  have you tried to simply connect to the modem's web-admin interface (which should be at 10.0.0.1)?
    You might need to connect a PC directly to the modem to do this (may or may not work thru the router.)
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, January 4, 2009 10:24 PM
  • Interesting question as to whether the Cisco DSL box is plugged into the LinkSys's WAN or LAN port.  I've called my son but he is out for a bit, so will have him check when he gets back.

    As for logging into the Cisco at 10.0.0.1, that's the first thing I tried, but it wants a password.  The manual (which I found online) says that the default is to just hit ENTER, but that doesn't work, so apparently Qwest has assigned a password.  I wasn't intending to set port forwarding on the Cisco box, but simply wanted to log into it and turn off the DHCP server function in the Cisco.

    Thanks for the reply!
    Sunday, January 4, 2009 10:37 PM
  • To be perfectly blunt, you're going to need to talk to Quest to get the logon password from them.
    If they won't give it to you, ask to talk to a supervisor.  Threaten (politely) to dump them as an ISP.
    If they still won't give it to you, either find another ISP (if possible), or buy your own modem that you can do with as you please.
    Bottom line:  if you can't configure anything on the modem/router (such as port forwarding; or, ideally, configuring it to run in bridge mode, so that your router can do its job on its own), you're not going to get this working.

    -Chris


    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, January 4, 2009 10:54 PM
  • If Qwest won't give me the password so that I can disable DHCP on the Cisco DSL box, I think I can still make this work if I can make the EX470 Windows Home Server use a static IP address and then configure port forwarding to that address in the LinkSys WRT54G router.  I just need to figure out whether I can make WHS do static IP rather than requesting an IP via DHCP.  Boy, do I wish I was there in person rather than trying to do this over the phone.  Oh well.  I'll keep digging on the forums.

    Not sure what you mean by making the Cisco DSL box run in "bridge mode".  But if I could get into the Cisco box at all I could turn off the DHCP function so probably wouldn't have to figure out what bridge mode is anyway.

    Thanks again for the replys.  I'm still hopeful that when my son gets back home and checks the Cisco-to-LinkSys cabling that he will find that it is plugged into a LAN port on the LinkSys instead of the WAN port.  As you said, if it is in the WAN port, the Cisco box shouldn't be trying to assign IP numbers to stuff connected to the LinkSys.  That would be a very simple solution, so I'm keeping my fingers crossed!


    Chris Cupler said:

    ...
    Bottom line:  if you can't configure anything on the modem/router (such as port forwarding; or, ideally, configuring it to run in bridge mode, so that your router can do its job on its own), you're not going to get this working.


    Sunday, January 4, 2009 11:31 PM
  • <<If Qwest won't give me the password so that I can disable DHCP on the Cisco DSL box>>
    Then you won't be able to configure any port-forwarding in it.  Remember:  it's not a 'dumb' modem - it's a modem/router (albeit one with only one LAN port.)
    <<...then configure port forwarding to that address in the LinkSys WRT54G router.>>
    That would, unfortunately, only be one part of the puzzle.  There will still be the matter of the gateway (for simplicity, that's what I'll refer to the Cisco box from now on.  After all, that's what it is..) blocking everything that comes knocking at the front door.  Forwading ports on the Linksys won't do any good, if the incoming packets aren't making it that far.  Sorry.

    <<I just need to figure out whether I can make WHS do static IP rather than requesting an IP via DHCP.>>
    That part's easy.  Remote Desktop into it (on a local machine, Start > Run > mstsc.exe > type the machine name or IP address of the server.  Username = Administrator, password= your_Console_password.  Setting a static IP address there is the same as it would be on an XP machine.

    Bridge mode:  disables all routing, DHCP, and DNS functionality on the gateway, demoting it (functinally) to a traditional 'dumb' modem (AKA 'set of blinking lights', with all of the advanced functionality disabled.)
    Your router handles the connection, and gets to do its job (being a router) unimpeded.
    This would be the preferred fix for your issues, as it eliminates the gateway's routing function (as well as its DHCP server, and the additional NAT layer that its routing function adds to your setup) as obstacles to overcome.

    Even if the Linksys is connected via a LAN port, and you disable the DHCP server on it (because, as said earlier, two DHCP servers on one LAN= bad and unpredictable), you still don't have any way to configure port-forwarding on the gateway - you can't log into it to change any settings. 
    Also, a quick Google search shows the 678 not having UPnP support.  No UPnP support = WHS can't auto-configure port-forwarding in the gateway.

    <edit>
    Did a little more Googling on this, and, there is a way to reset the passwords on the 678:
    http://www.qwest.net/help/faqs_ppp_convert675.html#lookpswrd
    This appears to fully wipe the NVRAM on the unit (which also means that the connection settings will be lost); therefore, you'll need to have Quest's PPPoE configuration info (as well as your username\password) on hand, to re-enter it into the modem (or, into the router, should you get the modem running in bridge mode.)

    And, to configure the gateway to run in bridge mode, see this forum post for instructions.
    </edit>

    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Monday, January 5, 2009 12:02 AM
  • Hmmm.   You are right.  I need to give the Cisco 678 a lobotomy.  Sounds like Bridge Mode would do the trick.  I also found a reference online that says that if you have a router behind the Cisco 678 and want to use the router for port forwarding you can log into the Cisco 678 and issue the following commands:

    enable
    set nat entry add 10.0.0.2
    write

    But of course you still need to be able to log into the Cisco 678.  I'm more than a bit worried about doing a reset on the Cisco box and reconfiguring it from scratch.  Especially since I'm not actually there in person to try to get it working again.  I guess we'll have to throw ourselves on the mercy of Qwest and hope that they will either give us the password, or better yet, log into it remotely and put it into Bridge Mode for us.

    This has all been excellent info.  Thanks!
    Monday, January 5, 2009 12:55 AM
  • Well, I'm actually at my son's house, sitting in front of the WHS box and starting this config process.  I'm trying to Remote into the WHS box via the MSTSC.EXE command.  All is fine until I actually try to log in.  I then get a message saying that this account "must be granted Allow Access thru Terminal Services rights".  The account I am using is the administrator on the WHS box.  I've checked the options for user config on the WHS box and don't see any options for setting "Access thru terminal services" rights.  The account does have "Remote Access" rights, but as near as I can tell this isn't the same thing.  Seems like I'm in a catch 22.  I need to remote the WHS box in order to give my account "Access thru terminal services" rights but I can't remote the WHS box without those rights.  Suggestions?
    Saturday, January 10, 2009 6:13 PM
  • Hi,

    What are you actually typing into the RDP box, it must be 'Administrator' and the appropriate password, not  a 'name' and password.

    Colin


    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Saturday, January 10, 2009 6:32 PM
    Moderator
  • Yeah, just figured that out.  I was using my son's userid rather than "administrator".

    I'm now remoted in and getting ready to configure the static IP address.  I'm assuming that the subnet mask should be 255.255.255.0.  Not sure what the Default Gateway should be?

    Also, when I set the IP to manual it also makes the DNS server manual.  What do I put in there for Prefered and Alternate DNS servers?


    Saturday, January 10, 2009 8:29 PM
  • Hello,
    open a command prompt on the server and type
    ipconfig /all
    This will give you all informations you need to set the proper subnet mask, default gateway and DNS server (the both last values are usually the internal address of your router).
    Be aware, that each typo will make a connection impossible.
    Best greetings from Germany
    Olaf
    Saturday, January 10, 2009 8:38 PM
    Moderator
  • That did it!  Thanks to all for the great answers!
    Saturday, January 10, 2009 8:58 PM