locked
>#9628 - An error occurred while delivering the e-mail message with subject "xx" in mailbox rtosales@xxx.com for delivery to http://crm.xxx.com/MainCRM RRS feed

  • Question

  • All,

       I'm pretty close to pulling all of my hair out on this issue. I will do my best to highlight my situation.

    1. CRM 2011 On-Premise on a single machine install of all roles. - MACHINE1

    2. Connecting to SQL Server 2008 R2 on a separate machine. - MACHINE2

    3. Created a MainCRM and SampleCRM org.

    4. Installed E-Mail router on the MACHINE1 and configured Incoming and OutGoing profiles.

    5. Added a new key under HKLM/Software/Microsoft/MSCM called DisableSecureDecryptionKey and set it to 1. (as per other posts)

     

    Scenario 1: (SampleCRM Org)

    1. Changed Email(tracking) and Marketing(Campaign responses) setings under SystemSettings to work with E-Mail Router.

    2. Created a Team called "RTO Marketing"to and set the owner to a user with Marketing Manager and System Customizer Roles.

    3. Updated the Default queue "<RTO Marketing>" to include an email address RTOSALES@xxx.com which is a valid and has proper domain credentials.

    3a. Changed email incoming and outgoing to use e-mail router and included the domain credentials for RTOSALES@xxx.com . Also selected to "process all E-Mails as activites".

    4. COnfigured Incoming Profile in e-mail router to use Exchange 2010 using EWS and use "USer Specified" 

    5. Outgoing to use SMTP server and windows authantication

    6. Setup a Deployment profile for SampleCRM.

    7. Load Data and mapped the Incoming and Outgoing profiles.

    8. Perform "Test Access" and everything works nicely.

    9. Send a Test email to this inbox and shows up in CRM as email activity under the "<RTO Marketing>" queue.

    10. Nice ending to this story for SampleCRM org.

     

    Scenario 2: (Main CRM Org. NOTE: Both orgs are hosted by the same CRM server).

    1. I do the exact same things as above on this org and i get the below the error.

     

    #9628 - An error occurred while delivering the e-mail message with subject "<subject>" in mailbox rtosales@xxx.com for delivery to http://crm.xxx.com/MainCRM. System.ServiceModel.FaultException`1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: systemuser With Id = 5d13f05f-58d9-e011-97b5-00155d02b10b Does Not Exist (Fault Detail is equal to Microsoft.Xrm.Sdk.OrganizationServiceFault).</

    I have tried anything and all, Including giving the Team "System Administrator role". What I'm not sure is where on earth is E-Mail Router figuring the System User ID: <5d13f05f-58d9-e011-97b5-00155d02b10b >.  I checked SystemUserBase and QueueBase tables to find anything resembling this UID and cannot find in SampleCRM and MainCRM.

    Please Help.

    Prabhakar

     

     

     


    Prabhakar Harita @ SA IT Services
    Friday, September 9, 2011 8:07 PM

All replies

  • This is similar to an issue which occured in CRM 4. Please verify that you have the latest UR installed.

    You may want to refer to this KB Symptom 3 for further infomation although it is related to CRM 4:

    http://support.microsoft.com/kb/956129

    Please write back if this resolves your issue.

     

    • Proposed as answer by Jeffrey Loucks Tuesday, September 13, 2011 4:00 AM
    Tuesday, September 13, 2011 4:00 AM
  • I have looked into this error on number of blogs and sites. No luck. Problem is this functionality was working for this org. I added the same email to SampleCRM org and ran the email router, while disabling the MainCRM router configuration. I came back around and disabled SampleCRM and enabled MainCRm and MainCRM email routing has completely stopped with this error being recorded in the Event Viewer.

    As last choice effort I'm trying to find out if there a way to reset the email router configuration and start from scratch with E-Mail router. Only trouble is that we already started a Quick Campaign from MainCRM and not sure what the impact will be. REply emails are still in the Exchange inbox in case we need to manually associate and promote into CRM.

    Thanks for looking into it.

    Search continues.


    Prabhakar Harita @ SA IT Services
    Thursday, September 15, 2011 5:48 PM
  • I suggest you review the CRM services and ensure they are still running and configured properly.

    Interesting informaiton for you:

    SystemDrive:\Program Files\Microsoft CRM Email\Service

    Microsoft.Crm.Tools.EmailAgent.xml

    This KB talks about the registry settings:

    http://support.microsoft.com/kb/906471

     

    Have you tried runnign the configuration Wizard?

    Friday, September 16, 2011 5:41 PM