locked
New User: Home Server Console cannot connect to home server RRS feed

  • Question

  • When I run the Windows Home Server Console, I get the error message 'cannot connect to home server'. I know this is some kind of name resolution problem because when I installed it, I had to set it up with the internet disconnected in order to have the 'Initiate' software find it. When the internet is connected, the server name resolves to some remote machine with the same name. Also when I ping the server name, I get some remote server IP address returned.

    I can access the home server from Explorer via the network workgroup folder, but I don't want to have to disconnect from the internet every time I need to run the home server console.

    I found the 'Windows Home Server client join troubleshooting hints' document that mentions this issue and says something along the line of 'you should configure your router to be a home DNS server' - but doesn't say how... 

    My router is a Belkin wireless ADSL modem/router and is set up to as a DHCP server and its DNS addresses are set to the OpenDNS servers.

    Can anyone explain how to give my local home server priority over these remote servers with the same name?
    Wednesday, October 29, 2008 6:53 PM

Answers

  • dlorde said:

    My router is a Belkin wireless ADSL modem/router and is set up to as a DHCP server and its DNS addresses are set to the OpenDNS servers.

    Please try setting your DNS servers to those provided by your ISP. OpenDNS, in it's attempt to be helpful (and build a business model), does some things that don't follow the relevant specifications. The result is that most users can't connect to their server with OpenDNS configured.
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by dlorde Thursday, October 30, 2008 4:24 PM
    Wednesday, October 29, 2008 10:21 PM
    Moderator

All replies

  • Hi,

    On your server and clients, their DNS servers should be your router, so they don't look outside your home network. In the individual Network Settings, they should each be set so they obtain both their IP address and their DNS server address automatically.

    An example of 'ipconfig /all' from a command prompt on one of my Clients is shown below:

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : xxxxx-PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Mixed
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : Home

    Wireless LAN adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . : Home
       Description . . . . . . . . . . . : Intel(R) Wireless WiFi Link 4965AGN
       Physical Address. . . . . . . . . : 00-13-E8-98-06-AD
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::a483:694e:a24d:7b67%9(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.120(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : 29 October 2008 03:08:01
       Lease Expires . . . . . . . . . . : 06 December 2144 01:40:12
       Default Gateway . . . . . . . . . : 192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    You could also try running 'discovery.exe' from the WHS folder in Program Files on the Client, this will search the network for your server, and if it finds more than one, lets you choose the one you want.

    Colin








    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Wednesday, October 29, 2008 7:17 PM
    Moderator
  • Thanks for the rapid response :-)

    OK, I set the Windows DNS server to be the router,  and I did an 'ipconfig /flushdns', and now my 'ipconfig /all' looks similar to the one you posted, but still no WHS Console access... 

    I'm currently copying gigabytes of data to the server, so I'll wait until that finishes, and reboot my PC to see if that does it.

    I'll post back either way.

    Thanks again,

    Dave
    Wednesday, October 29, 2008 8:46 PM
  • dlorde said:

    My router is a Belkin wireless ADSL modem/router and is set up to as a DHCP server and its DNS addresses are set to the OpenDNS servers.

    Please try setting your DNS servers to those provided by your ISP. OpenDNS, in it's attempt to be helpful (and build a business model), does some things that don't follow the relevant specifications. The result is that most users can't connect to their server with OpenDNS configured.
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by dlorde Thursday, October 30, 2008 4:24 PM
    Wednesday, October 29, 2008 10:21 PM
    Moderator
  • Resetting the DNS servers to my ISP servers did the job! 

    I originally switched because the ISP had a problem at one time, but they work fine now, and I can now access my Home Server through the Console :-)

    Many thanks for your help Ken, and thanks too to Colin for explaining about DNS setup.

    I am now officially a Happy Bunny ;-)

    Dave
    Thursday, October 30, 2008 4:15 PM
  • I know this is and old post, but I had a similar issue and none of this helped, but I did fix it.

    My Home server had lost it's Time so it was reset back to 2003 and apparently when the time on the desktop and the server get way out of each other the credentials get very wonky.  I was able to get on Via Remote desktop, so I just reset the time and it all worked fine.  Hope this helps someone save the Hours of frustration I had working with this problem.

    Sunday, December 21, 2014 3:22 PM