locked
Problem publishing a exported entity RRS feed

  • Question

  • Hi,

    I have this issue, when I try to publish changes in the LEAD Entity from a XML file exported from our testing environment. The publishing process don't finish showing a generic error window.

    Checking the XML file of the exported entity, we noticed that the relationships sections are missing.
    I try export another entity and I got the same problems.... any ideas?

    All CRM 4 environments are with UR-8

    Thanks in advance

    Thursday, February 4, 2010 2:05 PM

Answers

  • Have you tried turning Dev errors on when you publish to see if you receive a more descriptive error message?  You also might want to check the CRM logs.

    When you select an entity to export, you should receive a dialogue box that states something like:

    ........ mappings and relationships between the selected and any non-selected entities will not be included.........


    Please ensure that you have selected all entities that have a relationship to the entity you want to export before attempting the export, import and publish option.  Chances are you may not be able to publish the one entity because other dependent entities are missing.


    Best Regards, Donna
    • Proposed as answer by Donna EdwardsMVP Thursday, February 4, 2010 5:11 PM
    • Marked as answer by Jim Glass Jr Thursday, February 4, 2010 6:49 PM
    Thursday, February 4, 2010 5:06 PM

All replies

  • Hi
    So the only entity with any changes is the Lead? Are you just exporting that entity customisation?
    Rob
    www.crmconsult.info www.chorusit.com Twitter:robertpeledie
    Thursday, February 4, 2010 4:18 PM
  • Have you tried turning Dev errors on when you publish to see if you receive a more descriptive error message?  You also might want to check the CRM logs.

    When you select an entity to export, you should receive a dialogue box that states something like:

    ........ mappings and relationships between the selected and any non-selected entities will not be included.........


    Please ensure that you have selected all entities that have a relationship to the entity you want to export before attempting the export, import and publish option.  Chances are you may not be able to publish the one entity because other dependent entities are missing.


    Best Regards, Donna
    • Proposed as answer by Donna EdwardsMVP Thursday, February 4, 2010 5:11 PM
    • Marked as answer by Jim Glass Jr Thursday, February 4, 2010 6:49 PM
    Thursday, February 4, 2010 5:06 PM
  • Hi Robert,

    Yes, for now the changes are afecting only a that entity, but we were made changes in others before, whitout problems.
    Thursday, February 4, 2010 5:38 PM
  • Thanks Dona,

    Yes i can see the dialog box and turn On the Dev errors, but still appears the generic windows that appears a few minuts after publish,
    I wil try to exporting the others entities in the relationship and publish again, I let you know if it works.

    Regards
    Thursday, February 4, 2010 5:45 PM
  • Hi Donna

    I try your tip it's works in testing environmet, but still the same problem on producction server
    I will try to setup the relationships manually in this server.

    Thanks to much
    Thursday, February 4, 2010 7:41 PM
  • You're welcome, have a good day
    Best Regards | Twitter: edwardsdna
    Thursday, February 4, 2010 7:44 PM