locked
Cannot Resolve Unresolved Address RRS feed

  • Question

  • We are running Dynamics CRM 2013 6.0.2.51 DB 6.0.2.51 on-prem. We have the following problem, which happens regardless of whether you use the Outlook plug-in or go directly to the CRM website in a browser and happens on multiple computers:

    • Open an email with an unresolved address
    • Click on the address, which brings up the "Resolve Address" dialog
    • Click "Resolve to an existing record" (checked by default)
    • Look up the contact to which you want to resolve the record
    • Click OK
    • The email now shows the contact's name in place of the red, unresolved email address that it had before
    • Click Save
    • Press Control-S
    • Click Save a few more times
    • Press Control-S repeatedly hoping against all hope
    • Close the email
    • Open the email again
    • Address is still unresolved 
    • Curse the day that you ever recommend this horrible product to management, which is now the bane of your existence and the largest blemish on your reputation

    Has anyone else run into this issue or know what may be done to fix it?

    Thursday, April 23, 2015 9:24 PM

All replies

  • Are there any plugins registered against the email entity?  Custom code could error out in the background failing a validation check and preventing the record from being updated.

    Is the user account being used to update the email the actual owner or recipient of the email that is being manually resolved?

    Try giving the user the sys admin security role as a test to see if the issue persists.  It could potentially be a missing privilege that may not be getting displayed.

    If all above fails, you may want to try running a platform trace on the CRM server while performing the task to see if any errors appear.

     

    Jason Peterson

    Thursday, April 23, 2015 9:46 PM
  • There are no plugins registered against email entities and my user account already is sys admin. I turned tracing on, but there are no log entries at all. In addition, I ran a network monitor on my computer and can confirm that no communication to the server takes place when clicking Save. Lots of web requests when opening the email, web requests when looking up the contact, but nothing when you click Save. It appears that it is just simply not saving. This happens on Chrome 42, IE 11 and the Outlook plugin (which I assume uses IE behind the scenes). Have also tried on multiple computers.

    Thursday, April 23, 2015 10:11 PM
  • Looks like you are on Rollup 2.  Look at the fixes for rollup 3.

    https://support.microsoft.com/en-us/kb/2930480

    The first item in section "Issues that are resolved in Update Rollup 3 for Microsoft Dynamics CRM 2013" may be your issue.

    • Unresolved email sender is not displayed correctly on Email form

    Jason Peterson

    Thursday, April 23, 2015 11:55 PM
  • I applied SP1 followed by SP1 Rollup 1, which fixed the issue.

    What's interesting is that we used to be able to resolve unresolved recipients with no problem. Then, one of the updates broke this function. When you clicked on an email with an unresolved recipient, you could briefly see the name in red which would quickly disappear leaving behind only the semicolon separator and nothing to click on to resolve it. That particular bug was supposedly fixed in 2013 RTM rollup 1, was listed as fixed in the issue list, but was not fixed by that update. Eventually, it was fixed in RTM rollup 3. Why is that interesting? Because it means that the development team fixed a bug where the unresolved recipient's name would disappear and never even once bothered to actually click on the name and try resolving it to see if their fix actually worked all the way through. They must have just said, "well, the name is there now so we're good". Where is the quality control on this product?

    See this thread for more details:

    Unresolved Email Addresses Disappear with CRM 2013

    Tuesday, April 28, 2015 4:46 PM