locked
How to add IIS default user 'IIS Apppool\DefaultAppPool' to a user group in 'Local Users and Groups'? RRS feed

  • Question

  • How to add IIS default user 'IIS Apppool\DefaultAppPool' to a user group in 'Local Users and Groups'?

    I would like to add 'IIS Apppool\DefaultAppPool' user to DB2ADMNS user group. I dont find the user listed. Please help.

    • Moved by Val Mazur Wednesday, July 25, 2012 12:21 PM (From:ADO.NET Managed Providers)
    Tuesday, February 21, 2012 9:46 AM

Answers

  • Hi

    You will not be able to see it listed as it is an internal account. Your only option is the following:

    1. open Computer management, navigate to local users and groups --> groups.
    2. Doubole click on a local group name,
    3. Click Add
    4. Type IISAppPool\DefaultAppPool then click Check Names and OK.

    I've done these steps and worked, but my IIS is set to use Application Pool identity.

    You cannot add Application pool identity to domain groups.

    I hope it helps.

    J.


    There are 10 type of people. Those who understand binary and those who do not.
    My Blog

    • Proposed as answer by Janos BerkeMVP Wednesday, February 29, 2012 4:18 AM
    • Marked as answer by Alan_chen Wednesday, February 29, 2012 5:47 AM
    Tuesday, February 21, 2012 10:37 AM

All replies

  • Hi,

    When you open the Group click add then copy the IIS Apppool\DefaultAppPool into the Enter the object names to select and click Check Names.  

    Janos


    There are 10 type of people. Those who understand binary and those who do not.
    My Blog

    Tuesday, February 21, 2012 10:03 AM
  • Thanks for the immediate reply Janos. But, i dont find the user listed. So unable to add it to the group.
    Tuesday, February 21, 2012 10:34 AM
  • Hi

    You will not be able to see it listed as it is an internal account. Your only option is the following:

    1. open Computer management, navigate to local users and groups --> groups.
    2. Doubole click on a local group name,
    3. Click Add
    4. Type IISAppPool\DefaultAppPool then click Check Names and OK.

    I've done these steps and worked, but my IIS is set to use Application Pool identity.

    You cannot add Application pool identity to domain groups.

    I hope it helps.

    J.


    There are 10 type of people. Those who understand binary and those who do not.
    My Blog

    • Proposed as answer by Janos BerkeMVP Wednesday, February 29, 2012 4:18 AM
    • Marked as answer by Alan_chen Wednesday, February 29, 2012 5:47 AM
    Tuesday, February 21, 2012 10:37 AM
  • Hi,

    I am writing to check the status of the issue on your side.  Would you mind letting us know the result of the suggestions?
    If you need further assistance, please feel free to let me know.   I will be more than happy to be of assistance.

    Have a nice day.


    Alan Chen[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, February 27, 2012 3:49 AM
  • Hi!

    I can't select the app pool location, only the pc name:(((((((

    I need a banana!

    Monday, July 23, 2012 10:25 PM
  • Make sure that you have a space in that username.  It isn't "IISAppPool\DefaultAppPool"  It's "IIS AppPool\DefaultAppPool".
    Wednesday, July 29, 2020 2:22 PM