locked
Failure the system cannot move the file to a different disk drive RRS feed

  • Question

  • When I reach the 'Deploy Server' step in my OCS 2007 install, I get the following strange error:

     

    Failure [0x80070011] The system cannot move the file to a different disk drive

     

    In the LC_Server_[date]_[time]_activate.html log file, this error message is listed next to 'Check Product ID' under the 'Check Server State' node (last node).

     

    Any ideas?

     

    Thanks

    Friday, June 15, 2007 7:33 PM

Answers

  • Ok I gave up on that particular install so I created a fresh new environment and then everything installed!

     

    I think the problem I was experiencing came from the fact that I initially installed OCS 2007 and got to the 'Certificate Setup' portion of the install and then I ran into some issues getting a valid certificate, I rebooted the machine, and then the OCS Setup had rolled back to Step 1 (setting up AD)... but I guess it didn't truly rollback and clean-up (though why it rolled back at all is another question).

    Wednesday, June 20, 2007 5:51 PM

All replies

  • Hi Mike,

     

    Can you tell us something regarding the "history" of your system?

    Did you install OCS on a freshly installed Windows machine?

    Have you tried running Procmon.exe (from the Sysinternals tools) and monitor file access while the problem occurs? This might give us a clue which file cannot be moved.

     

    Thanks

    Bernd

    Monday, June 18, 2007 1:37 PM
  • I ran setup while monitoring the process using the Process Monitor tool - the only thing I notice near the end of the capture is a lot of 'NAME NOT FOUND' results when lcscmd.exe is looking for some DLLs.

     

    For example, lcscmd.exe tries a QueryOpen operation on E:\OCS2007\se_eval\setup\i386\msapsspc.dll and it shows a NAME NOT FOUND. But it then finds the DLLs in the win\sys32 folder and successfully loads them (or at least I think).

     

    Right before it creates the log file and starts writing data to it, I just see a bunch of 'SUCCESS' results so nothing jumps out as being a problem.

    Tuesday, June 19, 2007 4:07 PM
  • I tried a command line activation and got the same thing:

     

    Executing "Initialize Conferencing Server Object"
    Executing "Server Domain State"
    Executing "Activate"
    Executing "Log Action Parameter"
    Executing "Check Server State"
    Executing "Log Action Parameter"
    Executing "Check Product ID"
    Check the log file "C:\DOCUME~1\mpugh\LOCALS~1\Temp\2\Activate[2007_06_19][12_27
    _24].html" for details.
    ERROR (0x80070011): The system cannot move the file to a different disk drive.

    Type lcscmd /? for help using this command.

    Execution time = 2654 ms

    Tuesday, June 19, 2007 4:29 PM
  • Ok I gave up on that particular install so I created a fresh new environment and then everything installed!

     

    I think the problem I was experiencing came from the fact that I initially installed OCS 2007 and got to the 'Certificate Setup' portion of the install and then I ran into some issues getting a valid certificate, I rebooted the machine, and then the OCS Setup had rolled back to Step 1 (setting up AD)... but I guess it didn't truly rollback and clean-up (though why it rolled back at all is another question).

    Wednesday, June 20, 2007 5:51 PM
  • i have the same problem: the computer name and the name in the public certificate was different, so i renamed the computer. After that, the deploy server wizard rolled back to step 1: deploy server. During the deployment, i have the same error: [0x80070011] The system cannot move the file to a different disk drive. 

    Any ideas?  full reinstall maybe?? 

    thanks
    Regards
    Tibor
    MVP-Enterprise Security
     
    Wednesday, September 9, 2009 2:30 PM