locked
"The server or pool that this user was assigned is no longer valid. Please select a new one" RRS feed

  • Question

  • My company is upgrading from a standard edition LCS 2005 SP1 server to an OCS 2007 R2 Enterprise Pool.

    - KB911996 and KB921543 have been installed on the LCS 2005 SP1 server.

    - Steps 1 - 6 of the migration of the global settings from System to Configuration was completed ( only step remaining is the "DeleteGlobalSettingsTree" )

    - The forest/schema/domain prep for OCS 2007 R2 was completed successfully.

    But now I get this error message when I access the LCS properties of any user:

    "The server or pool that this user was assigned is no longer valid. Please select a new one"

    The pool setting is blank and I can re-add the person back to the original LCS server name. When I do that, it acts like the user account has just been created; no contacts, you receive the requests from other contacts that want to add you, etc.

    Has anyone ever seen this before ? Any help would be great.

    Thanks.




     

    Monday, May 18, 2009 2:50 PM

All replies

  • Hi
    It's been a while since you posted this, so did you manage to solve this issue?

    If not:
    I've experienced the same in our internal OCS deployment after the migration process from System to Configuration was completed. As you, we have not completed the last step "DeleteGlobalSettingsTree" either.

    The migrated users all have a msRTCSIP-PrimaryHomeServer (use adsiedit.msc and properties on a given user) which points to the new Configuration:
    CN=LC Services,CN=Microsoft,CN=OCS01,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=xx

    However, when starting the dsa.msc and the Communcations tab on a user - it seems like it somehow tries to locate the user in the old System pool. When choosing the pool from the list, and applying the new settings, the msRTCSIP-PrimaryHomeServer value for that user changes back to the old System value:
    CN=LC Services,CN=Microsoft,CN=OCS01,CN=Pools,CN=RTC Service,CN=Microsoft,CN=System,DC=xx
    This is obivously wrong, as all servers, roles and the rest of the users points to the new Configuration container.

    I've read in a post somewhere, that there were problems starting the Mediation role service after the migration process (minus the "DeleteGlobalSettingsTree") was completed. The author reported that after going through with the last step, the issue was solved and the Mediation server fired again.

    Perhaps it's the same here and going through with the final step will solve your issue? Unfortunately I cannot confirm it, since we still haven't completed the step ourselves (still wating for the AD Forest guy completing the step) . 

    Good luck and let me know how it went!

    Regards
    Martin
    Friday, July 10, 2009 1:45 PM
  • Hi,

    I've got the same issue and message, does running the last step fix it for you?

    Regards,

    Steve
    Tuesday, August 18, 2009 3:09 PM

  • Try using ADSIEdit to locate the user and edit the FQDN on the msRTCSIP-PrimaryHomeServer attribute to point to an available server or pool accordingly (more here).

    Hope this helps. Do let us know please. Thank you.


    TechNet Forum Moderator - http://www.leedesmond.com
    Tuesday, August 18, 2009 4:09 PM
    Moderator
  • I'm afraid that link doesn't help, before I go into the OCS snapin the value for msRTCSIP-PrimaryHomeServer is CN=LC Services,CN=Microsoft,CN=OCSSERVERNAME,CN=Pools,CN=RTC Service,CN=Services,CN=Configuration,DC=domainname,dc=local which is as it should be since this is where the migration tool moves it to.

    When I go into the Communications tab i get "The server or pool that this user was assigned is no longer valid. Please select a new one" I can then select the only available pool and after that the value changes to CN=LC Services,CN=Microsoft,CN=OCSSERVERNAME,CN=Pools,CN=RTC Service,CN=Services,CN=system,DC=domain,dc=local
    Tuesday, August 18, 2009 4:24 PM
  • I ran the final step in the migration process, the deletion of the old settings in the system container and after that OCS seems to be fine, the duplicate pool is gone and when I go into the communications tab in a users AD profile there is no error and it shows them in the correct pool

    It's a shame the notes don't mention this, since they say to test functionality before deleting the old container but that's the way it goes.

    Steve
    Wednesday, August 19, 2009 8:39 AM