locked
Useing XML config file deployment CRM 4 error RRS feed

  • Question

  • Hello,

    I had Install CRM Server use XML config file in the command line , but it's not success.

    I found the log file below information:

                    |   Info| === Setup bootstrap logging started 3/22/2009 10:14:16 PM ===
    22:14:16|   Info| Bootstrap version: 4.0.7333.3.
    22:14:16|   Info| User: administrator.
    22:14:16|   Info| Invoked with command line: setupserver.exe  /config c:\config config.xml
    22:14:16|   Info| Running D:\Server\amd64\SetupServer.exe
    22:14:16|   Info| Loading bootstrap library D:\Server\amd64\ServerSetup.dll
    22:14:16|   Info| Microsoft Dynamics CRM is not currently installed.
    22:14:16|   Info| Closing bootstrap library D:\Server\amd64\ServerSetup.dll
    22:14:16|   Info| Beginning to parse configuration file 'c:\config'
    22:14:16|  Error| Error parsing config file(HRESULT = 0x80070005) (configfileparse.h:CConfigFileParser::Parse:325).
    22:14:23|  Error| Error parsing config file, Error, OK

    22:14:23|   Info| InputResult: OK
    22:14:23|   Info| === Setup bootstrap logging ended 3/22/2009 10:14:23 PM ===     

    Anyone got a hint on this problem ?  thanks.
    Monday, March 23, 2009 6:43 AM

Answers

  • Your command line looks to be : setupserver.exe  /config c:\config config.xml  Is the "config" repeated intentionally?

    Shouldn't it be "setupserver.exe  /config c:\config.xml" instead?


    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Monday, March 23, 2009 7:37 PM
    Moderator

All replies

  • It might help to understand why you had to deploy using this option.  Take a look at this blog and see if anything is applicable.

    http://dmcrm.blogspot.com/2008/02/upgrading-custom-code-from-30-to-40.html
    Best Regards, Donna
    Monday, March 23, 2009 6:55 PM
  • Your command line looks to be : setupserver.exe  /config c:\config config.xml  Is the "config" repeated intentionally?

    Shouldn't it be "setupserver.exe  /config c:\config.xml" instead?


    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Monday, March 23, 2009 7:37 PM
    Moderator
  • lol, good catch
    Best Regards, Donna
    Monday, March 23, 2009 8:06 PM
  • twJack - did you have any success in moving forward with the corrected command line?
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Tuesday, March 24, 2009 5:14 PM
    Moderator
  • Hi, Scott:

    I had move the config.xml form "c:\config" folder to root path "c:\ " , it's work. 

    In my opinion, this maybe secturity problem when mscrm installation need to check folder permission.

    BTW, when install crm on Server2008 only networkservice account can excute,  whether Domainuser account can excute install success?

    Wednesday, March 25, 2009 3:26 AM
  • I am glad that worked! -

    Sorry, but I do not understand the new question about networkservice account and domianuser account. I would encourage you to open a new thread with that question and some more explaination and another user may recognize the issue. -
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Wednesday, March 25, 2009 9:40 AM
    Moderator