Xbox360 Media Center - "Cannot Play Video. A firewall or network configuration issue is preventing media playback." RRS feed

  • Question


    I have a Linksys WRT54G, HP running Vista and 360.


    Everything worked fine for months, then the Xbox died.  Microsoft sent the replacement.  Nothing else changed.  I got the Xbox and PC connected again with no problems.


    But now, when I try to watch recorded or live TV (or listen to music), I get the following message.


    "Cannot Play Video. A firewall or network configuration issue is preventing media playback."


    Over six hours on the phone with tech support with both Linksys and Xbox Support has gotten nowhere.


    Nothing has changed on my network except the new/refurbished Xbox.


    I have ruled out Linksys.  Everything is open on it and nothing blocked.


    I'm running:

    Microsoft Vista Home Premium

    Microsoft Live One Care

    Microsoft Xbox360

    (I see a trend)


    Thanks for the help!

    Tuesday, February 5, 2008 1:45 PM


All replies

  • If you turn off the OneCare firewall, does it work?



    Tuesday, February 5, 2008 8:18 PM
  • No, it doesn't.  I should have mentioned that I turned it off and confirmed the built-in Windows firewall was off too.


    Wednesday, February 6, 2008 2:04 PM
  • When OneCare is installed, the Windows Firewall is disabled, so that's not the issue. If you turned off the OneCare firewall, you've ruled out that as an issue - for now.

    See if any of this helps - http://support.microsoft.com/kb/932161




    If not, I'd suggest xbox support. If you get it working without the OneCare firewall, but it then fails again once the OneCare firewall is enabled - http://support.microsoft.com/kb/913963 (this is for 1.6, but the instructions for 2.0 are similar enough)



    Thursday, February 7, 2008 2:13 AM
  • Was your issue resolved?   I am having the same problem.   "Cannot Play Video"  A nework or firewall . . .


    Monday, July 7, 2008 1:04 AM
  • i thought i was the onlyone who had this problem, if u guys find out please tell me
    Friday, November 14, 2008 4:17 PM
  • I also have the same issue, everything works except for any streaming video and music.  Does this have something to do with RTSP being blocked?  I've had this working previously.  Also, same exact files work fine when using xbox dashboard.
    Friday, November 28, 2008 5:55 AM
  • Have you considered going to sysinternals and downloading their process monitor/network monitor to see what ports it's trying to open?  Its worked on a few other MS problems that "support" didn't have an answer for.

    Monday, December 22, 2008 3:44 AM