none
Migration from 2012 R2 to 2016? RRS feed

  • Question

  • I wasn't aware of 2016 until just now.  I did see that the release notes state that "Upgrade and migration from an earlier version of HPC Pack are not supported".  Before I even begin looking at this, I wanted to be sure I'd have to essentially start my cluster over from scratch.  It's overall small, but it'd still be quite the effort to remove all components from every machine, reload the server, and set up a new cluster.  Is that really the only path forward?
    Thursday, March 2, 2017 10:56 PM

All replies

  •   HPC Pack 2012 R2 is still supported thus you're fine to use HPC Pack 2012 R2. There are some infrastructure changes for HPC Pack 2016 (From Failover Cluster to Service Fabric Cluster), thus we don't easy way to do upgrade.

      The installation of compute node shall be easier as we support un-attend installation and un-installation. Sorry for the in-convenience.


    Qiufang Shi

    Friday, March 3, 2017 4:11 AM
  • Don't get me wrong, I have no plans of rushing into it; I only found out it existed because I was casually wondering if there'd be a 2012 R2 Update 4 and started looking.  And at only around 50 nodes, it's not an overwhelming task.  I'll probably stick with installing the latest QFE for 2012 R2 first and see what happens there.  We utilize workstation nodes a lot and I've still never found a fix for my LogonUI.exe bug; I was hoping 2016 may resolve it.
    Friday, March 3, 2017 1:50 PM