none
registry settings not copied correctly RRS feed

  • Question

  • I've been running Streets and Trips (2010) without problem until today and suddenly get this error:

    "Your registry settings for this application were not copied correctly.  To correct these settings, run Setup again for this application from the location where you originally installed it."

    What does this mean?  I understand I have to reinstall it.  What does it mean "from the location where..."?  I'll put it on the same computer obviously.  And the registry settings being copied.  Why copied at all and from where?

    Later --- I uninstalled, did a system cleanup as the uninstall seemed to be fraught with problems, and reinstalled S&T.  The same error message is generated.  Has no one run into this?

    Windows 8.



    • Edited by MikeInPoulsbo Friday, April 26, 2013 2:50 AM added info
    Thursday, April 25, 2013 9:14 PM

All replies

  • Just encountered this problem myself.  Couldn't do re-install because it keeps failing at the installation of the C+++ part.  Error msg saying "A key component failed to load, Setup will now exit."  And it just leaves me there.  Program worked fine forever, now suddenly it doesn't.  Help!
    Friday, April 26, 2013 2:32 PM
  • I didn't run into any problems with the re-install, it just didn't solve the porblem.  A very messy fix that I found after some searching was to locate the executable "streets.exe", create a shortcut to it on the desktop, and edit the advanced properties of the shortcut to allow it to run as administrator.  When you double-click the shortcut you get the UAC window and then it opens.  What you can't do is double-click on a saved file.  It does work to drag the file onto the shortcut.  Makes me wonder at times whether Microsoft puts ticking bombs in their software to motivate you to go off and buy the most recent release.

    Friday, April 26, 2013 5:02 PM
  • Nah... it is happening right now in S&T 2013 to one of my users.  HIGHLY FRUSTRATING....

    An item to note, I setup the program on a fresh machine with the same permissions for that user, and things worked fine.  It could be another program or even anti virus that is the culprit.  Either way, there are a few things to try before completely giving up.  One would be to start the computer in safe mode and see if it opens.  Another way would be to open msconfig.exe and start the computer in diagnostic mode, or if you wanted to, selective startup mode.  If you did the latter, you could tell a program at a time to not load upon startup until you find what is causing the issue. 

    As a last resort, try these steps: http://support.microsoft.com/kb/314590?wa=wsignin1.0


    Computer Systems Specialist

    Tuesday, June 25, 2013 8:58 PM
  • The other day I inadvertently clicked the old Streets&Trips icon on my desktop and the program opened without errors.  I can also click on a saved file and it opens OK.  I have not made any significant changes that I am aware of (other than, perhaps, some Windows 8 update).  So as far as I am concerned the problem is solved, for now -- disappeared as mysteriously as it appeared.

    Tuesday, June 25, 2013 9:50 PM
  • thanks, fixed the unknown problem
    Sunday, August 11, 2019 5:28 PM