none
"Set publish date" failing to publish the set date RRS feed

  • Question

  • I'm finding the "Set publish date" failing to set the date.  The last dozen or so, posts that I've "Set publish date" have all done this.  When you check on spaces, it just published with the current date/time.  However as if you reopen the post in Live Writer.  Then "Set publish date" again and publish.  It will post with the publish date you set!  I've not noticed this issue before.

    Anybody else having the same problem?

    Live Writer version: 14.0.8050.1202

    Jasper
    Thursday, January 22, 2009 2:28 PM

All replies

  • Yep, sorry, it's a known issue on the Spaces side. I don't have an ETA for a fix, in the meantime you have to do Publish twice to make the date stick.
    Thursday, January 22, 2009 6:34 PM
  • Not a problem.  Great to know the Live Writer team is on the case.  The other work around that I've been using, without knowing it.  Is using email publishing a form basic post from me old Windows Mobile.  Which is sent over the air via Windows Live or Exchange.  While I'm out and about, then upon return to the PC using Live Writer to open that post and fill in the details.  Thus the "Set pubish date" isn't an issue using this method of blogging!

    Thanks
    Jasper
    Thursday, January 22, 2009 6:59 PM
  • Joe Cheng [MSFT] said:

    Yep, sorry, it's a known issue on the Spaces side. I don't have an ETA for a fix, in the meantime you have to do Publish twice to make the date stick.

    I hate to disagree with you but you can hit "publish" as many times as you want but it doesn't do squat. There is no way to make the date stick. Based on my experimentation it appears that if the day is set to one day prior to the current date, but time  specified on that date is later than the current clock time the "Set Publish Date" information is ignored. If the "Set Publish Date" is more than one date prior to the current date the "Set Publish Date" information is ignored.

    So basically, there seems to be a very narrow window of dates/times that are being recognized/allowed in the "Set Publish Date" function.

    I do have one question of clarification: You say you have no ETA for a fix but what you didn't say is if anyone is actually working on a fix, or if anyone really cares that it needs a fix. Has this issue (and Spaces in general) been shoved to the back burner by MicroSoft? Spaces seems to have largely been ignored by MicroSoftand work on it abandon for quite some time. If MicroSoft has lost interest in maintaning Spaces (much less, actually improving it), please let us know so we can investigate moves to other blogger services.

    Thanks.
    Sunday, February 1, 2009 11:11 PM
  • AlaskaHome1959 said:

    Joe Cheng [MSFT] said:

    Yep, sorry, it's a known issue on the Spaces side. I don't have an ETA for a fix, in the meantime you have to do Publish twice to make the date stick.

    I hate to disagree with you but you can hit "publish" as many times as you want but it doesn't do squat. There is no way to make the date stick. Based on my experimentation it appears that if the day is set to one day prior to the current date, but time  specified on that date is later than the current clock time the "Set Publish Date" information is ignored. If the "Set Publish Date" is more than one date prior to the current date the "Set Publish Date" information is ignored.

    So basically, there seems to be a very narrow window of dates/times that are being recognized/allowed in the "Set Publish Date" function.

    I do have one question of clarification: You say you have no ETA for a fix but what you didn't say is if anyone is actually working on a fix, or if anyone really cares that it needs a fix. Has this issue (and Spaces in general) been shoved to the back burner by MicroSoft? Spaces seems to have largely been ignored by MicroSoftand work on it abandon for quite some time. If MicroSoft has lost interest in maintaning Spaces (much less, actually improving it), please let us know so we can investigate moves to other blogger services.

    Thanks.



    A workaround for this is on Live Writer version: 14.0.8050.1202:

    • Publish your post as per-normal, don’t worry about the “Set publish date”
    • Then re-open that post.  By clicking on it from “Recently posted” from the right of the Live Writer window.
    • Set the publish date with the Date and Time you need for the post.
    • Publish the post again.  This time the publish date and time will be correctly set on your space.

     


    Jasper
    Monday, February 2, 2009 3:25 AM