locked
Communicator 2007 R2 Won't Update Address Book RRS feed

  • Question

  • Hi,
    I have an Office Communications Server 2007 R2 Standard Edition server running on Server 2008 64 bit.  The server runs Front End, Web and A/V roles.  Office Communicator 2007 R2 clients are able to connect but receieve the following warning:

    Cannot synchronize with the corporate address book. This may be because the proxy server setting in your web browser does not allow access to the address book. If the problem persists, contact your system administrator.

    Steps tried:
    Installed Communicator on the OCS server and the issue persisted
    Reissued certificate to OCS server
    Reset service account passwords

    Any thoughts?

    Thanks,
    Nate
    Tuesday, July 28, 2009 9:08 PM

All replies

  • There could be many possible reasons for that failure.  For one, if you've reset the password ont he RTCComponentService account and have not updated the credentials on the IIS App Pool.  Take a look at the latter section of this blog article to verify/fix that: http://blogs.pointbridge.com/Blogs/schertz_jeff/Pages/Post.aspx?_ID=66

    Also check this TechNet article for some troubleshooting assistance: http://support.microsoft.com/kb/953113
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    • Marked as answer by NSNateS Tuesday, August 4, 2009 8:28 PM
    • Unmarked as answer by NSNateS Tuesday, August 4, 2009 8:41 PM
    Tuesday, July 28, 2009 9:45 PM
    Moderator
  • Jeff,
    Thanks for the response.  I uninstalled the Web Services components as I found another article saying having them all installed on the same server was not a supported topology.  It seems to have uninstalled the Application Pool that OCS was using.  Any instructions on the process for recreating the application pool?

    Thanks,
    Wednesday, July 29, 2009 4:44 PM
  • Take a look at this thread from yesterday: http://social.microsoft.com/Forums/en-US/communicationsserversetup/thread/e4c1eb2f-b4c3-46ea-82be-8f1d9167e51e
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Wednesday, July 29, 2009 7:41 PM
    Moderator
  • Jeff,
    Once again, thank you.  I'll follow the steps there and then try.

    Thanks,
    Thursday, July 30, 2009 6:56 PM
  • I also don't feel AS bad as I am apparently not the only person to make that mistake.

    Nate
    Thursday, July 30, 2009 6:57 PM
  • Jeff,
    The issue persists after modifying the IIS settings and reinstalling Web Components.  Any other ideas?

    Thanks,

    Nate
    Tuesday, August 4, 2009 8:31 PM
  • Anyone?
    Tuesday, August 11, 2009 1:11 PM
  • Nate,

    A longshot but take a look at my blog I posted earlier.  I've since updated it to include an LCSCMD command to update the pool with the new account credentials.  It can't hurt to re-activate the pool.  Since you have a Standard Edition server you can ignore the switches for the RTCGuestAccessUser account.

    Otherwise I'd say something is still hosed in the IIS virtual site.
    Jeff Schertz, PointBridge | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Tuesday, August 11, 2009 1:46 PM
    Moderator