locked
Upload Error with large (1Gb) multi file upload. RRS feed

  • Question

  • When I try a large upload I recieve the message: "The upload finished with errors" message.  Is it possible the problem is a timeout? I ask  becuse it is taking a while (20+ minutes). 

    The strange part is the message "For more information click Error."  but I see no error to click.

    The status still says uploading for the file that was in progress.

    Tuesday, June 7, 2011 6:14 PM

All replies

  • Phil

    Upload from where to where. 20 minutes for a 1GB (I assume you mean GigaByte) file seems about right for a 100Mb/sec LAN (I achieve around 75 Mb/sec on a Gb LAN). I am not aware of any timeout issues.

    Phil


    Tuesday, June 7, 2011 6:25 PM
  • Upload via the server website from a remote location.  I was not worried about the total time (I believe my current location is throttling me).

    I will hazard a guess that after one file is transferred the WHS site has logged me out due to the inactivity monitor and the next file cannot start.  Can anybody confirm that this is possible?

    Phil 

    Tuesday, June 7, 2011 7:32 PM
  • Phil

    From the original WHS Remote Access documentation:

    "Large File Uploads May Time Out Before Finishing
    If you upload a large file or group of files by using Remote Access, the session may time out before the
    upload finishes. To resolve this problem, you can increase the time-out parameter in the Windows Home
    Server web.config file.

    To increase the Remote Access time

    1. Use mstsc.exe to start a Remote Desktop Connection session to your

    Caution

    Be careful when using a Remote Desktop Connection to your home server. You can

    damage Windows Home Server functionality if you use Remote Desktop incorrectly.

    2. Use a text editor, such as notepad.exe, to open C:\Inetpub\remote\web.config

    3. Locate the following line:

    <sessionState mode="InProc" cookieless="false" timeout="20"/>

    4. Replace "20" (which represents 20 minutes) with a larger number, to allow your uploads to finish.

    Note

    If you change the timeout value to more than 200 minutes, you must also change the

    executionTimeout value. Search for the following line

    <httpRuntime maxRequestLength="2097151" executionTimeout="12000"/>

    and increase the executionTimeout value (Measured in seconds) to the same or greater value than the timeout value (measured in minutes)

    5. Save your change, close the file, and then log off from your Remote Desktop Connection

    session.

    6. Use Remote Access to upload your file or files, to ensure that the new time-out parameter is sufficient to finish the upload.

     

    Important

    If you increase the time-out parameter, you increase your security risk. Do not leave a computer

    that has an active session unattended in a public place.

    ----------------------------------------------------------

    Sounds like WHS2011 has the 20 minute limit set also and you can probably apply the same change.

    Phil

    Tuesday, June 7, 2011 8:07 PM
  • The instructions appear to be correct only for WHS v1.  The file web.config does not exist in the path specified.   

    However I believe I have found the correct file in c:\Program Files\Windows Server\Bin\WebApps\RemoteAccess\web.config.  The default timeout for WHS 2011 seems to be 30 minutes. 

    Can anybody confirm that this is the new correct location for the web.config file?

     

    Friday, June 10, 2011 3:50 PM
  • Certainly looks like it to me - have you tried it?
    Friday, June 10, 2011 5:49 PM