locked
hdmake generating pngs RRS feed

  • Question

  • I'm surprise to see that hdmake now generates png instead of wdp. However, it seems that HDView is even more suprised then me. When trying to access a site created with the hdmake 1.7 (in which all generated tiles are pngs), HDView generates an error saying:

    Could not create scene from file:
    file://[MyPath]\l_0\c_0\tile_0.wdp
    hr=0x800c0005

    No wonders that it can be created, the file HDView is looking for is now called
    tile_0.png!

    Is there an attribute to add in the xml file to tell HDView to look for pngs?

    Fred
    Friday, September 5, 2008 1:39 PM

Answers

  • I think this only happens when outputting at quality 1.0 (lossless mode).  This is a bug!  Can you confirm that you are selecting quality 1.0.  To work around for now please use quality 0.99

    Saturday, September 6, 2008 1:53 AM

All replies

  • After looking at hdview's xml file again, I've noted that the imageset's url includes the file extension. Changing it from wdp to png did the trick. HDView handles pngs just fine. However, hdmake produced an xml with the wrong imageset's url file extension.

    Fred
    Friday, September 5, 2008 2:06 PM
  • I just noticed that the last level of generated tiles are wdp, the first ones are png.

    Fred
    Friday, September 5, 2008 6:03 PM
  • I think this only happens when outputting at quality 1.0 (lossless mode).  This is a bug!  Can you confirm that you are selecting quality 1.0.  To work around for now please use quality 0.99

    Saturday, September 6, 2008 1:53 AM
  • I was effectively using 1 as the quality. Using 0.99 made hdview generate wdp for all tiles.

    Fred
    Saturday, September 6, 2008 2:27 AM