locked
Can't get remote access to computers working RRS feed

  • Question

  • Hi,

    I'm running a trial version of WHS with Power Pack 3 beta. For the test, since I don't have any spare hardware lying around, I'm running WHS within a Windows Virtual PC on a Windows 7 Ultimate PC. I've made sure the Windows Virtual PC is on the exclude list of the Windows 7 firewall.

    I've attached 2 computers to the WHS though the console software: the desktop on which Virtual PC is running, and a laptop that is also running Windows 7 ultimate.

    I've been able to get most of it to work, including automated daily backups of both machines, the custom domain, and I can log into the web page and console bot on the local network and remotely over the internet.

    The only thing I've been unable to figure out is how to enable remote access to computers. I've enabled remote desktop access on both machines and RDP works fine when accessed directly over the LAN. I've also made sure to enable remote access to shared folders and computers for the 2 users I've got set up for WHS access.

    However, when I go to the remote access tab on the WHS website, both computers always display a yellow circle and "Connection disabled". This even happens over the local LAN.

    Is this an issue with running WHS in a Virtual PC, a powerpack 3 issue, a Windows 7 issue, or a configuration issue?

    Thanks!
    Wednesday, November 11, 2009 10:14 PM

Answers

  • Ok, thanks for the help. I finally figured it out. Some time ago I had changed the Remote Desktop listening port to something non-default. Finally, after changing it back, rebooting, fixing my typo so that it really was changed back, rebooting again... It now works as expected.
    Friday, November 20, 2009 6:08 AM

All replies

  • Hi,

    I'm running a trial version of WHS with Power Pack 3 beta. For the test, since I don't have any spare hardware lying around, I'm running WHS within a Windows Virtual PC on a Windows 7 Ultimate PC. I've made sure the Windows Virtual PC is on the exclude list of the Windows 7 firewall.

    I've attached 2 computers to the WHS though the console software: the desktop on which Virtual PC is running, and a laptop that is also running Windows 7 ultimate.

    I've been able to get most of it to work, including automated daily backups of both machines, the custom domain, and I can log into the web page and console bot on the local network and remotely over the internet.

    The only thing I've been unable to figure out is how to enable remote access to computers. I've enabled remote desktop access on both machines and RDP works fine when accessed directly over the LAN. I've also made sure to enable remote access to shared folders and computers for the 2 users I've got set up for WHS access.

    However, when I go to the remote access tab on the WHS website, both computers always display a yellow circle and "Connection disabled". This even happens over the local LAN.

    Is this an issue with running WHS in a Virtual PC, a powerpack 3 issue, a Windows 7 issue, or a configuration issue?

    Thanks!
    Running WHS in a VM is unsupported.  Having said that, it should still work (I do it all time for testing purposes :)  ).  First thing I would try is to completely disable the firewall on your real Win 7 workstation (so there is no possible way it can interfere).  Make sure you disable both firewalls (public and private).  Then power the server, then reboot the Win 7 workstation, then try it again (preferably from outside your LAN).  Also, you could try checking Shields Up! (after doing all of this), do a custom port scan for 80, 443, and 4125, then post the results here.
    Thursday, November 12, 2009 2:47 AM
    Moderator
  • Running WHS in a VM is unsupported.  Having said that, it should still work (I do it all time for testing purposes :)  ).  First thing I would try is to completely disable the firewall on your real Win 7 workstation (so there is no possible way it can interfere).  Make sure you disable both firewalls (public and private).  Then power the server, then reboot the Win 7 workstation, then try it again (preferably from outside your LAN).  Also, you could try checking Shields Up! (after doing all of this), do a custom port scan for 80, 443, and 4125, then post the results here.
    Hi,

    I tried your suggestions and after rebooting everything I was able to successfully connect to the Win7 workstation through the Home Server VM. I then re-enabled all the firewalls as they were before (I had disabled all firewalls on Win7 and WHS) and it continued to work. I tested initially within the LAN but then tested over the internet and it also worked fine. At another location I couldn't get it to work (always times out) but I suspect that's due to a rather restrictive firewall at that location. I'm able to access the web page and initiate the RDP, but the RDP connection cannot be succesfully established. I'm not sure if the firewall is preventing access to port 4125 or RDP protocol or both but I imagine either would prevent the connection.

    Oh, I also had to change the Remote Access settings on Win7 to accept RDP connections from any client (as opposed to the more restrictive option), but I assume this is necessary. I had tried that before but it didn't work for some reason. Maybe rebooting was necessary.

    Also, Shields Up reports 80 and 443 are Open, and 4125 is Closed (but not Stealth). Is this the expected result?

    The issue I'm still having, however, is that I added another workstation (this one is XP Profession) I added still is not accessible remotely through WHS. Whenever I attempt (even inside the LAN) to do so I get the following error:

    "Cannot connect to your home computer. Check your network connection and make sure your home computer is not blocked by a firewall. If your home computer has recently restarted, try again in a few minutes."

    However, I can connect (over the LAN) directly to that workstation using the RDP client.

    Thanks.
    Friday, November 13, 2009 5:28 PM
  • Hi,

    I tried your suggestions and after rebooting everything I was able to successfully connect to the Win7 workstation through the Home Server VM. I then re-enabled all the firewalls as they were before (I had disabled all firewalls on Win7 and WHS) and it continued to work. I tested initially within the LAN but then tested over the internet and it also worked fine. At another location I couldn't get it to work (always times out) but I suspect that's due to a rather restrictive firewall at that location. I'm able to access the web page and initiate the RDP, but the RDP connection cannot be succesfully established. I'm not sure if the firewall is preventing access to port 4125 or RDP protocol or both but I imagine either would prevent the connection.

    Oh, I also had to change the Remote Access settings on Win7 to accept RDP connections from any client (as opposed to the more restrictive option), but I assume this is necessary. I had tried that before but it didn't work for some reason. Maybe rebooting was necessary.

    Also, Shields Up reports 80 and 443 are Open, and 4125 is Closed (but not Stealth). Is this the expected result?

    Yes, that's correct.

    The issue I'm still having, however, is that I added another workstation (this one is XP Profession) I added still is not accessible remotely through WHS. Whenever I attempt (even inside the LAN) to do so I get the following error:

    "Cannot connect to your home computer. Check your network connection and make sure your home computer is not blocked by a firewall. If your home computer has recently restarted, try again in a few minutes."

    However, I can connect (over the LAN) directly to that workstation using the RDP client.

    Thanks.
    When you logon to the Remote Access website, what does it show as the status of your XP Pro client ("Connection Disabled", "Available for Connection", etc.)?  Have you tried disabling the firewall on that client?  Do you have any other security suite software installed on that client?
    Friday, November 13, 2009 8:12 PM
    Moderator
  • When you logon to the Remote Access website, what does it show as the status of your XP Pro client ("Connection Disabled", "Available for Connection", etc.)?  Have you tried disabling the firewall on that client?  Do you have any other security suite software installed on that client?
    The XP Pro Client says "Available for Connection" but when I attempt to connect I always get that error.

    I tried disabling the XP firewall altogether but it didn't help. I'm running NOD32 antivirus (NOT security suite). Other than the antivirus and the built in firewall, there's no additional security software installed.

    Incidentally, I thought this might be an issue with the extra complexity of the virtual machine, but his weekend I picked up a real Home Server (Acer H340) and set it up. It's behaving exactly like the trial I was running in the VM. Again, everything works except I can't get the remote access to the XP machine. Same status and error messages.

    Thanks!
    Monday, November 16, 2009 12:38 PM
  • The XP Pro Client says "Available for Connection" but when I attempt to connect I always get that error.

    I tried disabling the XP firewall altogether but it didn't help. I'm running NOD32 antivirus (NOT security suite). Other than the antivirus and the built in firewall, there's no additional security software installed.

    Incidentally, I thought this might be an issue with the extra complexity of the virtual machine, but his weekend I picked up a real Home Server (Acer H340) and set it up. It's behaving exactly like the trial I was running in the VM. Again, everything works except I can't get the remote access to the XP machine. Same status and error messages.

    Thanks!
    You could always try temporarily uninstalling your A/V.  Are there any other programs that both of your clients have in common?
    Wednesday, November 18, 2009 5:34 AM
    Moderator
  • Ok, thanks for the help. I finally figured it out. Some time ago I had changed the Remote Desktop listening port to something non-default. Finally, after changing it back, rebooting, fixing my typo so that it really was changed back, rebooting again... It now works as expected.
    Friday, November 20, 2009 6:08 AM