locked
CRM Laptop Client and Outlook 2007 logon problem RRS feed

  • Question

  • Hi

     

    I have installed Microsoft CRM Laptop Client for Outlook (offline-enabled) v3.0.5745.0. After installation I open Outlook 2007 and I'm asked for username and password to log on to CRM. I've tried to write username as 'domain\username' and only 'username', but I only get this message: Connection failed: verify credentials and try again.

     

    When I've typed my username and password three times, I get passed this message, but when I try to open any folder of the CRM, I'm giving a new message:

    Error

    An error has occurred. For more information, contact your system administrator.

     

    No wonder that I'm getting an error, since I did not log in correctly.

     

    What I've tried so far:

    - no problem at all using the system, when logging on via the webinterface.

    - put the CRM site in my trusted local intranet zone

    - username and password for user is saved

    Start -> run -> control userpasswords2

    Advanced tab and the Manage password

    Server: IP of the server

    Username: domain\username

    Password: password

    - tried to install Microsoft CRM Desktop Client for Outlook v3.0.5745.0, and it works (but I can not use it offline)

    - tried to uninstall and reinstall, but it did not help

     

    Client (Laptop):

    Windows XP Pro with SP2. all updates applied

    Office 2007 Enterprise. all updates applied

    Client is not a member of any domain, but of a workgroup

    Client connects to server via VPN tunnel

    CRM installed with the local Administrator account

     

    If I have forgotten to mention anything just ask, and I hope anyone can help me

     

    //Stephan

    Wednesday, October 3, 2007 7:20 AM

Answers

  •  

    1. Set the Internet Explorer User Authentication to "Automatic logon only in Intranet zone".

    2. Add CRM and report server to Trusted Zones in the IE

    3. Make sure that the "Enable Integrated Windows Authentication" option in the IE is checked

    Thursday, November 1, 2007 8:11 AM
  •  

    Try this one:

     

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;934243

     

     

    This problem occurs because the FEATURE_SUBDOWNLOAD_LOCKDOWN feature in Internet Explorer 7 prevents the automatic download of files from a Web site for which Outlook is the referrer:

     

    To work around this problem, disable the FEATURE_SUBDOWNLOAD_LOCKDOWN registry subkey. To do this, follow these steps on the computer that is running the Microsoft Dynamics CRM desktop client for Outlook:

    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SUBDOWNLOAD_LOCKDOWN
    3. Right-click Outlook.exe, and then click Modify.
    4. In the Value data box, type 0, and then click OK.
    5. Exit Registry Editor.

    Sunday, December 2, 2007 8:52 PM
  • Well, I think this is at least one possible problem

     

    Client is not a member of any domain, but of a workgroup

     

    Make the Laptop part of the forest.

    Create the machine account BEFORE you add the laptop to the forest.

    Then VPN in and see if you are prompted for a "Integrated Security" login.

     

    Tuesday, December 4, 2007 8:19 AM
    Moderator

All replies

  • The client not being a domain member could be the problem. I've only met this once, in a test environment, and could get the client to work using the runas command to run Outlook as the domain user. You may also need to run the Microsoft.Crm.Application.Hoster.exe in the context of the domain user.

     

    Is there any reason you can't add the machine to the domain ?

     

    Another possible cause could be anti-virus software preventing .Net code running locally

     

     

    Wednesday, October 3, 2007 8:42 AM
    Moderator
  • Hi

     

    I was afraid that the client not being a member of a domain could be a problem. But I will have clients which has no access to the domain controller, and thats why I need it to work without.

     

    I have now tried to use the runas command. I created shortcuts for both programs, and changed the target to:
    Outlook: runas /netonly /user: domain\username "C:\Programmer\Microsoft Office\Office12\OUTLOOK.exe"
    CRM: runas /netonly /user: domain\username "C:\Programmer\Microsoft CRM\Client\res\web\bin\Microsoft.Crm.Application.Hoster.exe"

     

    First I shutdown both programs from the process list of the Task Manager. Then I started CRM, and a command prompt showed up and asked me for the password for my domain user. Then I started Outlook the same way, but I did still have the same problem.

     

    Checked up in the Task Manager, and both programs are running under the username of the user which I'm logged in with.

     

    Tried to test with a local user called Test, and that worked just fine
    Outlook: runas /user:Test "C:\Programmer\Microsoft Office\Office12\OUTLOOK.exe"

     

    I'm using Avira AntiVir Personal Edition, but have tried to disable it, and shutdown the program from the Services

     

    VPN client I'm using is CheckPoint VPN-1 SecureClient NGX R60 HFA1 (Build 019)

     

    I have no firewall installed, and Windows firewall is disabled

     

    Thanks for your suggestions so far

     

    //Stephan

     

    Sorry I did not answer yesterday, but got always an error when I tried to post
    Thursday, October 4, 2007 6:30 AM
  • I was hoping this would have worked. A couple of other things to consider:

     

    You said you'd added the user account and password in Users, Manage Passwords and specified the IP address of the server. Is the CRM server specified by IP address as well - they should be the same ? You could also try specifying the username in the form username@fullyqualifieddomainname

     

    The VPN client maybe the issue, but I doubt it if you can connect by the web browser or the desktop client. I'm not sure if this is viable, but could you add a PPTP VPN link (either in place of, or on top of, the CheckPoint VPN) which would include the user specifying a domain account ?

     

    Thursday, October 4, 2007 8:23 AM
    Moderator
  • Hi

     

    The CRM server is specified by it's IP address, so that should not be a problem.

     

    Have tried to change the username as you suggested, but that was also not the problem.

     

    Over the weekend I thought of, if the problem is in my firewall. Will try to monitor my firewall today/tomorrow, to see if I might have a port blocked which should be open. So will return with my results later.

     

    //Stephan

    Monday, October 8, 2007 6:40 AM
  • Hi

     

    Found this document:
    http://download.microsoft.com/download/a/e/e/aee1b205-3fba-4f44-a57a-e681b1b0d364/Outlook_2007Update.doc

     

    and followed the guidance: Configure Offline Use of the Microsoft CRM Laptop Client for Outlook
    Allow cached credentials

    1. On the Start menu, point to Programs, point to Administrative Tools, and click Local Security Policy.

    2. Expand Local Policies, and then select Security Options.

    3. Set the value in Number of previous logons to a value greater than 0. Or, if using Windows XP, set the value Interactive Logon: Number of previous logons to cache to a value greater than 0 (the default value is 10).

    but still same error


    I then changed the port for the server, so the new address was http://ip:5556. Did not want to uninstall, so I changed the registry-key for the new location
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\ServerUrl=http://ip:5556/MSCRMServices
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\WebAppUrl=http://ip:5556


    After this I got a new error after being prompter for the password three times:
    http://support.microsoft.com/kb/937118/EN-US

     

    I was really happy to see that MS knew about this problem, and that they had made a hotfix for this problem. Called MS and got the hotfix, but I got an error everytime I tried to install another update which is required:
    http://support.microsoft.com/kb/925874/en-us

     

    Error: An unexpected internal error has occurred.


    Before I will end today, I can inform that I have found a solution, which I will do some more testing on, before I will post it here as a solution. Only thing I will mention now is, that all settings made on the Client side so far, don't seem to be necessary. So if you have the same problem, forget everything about:
    - putting the page in your trusted local intranet zone
    - save username and password
    - use the 'runas' command
    - disable antivirus (at least for Avira AntiVir Personal Edition)
    - VPN Client also seems to be ok


    Will hopefully find the time to post my solution today or tomorrow

     

    //Stephan

     

    Tuesday, October 9, 2007 9:52 AM
  •  

    1. Set the Internet Explorer User Authentication to "Automatic logon only in Intranet zone".

    2. Add CRM and report server to Trusted Zones in the IE

    3. Make sure that the "Enable Integrated Windows Authentication" option in the IE is checked

    Thursday, November 1, 2007 8:11 AM
  • Hi all

     

    i have the same problem except i have a domain and my computer is in the domain

    after installation i have the same logon problem and i tried the same as you.

    i opened call with microsoft support.

    Sunday, December 2, 2007 1:23 PM
  •  

    Try this one:

     

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;934243

     

     

    This problem occurs because the FEATURE_SUBDOWNLOAD_LOCKDOWN feature in Internet Explorer 7 prevents the automatic download of files from a Web site for which Outlook is the referrer:

     

    To work around this problem, disable the FEATURE_SUBDOWNLOAD_LOCKDOWN registry subkey. To do this, follow these steps on the computer that is running the Microsoft Dynamics CRM desktop client for Outlook:

    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_SUBDOWNLOAD_LOCKDOWN
    3. Right-click Outlook.exe, and then click Modify.
    4. In the Value data box, type 0, and then click OK.
    5. Exit Registry Editor.

    Sunday, December 2, 2007 8:52 PM
  • Well, I think this is at least one possible problem

     

    Client is not a member of any domain, but of a workgroup

     

    Make the Laptop part of the forest.

    Create the machine account BEFORE you add the laptop to the forest.

    Then VPN in and see if you are prompted for a "Integrated Security" login.

     

    Tuesday, December 4, 2007 8:19 AM
    Moderator
  • Hi Stephan,

    This is exactly the problem I now have, what was the solution?

    Regards,

    Irishtoon
    Tuesday, July 28, 2009 2:28 PM